YouTube is still painful to use on 4.2

Discussion in 'iPad' started by otis123, Nov 11, 2010.

  1. otis123 macrumors 6502a

    May 4, 2006
    YouTube is just ungodly slow, I'm connected to an airport extreme that is in 802.11n 5ghz only mode, and YouTube acts like it's on a dial up connection. My Internet is just fine, frontier (was verizon) fios at 20 down and 5 up. Is this a bug? Or is the wifi antenna really that bad in the iPad? Its like the connection falls asleep or something.
  2. whocaresit macrumors 6502a

    Jul 18, 2010
  3. Crosbie macrumors 6502a


    May 26, 2010
    Brighton, UK
    I find it frustrating that it'll always serve up the largest sized video available, regardless of the bandwidth you're on - so you get sluggish 720p even if you're on a mifi or a bust public broadband, rather than either automatically downgrading the quality or giving you the option to trade off.
  4. gatearray macrumors 65816

    Apr 24, 2010
    Download a speedtest app to test your iPad's connection, but also, does YouTube load OK in Safari on your Mac (or an iPhone) connected to the same Wifi network?

    Personally, my iPad always plays back YouTube videos just fine, either through the YouTube app, or embedded in a webpage. Airport Express with a similar connection speed as yours.
  5. gforce216 macrumors 6502a

    Jun 17, 2009
    The YouTube website designed for the ipad gets the job done for me.
  6. jmann macrumors 604


    Dec 8, 2007
    bump on a log in a hole in the bottom of the sea
    Have you tried changing the DNS numbers? That seemed to speed things up for me.
  7. MFP, Nov 11, 2010
    Last edited: Nov 11, 2010

    MFP macrumors newbie

    Sep 26, 2010
    YouTube is still painful to use on 4.2

    I'm on 3.2 and the videos aren't viewable, I've changed the DNS numbers, still extremely slow, I can't seem to find a way to make it faster. I'm usig a linksys router TL-WR641G / TL-WR642G.
    Any help?

    (I live in South America.)

    Download 0.92 Mbps, Upload 0.34 Mbps.
  8. Codythatsme macrumors member

    Jan 30, 2010
    Ive noticed this and it has ruined my youtube viewing experience. I've put it down to the issue that the youtube app defaults the video quality to the highest which my speed cant handle. On my computer I playback Youtube at 360p but it seems to detault at 720p. It would be fine if I could use safari on the iPad to view YouTube video but html5 doesn't work for videos with ads which is basically every YouTube video I watch...
  9. EssentialParado macrumors 65816

    Feb 17, 2005
    I'm currently staying with my sister and her 100Mbps connection, and YouTube loads excellently. More than excellently, in fact.

    So I think it's something to do with the connection and the way the YouTube app loads videos.

    Furthermore, if I just go to it will load videos much faster. Otherwise, I basically can't use the YouTube app on my iPad at home. Hopefully they'll add a quality switch to the settings, or at least recognize the quality you've got YouTube set at in your profile.
  10. Blakjack macrumors 68000


    Jun 23, 2009
    I hate tapping on my channels and getting a "Youtube not available" message. Wats with that?
  11. Codythatsme macrumors member

    Jan 30, 2010
    I found the mobile youtube workaround however its painfully buggy. I'll be 1 minute into watching a video and it will stop and I have to refresh to start playing again. Even then I have to watch it in 240p whack makes me want to vomit.
  12. tablo13 macrumors 65816


    Jul 29, 2010
    Edmonton, Alberta, Canada
    Maybe the syndication setting in videos.
  13. Gordon Gekko macrumors regular

    Dec 2, 2010
    Wall Street
    Are you using the Builtin App or the Mobile Site version through Safari?
  14. BobHail macrumors 6502a

    May 15, 2009
    Same here than in the other thread. THE BEST web experience!
  15. DuckSoup macrumors 6502a


    Mar 7, 2008
    Upstate Central NY
    I'll admit I am not that savvy on iPad tech, but I've found when my iPad is sluggish (including slow YouTube), that clearing out the items on hold in MultiTasking speeds things up quite considerably.


Share This Page