YouTube loads slow

Discussion in 'iMac' started by WesRocks360, Apr 9, 2013.

  1. WesRocks360 macrumors newbie

    Joined:
    Jun 13, 2012
    #1
    So I've got the brand new iMac and love it. You can see which one it is under in my signature. Im just wondering WHY IS YOUTUBE LOADING SO SLOWLY. I have no issues with my internet everything else runs perfectly but youtube takes ages to load videos. I can use my laptop and it runs it perfects. My brother whos not even near the router can use it perfects on his 2009 iMac. Any suggestions?
     
  2. iF34R macrumors 6502a

    iF34R

    Joined:
    Jul 13, 2011
    Location:
    South Carolina
    #2
    My only issues with youtube is the stuttering in full screen. Weird. Doesn't do it if I'm booting into Windows, on the same machine.
     
  3. Fantola macrumors member

    Joined:
    Oct 12, 2012
    Location:
    Århus, Denmark
    #3
    It's a bug on youtube! have the same problem with all kinds of computers!
     
  4. turtlez macrumors 6502a

    turtlez

    Joined:
    Jun 17, 2012
    #4
    it is adobe flash fault. Switch to google chrome for flash video because Google modify their own version. I switched to chrome purely because youtube was so slow on safari. Chrome is almost instant again. The sooner html5 takes over the better :)
     
  5. RoastingPig macrumors 68000

    RoastingPig

    Joined:
    Jul 23, 2012
    Location:
    SoCal
    #5
    youtube is always broken never rely on that site always assume the site not your computer
     
  6. bmcgrath macrumors 65816

    bmcgrath

    Joined:
    Oct 5, 2006
    Location:
    London, United Kingdom
    #6
    But isn't most of youtube HTML5...? I believe it's actually Safari...
     
  7. senseless macrumors 68000

    senseless

    Joined:
    Apr 23, 2008
    Location:
    Pennsylvania, USA
    #7
    I noticed the slowdown about 2 months ago. Anything over 240p stops and starts, even with high speed Fios.
     
  8. renem111 macrumors newbie

    Joined:
    Apr 9, 2013
    #8
    satrange i have the same problem and also tried differend browsers but nothing helped...:confused:
     
  9. edry.hilario macrumors 6502a

    Joined:
    Aug 1, 2010
  10. Gemütlichkeit macrumors 65816

    Gemütlichkeit

    Joined:
    Nov 17, 2010
    #10
  11. Mbzamg32 macrumors newbie

    Joined:
    Mar 21, 2013
    #11
    Try this...
    Go to system preference select network click on Advance then DNS click on the + sign enter 4.2.2.1 click + again type in 4.2.2.2 click OK then apply.

    Hope this works for you.
     
  12. Imac Sam macrumors 6502

    Imac Sam

    Joined:
    Oct 9, 2011
    Location:
    Harrisonburg, Virginia
    #12
    I put this into my router and so far youtube is working good.
     

    Attached Files:

  13. Imaginethe macrumors regular

    Joined:
    Feb 16, 2012
    Location:
    UK
    #13
    Mine has stuttered every now and again.

    Are people using flash or HTML5 to view Youtube videos? I know I signed up to HTML5 on my pc, but haven't yet on my mac (unless it is an account setting rather than site setting).
     

Share This Page