Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

jozero

macrumors 6502
Original poster
Sep 14, 2009
334
375
The YouTube app on Apple TV 4K is a clown car joke

It flashes to black every ad, & start of every video. The typical video has two 5 second ads at the start. Thats *5* black out flashes every video

It also asks if you want to exit the App for some insane reason when you want to leave it & turns off the tv!!

I have a quality HDMI cable connected to a 2 year old Sony OLED screen, with an AppleTV 4K

Is anyone else experiencing this?
 

Juicy Box

macrumors 604
Sep 23, 2014
6,988
8,178
It is probably your video settings. YT updated the app like 6 months ago, enabling HDR content, but at the cost of the delay in switching.

Try turning off Match Dynamic Range and/or Match Frame Rate in the video settings, and see if that works.
 

-Gonzo-

macrumors 65816
Nov 14, 2015
1,184
584
This is because you have your video setting set to 4KHDR or 4DV, it’s switching because ads are SDR and the majority of videos are also SDR.
Set the video settings to 4KSDR and you won’t have this issue.

Can’t help with the Exit issue as haven’t encountered that one as of yet.
Though you could try just pressing and holding the back button or press the TV button.
 
  • Like
Reactions: mallbritton

sunapple

macrumors 68020
Jul 16, 2013
2,257
3,820
The Netherlands
Definitely sounds like HDR switching, I had that same issue.

But I will say the YouTube app is the only app regularly crashing for me on both tvOS and iOS. That's with the HDR switching resolved. On tvOS it causes freezes that take a couple of minutes before you can try and return to the homescreen and force-quit the app. Super annoying.
 
  • Like
Reactions: jozero

-Gonzo-

macrumors 65816
Nov 14, 2015
1,184
584
Can’t help with the Exit issue as haven’t encountered that one as of yet.
Haha spoke too soon Lol
4909AAFC-2846-4728-A796-015F918F07DA.jpeg


Edit: ok so it doesn’t turn the TV off from what I can see upon selecting exit, it just goes to a blank screen which if you press the TV button will put the picture back on screen.

In future instead of a single press of back, press and hold back instead and it’ll go straight to the Home Screen.
Or press the TV which will either open the ATV app or go to the Home Screen depending on what option you’ve chosen in settings.
 
Last edited:
  • Like
Reactions: mallbritton

jozero

macrumors 6502
Original poster
Sep 14, 2009
334
375
Thanks for the advice

No ad blocking unfortunately

This is because you have your video setting set to 4KHDR or 4DV, it’s switching because ads are SDR and the majority of videos are also SDR. Set the video settings to 4KSDR and you won’t have this issue.

Paid quite a bit for the TV and the AppleTV 4k, does the 4KSDR setting mean it's no longer in HD video, but standard like 480p video? Wouldn't that also affect all the apps that work - Netflix, Prime Video, iTunes movies, etc?


Though you could try just pressing and holding the back button or press the TV button

Did figure that out but its a crazy solve, pretty ingrained after decade of AppleTV use to use the back button

I think the actual solution might just be stop using the TV for YouTube
 

-Gonzo-

macrumors 65816
Nov 14, 2015
1,184
584
Paid quite a bit for the TV and the AppleTV 4k, does the 4KSDR setting mean it's no longer in HD video, but standard like 480p video? Wouldn't that also affect all the apps that work - Netflix, Prime Video, iTunes movies, etc?
No not at all, SDR just means Standard Dynamic Range(No HDR)
Match Dynamic Range automatically takes care of when Dolby Vision or HDR is required depending on the video source.
You were getting the issue while having the UI set to HDR as pretty much 90% of Youtube content as well as ads are SDR so that’s what your TV was switching to which caused the black screen as that’s the TVs Handshake doing it’s thing to match the content being delivered.
 

curnalpanic

macrumors regular
Mar 26, 2008
182
247
It also asks if you want to exit the App for some insane reason when you want to leave it & turns off the tv!!

Anyone found a setting to turn this behavior off? Cancelling my Premium subscription if this stays.
 

jozero

macrumors 6502
Original poster
Sep 14, 2009
334
375
No not at all, SDR just means Standard Dynamic Range(No HDR)
Match Dynamic Range automatically takes care of when Dolby Vision or HDR is required depending on the video source.
You were getting the issue while having the UI set to HDR as pretty much 90% of Youtube content as well as ads are SDR so that’s what your TV was switching to which caused the black screen as that’s the TVs Handshake doing it’s thing to match the content being delivered.

thanks! That at least stopped the insane flickering
 
  • Like
Reactions: -Gonzo-

HDFan

Contributor
Jun 30, 2007
4,702
1,770
it also asks if you want to exit the App for some insane reason when you want to leave it

Not sure how, or why, you are leaving the app. I never leave it. I stop whatever video is playing so I can return to it then hit the TV button which is configured to go to the Apple TV home page. Run another app, then repeat the process to re-select the Youtube app where I can continue with whatever I was watching.
 
  • Haha
Reactions: sorgo

netnothing

macrumors 68040
Mar 13, 2007
3,732
355
NH
So the black screen happens to me at the start and end of videos. I have YT Premium, so no ads. ATV 4K 2017 connected to Denon AVR and Sony TV. I have my ATV set to 4K SDR with Match Range ON and Match Framerate OFF.

Not sure why I get the black screen, since my ATV is always in SDR unless it detects HDR?

Is this an issue with the 2017 ATV4K?

I have confirmed when this black out happens on the ATV, that the resulting video is still being output to my TV in SDR. So I have no idea why I get the blackout at the start and end of videos.

NOTE: I have a Roku 4K that is also hooked up through the same chain and that loads videos without issue.
 
Last edited:

-Gonzo-

macrumors 65816
Nov 14, 2015
1,184
584
So the black screen happens to me at the start and end of videos. I have YT Premium, so no ads. ATV 4K 2017 connected to Denon AVR and Sony TV. I have my ATV set to 4K SDR with Match Range ON and Match Framerate OFF.

Not sure why I get the black screen, since my ATV is always in SDR unless it detects HDR?

Is this an issue with the 2017 ATV4K?

I have confirmed when this black out happens on the ATV, that the resulting video is still being output to my TV in SDR. So I have no idea why I get the blackout at the start and end of videos.

NOTE: I have a Roku 4K that is also hooked up through the same chain and that loads videos without issue.
Are you sure you’re on the latest version of the app?
Go to the App Store and see if it says UPDATE, if it’s not that then I’m not sure why it’s happening.
 

HDFan

Contributor
Jun 30, 2007
4,702
1,770
Maybe to use other apps?

As I noted in post #11 to use another app you just press the tv button 2 times (if configured to go to home screen) which gives you the option to scroll through and select open apps or go to the home screen to open a new app without exiting YouTube.
 

netnothing

macrumors 68040
Mar 13, 2007
3,732
355
NH
Are you sure you’re on the latest version of the app?
Go to the App Store and see if it says UPDATE, if it’s not that then I’m not sure why it’s happening.
Yup, latest version of app and iOS. It's baffling me as to why it's happening as it doesn't make any sense. But I'm pretty sure it started in iOS 16.
 

netnothing

macrumors 68040
Mar 13, 2007
3,732
355
NH
Are you sure you’re on the latest version of the app?
Go to the App Store and see if it says UPDATE, if it’s not that then I’m not sure why it’s happening.

So I think I figured it out, and it's odd.

My ATV was set to:

4K SDR
Chroma 4:2:0
Match Range

So naturally it should never switch or blank the screen in YT since all the videos in YT are SDR. Yet it would blank the screen starting and stopping a video. I noticed when starting, the screen it blank, after a second you start to hear the video and then the video appeared on the screen. Super annoying.

Today I decided to switch my ATV over to 1080p SDR. When I did that, all videos loaded instantly in YT with no blank screen.

I then went back to switch the ATV back to 4K SDR. When I did that and went back into YT, videos loaded instantly still. I was a bit confused until I went back and realized that switching back to 4K SDR also switched the Chroma to 4:4:4.

So I did some testing and sure enough, with 4K SDR and Chroma set to 4:4:4, I don't get the screen blanking in YT. But once I switch back to Chroma 4:2:0, the blanking occurs.

Not sure why this would be? And who is to blame, iOS or YT? For now, since my connection supports it, I'll keep things at 4:4:4.

Hope this helps someone else who may be having this odd issue.
 
Last edited:

SeanChandler

macrumors newbie
Apr 14, 2004
19
0
Calgary, Alberta Canada
So I think I figured it out, and it's odd.

My ATV was set to:

4K SDR
Chroma 4:2:0
Match Range

So naturally it should never switch or blank the screen in YT since all the videos in YT are SDR. Yet it would blank the screen starting and stopping a video. I noticed when starting, the screen it blank, after a second you start to hear the video and then the video appeared on the screen. Super annoying.

Today I decided to switch my ATV over to 1080p SDR. When I did that, all videos loaded instantly in YT with no blank screen.

I then went back to switch the ATV back to 4K SDR. When I did that and went back into YT, videos loaded instantly still. I was a bit confused until I went back and realized that switching back to 4K SDR also switched the Chroma to 4:4:4.

So I did some testing and sure enough, with 4K SDR and Chroma set to 4:4:4, I don't get the screen blanking in YT. But once I switch back to Chroma 4:2:0, the blanking occurs.

Not sure why this would be? And who is to blame, iOS or YT? For now, since my connection supports it, I'll keep things at 4:4:4.

Hope this helps someone else who may be having this odd issue.
This helped me. Thanks for that! My ATV was set to 4K Dolby Atomos. I mostly watch Prime Video and Netflix content. Do I need 4K Dolby for those sources?
 

-Gonzo-

macrumors 65816
Nov 14, 2015
1,184
584
This helped me. Thanks for that! My ATV was set to 4K Dolby Atomos. I mostly watch Prime Video and Netflix content. Do I need 4K Dolby for those sources?
As long as you’ve got Match Dynamic Range turned on then that’ll take care of when those formats are required.
 
Last edited:

jwolf6589

macrumors 601
Dec 15, 2010
4,276
1,144
Colorado
The YouTube app on Apple TV 4K is a clown car joke

It flashes to black every ad, & start of every video. The typical video has two 5 second ads at the start. Thats *5* black out flashes every video

It also asks if you want to exit the App for some insane reason when you want to leave it & turns off the tv!!

I have a quality HDMI cable connected to a 2 year old Sony OLED screen, with an AppleTV 4K

Is anyone else experiencing this?
I am not and use the app often.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.