Youtube problem in Safari

Discussion in 'OS X El Capitan (10.11)' started by Olle F, Dec 9, 2015.

  1. Olle F, Dec 9, 2015
    Last edited: Dec 9, 2015

    Olle F macrumors newbie

    Joined:
    Dec 9, 2015
    #1
    Hey, I have a Safari-specific video playback problem. Specifically, when enlarging into fullscreen, it looks like this: http://i.imgur.com/ianOR1p.jpg

    It started happening a few days ago, I have no idea why. Anyone experienced something similar, or know what to do? So far, I've tried the basic stuff like restarting the computer, cleaning Safari cache and disabling extensions. I'm using a 2015 macbook pro 13".
     
  2. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #2
    Happening to me too since updating to 10.11.2. The only solution I've found so far is to spam click the video until it eventually fullscreens correctly.
     
  3. JaseUK macrumors newbie

    Joined:
    Dec 10, 2015
    #3
    I have the same problem and it's really annoying. I hope it gets fixed as I've had to install Chrome as my browser as a result.
     
  4. silvetti macrumors 6502a

    silvetti

    Joined:
    Nov 24, 2011
    Location:
    Poland
    #5
    Same issue here :(

    Also with twitch videos but that's happening before as well.

    I don't have Adobe Flash installed though.
     
  5. Tastydirt macrumors member

    Joined:
    Sep 25, 2009
    #6
    I found that if you double click the video, slow enough so it pauses the video between clicks, but fast enough so it still registers it as a double click, fullscreen works properly.

    Can't explain why but that seems to fix it for now.
     
  6. Tastydirt macrumors member

    Joined:
    Sep 25, 2009
    #7
    Actually a better way is to fullscreen the video normally, the pause the video and resume it. That also seems to fix the bug.
     
  7. ParanoidDroid, Dec 10, 2015
    Last edited: Dec 10, 2015

    ParanoidDroid macrumors 6502

    ParanoidDroid

    Joined:
    Sep 15, 2013
    Location:
    Venusville, Mars
    #8
    Screen Shot 2015-12-11 at 03.53.47.png I'm having difficulties watching YouTube videos in full screen mode with Safari as well – since 10.11.2 update. Every time I click full screen button in the player I see this (attached image).

    Has no beta tester every watched a video on YouTube? I find that very hard to believe!

    EDIT: What if it's a YouTube bug? Perhaps, the YouTube player doesn't recognize the new Safari version correctly?
     
  8. AliMacs macrumors 6502

    Joined:
    Oct 8, 2014
    #9
    I too have the same bug - but it's easy to fix - just opt out of html5 from youtube - quit the safari browser, then go and re-enable html5 and it seems to fix it so far for me.
     
  9. Tiptizzle macrumors 6502

    Joined:
    Apr 22, 2011
    #10
    Can you tell us how to do that? I've not had any luck finding it myself.
     
  10. Ethan H 1234 macrumors newbie

    Joined:
    Jul 6, 2015
    #11
    Also having this problem. I've noticed that the problem only occurs if your safari window covers the majority/all of your screen. When it's a small window, youtube seems to go to full-screen as normal. Would still like a solution as browsing via tiny windows isn't ideal :(
     
  11. AliMacs macrumors 6502

    Joined:
    Oct 8, 2014
    #12
    Guys - you can't disable the stupid html5 by default in el capitan/safari version 8.0+

    Just enable DEVELOPER MODE , then under DEVELOP -> USER AGENT - > OTHER - find the safari string with 9.0.2 (if you are using el capitan), then change it to anything but 8.0.2 - it will allow you to disable or re-enable.

    I believe this is an issue with hardware because using the same el capitan 10.11.2 on my older 2011 i7 17" mbp, it doesn't exhibit this problem at all. Only on my newer mbpr does this problem occur.

    Link: https://www.youtube.com/html5
     
  12. Tiptizzle macrumors 6502

    Joined:
    Apr 22, 2011
    #13
    Having the problem on a 2011 15" I7 MBP here. My wife's 13" 2015 MBA does not seem to have the problem.
     
  13. Grassgreen macrumors regular

    Joined:
    Jun 2, 2013
  14. Jess13 Suspended

    Jess13

    Joined:
    Nov 3, 2013
    #15
    I was going to post about this earlier, but I found a temporary fix :)

    Once you've entered into full screen, click the playbar, i.e. its start:

    MR.gif
     

Share This Page