YouTube takes forever on wifi

Discussion in 'iPhone' started by jcorbin, Feb 16, 2012.

  1. jcorbin macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    D.C.
    #1
    For whatever reason YouTube takes forever to load videos on wifi. On 3G its fine. Everything else loads fine on wifi
     
  2. DBZmusicboy01 macrumors 6502a

    Joined:
    Sep 30, 2011
    #2
    YouTube is having lots of problems lately this week...I bet if you ask everyone else they will agree with me
    it's not the same like it was last month.
     
  3. jcorbin thread starter macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    D.C.
  4. ModestMoo macrumors 6502

    ModestMoo

    Joined:
    Oct 2, 2011
    Location:
    Cambridge, UK
    #4
    I have the same problems like for an a few months now. Seriously. It takes faster on 3G which is like 1.5MB/s download and it takes baaaare longer on my Wi-Fi which is like 30MB/s...
     
  5. james92se macrumors 6502a

    Joined:
    Jun 21, 2010
    Location:
    Dallas, TX
    #5
    I've noticed this too, but for me this has been going on for months now.

    I just assumed it was just my wifi connection, which isn't terribly fast by today's standards (~12 mbps), but should still be fast enough to use YouTube fairly effortlessly, but instead it takes FOREVER to load anything. Even short 1-2 minute videos take forever, and by forever, I mean literally a good 4-5 minutes.
     
  6. rockyroad55 macrumors 601

    rockyroad55

    Joined:
    Jul 14, 2010
    Location:
    Phila, PA
    #6
    Wow I thought I was the only one. 3G breezes with no issue. Wifi hiccups.
     
  7. LapsangSouchong macrumors 65816

    LapsangSouchong

    Joined:
    Jul 15, 2010
    Location:
    the burrows
    #7
    I believe, in the end, this was the root of my husbands huge data gulp. I think it was so bad on wifi it switched to 3G and he didn't notice.
     

Share This Page