YouTube Video's choppy

Discussion in 'iMac' started by DougY, Dec 21, 2011.

  1. DougY macrumors 6502

    Joined:
    Dec 2, 2009
    #1
    My iMac, '09, 3.06gig Intel Core 2 Duo, Memory 12 gig.
    Whenever I play YouTube Video's, they are choppy and freeze frequently.
    My software is up to date.
    What can I do to solve this problem?
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Which browser do you use?
    Flash is up-to-date I suppose?

    ______________________________________________________
    Have a look at Activity Monitor (Applications / Utilities /) and select All Processes and sort by CPU to see what the culprit may be.
    Also check the "System Memory" tab to see what your "Page ins:", "Page outs:" and "Swap used:" are.

    image below uses sorting by CPU as an example
    [​IMG]
    Further reading:
    ______________________________________________________​
     
  3. kboyle65 macrumors newbie

    Joined:
    Dec 21, 2011
    Location:
    Chicago, Illinois
    #3
    I have this problem about once a month. I usually just reset my airport extreme and/or restart my computer. This almost always works for me.
     
  4. apunkrockmonk macrumors 6502a

    apunkrockmonk

    Joined:
    Nov 20, 2005
    Location:
    Rochester, NY
    #4
    The MacBook in my signature has stuttering issues with YouTube in safari. Chrome does not give me the same problem.
     
  5. Pachang macrumors regular

    Joined:
    Dec 17, 2009
    #5
    I can't say for sure there is probably too much flash open in other windows. Try installing something that blocks flash ilke this:

    http://hoyois.github.com/safariextensions/clicktoplugin/
     

Share This Page