Youtube videos not working on Safari?

Discussion in 'OS X Yosemite (10.10)' started by Hustler1337, Oct 22, 2014.

  1. Hustler1337 macrumors 68000

    Hustler1337

    Joined:
    Dec 23, 2010
    Location:
    London, UK
    #1
    Hi guys,

    Just wondering if anyone else has been having trouble watching Youtube videos on their website using Safari?

    A lot of the time when playing a Youtube video, the video appears as a black screen, though audio is audible. Using HTML5.

    Is anyone else having the same issues?
     
  2. Supermunki macrumors member

    Supermunki

    Joined:
    Jul 10, 2008
    Location:
    New Zealand
    #2
    Copypasta from a reply I posted to someone else:
    I have the same problem. It seems to be related to mp4 video, since it happens on every browser and even in quicktime. It doesn't even seem to be performance related. Audio plays and I get no video on YouTube, but if I move the mouse over the video it starts to play the video back but with a lot of choppiness.

    I noticed that toggling the overlay temporarily causes it to play smoothly, and that franticly waving the mouse over a YouTube video to constantly toggle the overlay causes the video to play perfectly. Obviously not an ideal solution, and it only works on YouTube anyway... Would be nice to have a solution to this.

    Tricking YouTube into using flash lets me watch videos smoothly, but not being able to watch html5 video is a hell of a pain in the ass.
     
  3. benji888 macrumors 68000

    benji888

    Joined:
    Sep 27, 2006
    Location:
    United States
    #3
    How do you even get youtube to play HTML5 on safari/yosemite at all? I had to download flash :mad::mad::mad: I don't get this, if half-arsed iOS can play HTML5 1080p video, why can't my mac?
     
  4. Sym0 macrumors 6502

    Sym0

    Joined:
    Jun 6, 2013
    #4
    Working fine here but I may have my youtube page set to Flash - but I noticed now I have to hit the back button TWICE to go back one page now on youtube, this sin't normal.
     
  5. benji888 macrumors 68000

    benji888

    Joined:
    Sep 27, 2006
    Location:
    United States
    #5
    I tried to find a setting within youtube for flash/HTML5, but, can't find it? :confused:
     
  6. GrumpyTrucker macrumors 6502a

    Joined:
    Jun 1, 2014
    #6
    Good point. Annoys me no end that I can watch YouTube videos on Facebook and other places quite happily from iOS but OS X versions insists I need Flash. I refuse to install Flash on my system as a plugin and this inability for websites to allow Safari to default to HTML5 is the only reason I have Chrome installed.
     
  7. Sym0 macrumors 6502

    Sym0

    Joined:
    Jun 6, 2013
    #7
    You used to be able to set preference but I think it is now forced, if your browser supports it then that is what it uses from now on. I can see there is a plugin for chrome to force flash but that's no use for safari.

    Might just have to stick with it and complain until its fixed.
     

Share This Page