Youtube weird problem

Discussion in 'MacBook Air' started by Labhras, May 13, 2015.

  1. Labhras macrumors regular

    Joined:
    Aug 17, 2014
    #1
    Hi all, I'm on a 13.3 2014 MBA.
    Recently it seems that whenever I want to watch a video on youtube from my laptop, the controls (play, rewind/fast forward, full screen, and video quality) aren't seen at all, I can't stop the video, the keyboard controls (spacebar or k to stop the video) are completely ineffective.
    When the video is finished, suddenly they reappear, but all the same I can't seem to be able to do anything with them.

    What on earth is going on in your opinion?
    Btw, I'm using Safari as browser.
     
  2. michaelsviews macrumors 65816

    Joined:
    Sep 25, 2007
    Location:
    New England
    #2
    Are you running any additional extensions ? Altering the browsers functionality in any way?
     
  3. Labhras thread starter macrumors regular

    Joined:
    Aug 17, 2014
    #3
    The only additions I have are

    - Youtube5
    - Evernote WebClipper
    - AdBlock

    I've heard that AdBlock was causing some problem and I've tried disabling it but nothing changed. It's a recent problem, and I had those additions when Youtube worked just fine.
     
  4. michaelsviews macrumors 65816

    Joined:
    Sep 25, 2007
    Location:
    New England
    #4
    I experienced a video not playing but the sound was there, hit Ctrl - R to reload and then the video show's up. That happened with No extension's running just a 15" MBP straight out of the box.
     
  5. Labhras thread starter macrumors regular

    Joined:
    Aug 17, 2014
    #5
    Problem is the video plays perfectly - but I can't use any of the controls to stop, rewind of play forward. Can't use the fullscreen mode either. Youtube controls don't appear and using the keyboard doesn't work either.
    I've reloaded the page, rebooted my laptop, and still the problem remains.
     
  6. Orka macrumors regular

    Joined:
    Dec 24, 2012
    Location:
    Moscow, Russia
    #6
    I have same issue, you have to switch Youtube5 extension off.

    Youtube changed their API recently so most apps (ios apps included) don't work with it properly, and some probably will never will.
     
  7. Labhras thread starter macrumors regular

    Joined:
    Aug 17, 2014
    #7
    Just tried, thank you so much! Do you know if there is any extension like youtube5 working? It was so easy for youtube videos...
     

Share This Page