Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

prairiefire

macrumors member
Original poster
Jun 8, 2007
62
0
MacBook Pro
Safari 5.1.5
Lion 10.7.3

YouTube videos will not play in Safari unless I diddle with the settings -- resolution of the video or size of the window.

When I click a video, I get a black window with the rotating circle. It's not buffering -- I have very fast Internet -- it will not play until I diddle.

The same video's play, immediately, in Chrome and Firefox.

Any ideas?

Thanks.

sjh

PS. I think this happened after a Flash upgrade from Software Upgrade. I've gone to Adobe's site and installed the latest Flash. Since it works in other browsers, I don't see this as a Flash issue. Am I wrong?
 

blatopilot

macrumors regular
Sep 24, 2011
149
0
MacBook Pro
Safari 5.1.5
Lion 10.7.3

YouTube videos will not play in Safari unless I diddle with the settings -- resolution of the video or size of the window.

When I click a video, I get a black window with the rotating circle. It's not buffering -- I have very fast Internet -- it will not play until I diddle.

The same video's play, immediately, in Chrome and Firefox.

Any ideas?

Thanks.

sjh

PS. I think this happened after a Flash upgrade from Software Upgrade. I've gone to Adobe's site and installed the latest Flash. Since it works in other browsers, I don't see this as a Flash issue. Am I wrong?

Chrome has built in flash, but Firefox does not, so you are probably correct.

Did you try reseting Safari from the menu? Give that a go and see if anything changes.

You could also try using html5 to isolate if its flash or not

http://www.youtube.com/html5

If you get normal playback it probably is flash.
 

prairiefire

macrumors member
Original poster
Jun 8, 2007
62
0
Disabled HTML5 Trial and It Works

Blatopilot --thanks for the response.

I did the opposite. I went to the site you posted and learned about the HTML5 trial. I was "enrolled" in the trial.

So, I turned it off and now YouTube works.

I'll turn it back on, when I have time, to see what that does.

Thank you.

Steve
 

fisherking

macrumors G3
Jul 16, 2010
8,651
3,054
ny somewhere
having the same problem; audio starts, video stutters...
i close the page and the audio plays a little still.

so i just did the opposite; i enrolled in the html5 trial, and will see what changes.

meanwhile, will follow this thread, see if anyone else is having the problem
(or has a fix)
 

petekjohnson

macrumors newbie
May 24, 2012
24
15
Springfield, MO
Safari 32-bit mode

I've been having the same problem as described here by everyone else: Youtube videos will not play in Safari. Other sites play video just fine, and other browsers (i.e. Chrome) play the same Youtube videos just fine.

I tried uninstalling and reinstalling the Flash plugin. I tried resetting the Flash Player by deleting all of its stored data under the Local Storage and Advanced sections of the Flash Player preference pane. I tried forcing Youtube to play HTML5 versions of the videos using ClickToFlash. Nothing seemed to work.

Then I read on another forum that I should put Safari into 32-bit mode (In Finder, Get Info on Safari icon and check the 32-bit mode box) and that this would fix the problem. I attempted to do this, and to my surprise, Safari was ALREADY in 32-bit mode. I unchecked the 32-bit mode box and restarted Safari (now in its native 64-bit mode, presumably) and suddenly Youtube is working fine again.
 

unblocktheplane

macrumors newbie
Nov 4, 2007
5
0
None of the above

MacBook Pro 2.33 GHz
Safari 5.1.7
Mac OS X 10.6.8

Neither enabling or refuting HTML5 in YouTube nor checking or unchecking 32-bit mode in Safari work for me.
 

c13

macrumors newbie
Nov 7, 2013
1
0
youtube not playing try

try installing opera browser it worked for me :):apple:
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.