You've already purchased this but it hasn't been downloaded....."

Discussion in 'iPad' started by Kahnyl, Apr 24, 2010.

  1. Kahnyl macrumors 68000

    Feb 2, 2009
    "You've already purchased this but it hasn't been downloaded. To download it, go to Purchases and tap Redownload."

    I bought a book earlier but the download stopped a fifth of the way through. When I went back to the store and clicked purchase again I got that message. So I went to Purchases and tapped on Redownload. I got the same message again!

    I just know it's because there's a partially downloaded file somewhere and that if I deleted that this would probably be fixed but obviously I can't do that yet.

    Has anyone run into this problem and know of a solution besides rebooted and resyncing, which didn't work?
  2. BaronStein macrumors regular

    Feb 11, 2010
    Just restart your iPad. And check whether the app is downloading. If it says paused, then tap it. Or, if you can't find, try to download it from app store again.

    Sometimes, I have similar problems on my iPad too. Restarting usually make things work...
  3. Kahnyl thread starter macrumors 68000

    Feb 2, 2009
    It's an iBook.

    It's not on my bookshelf except for the brief moment between tapping it in purchases, the shelf spinning around and me getting the message. I've tried uninstalling iBooks but if there's corrupt data somewhere that isn't helping because when I re-install iBooks all my books show up without me reloading them from iTunes. Even ones I haven't bought from Apple, so it's not like they're being redownloaded.

    So for some reason the iPad isn't deleting that app's data after it's gone.

    EDIT: Got this (second) reply from support. Crappy solution.

    "Heather here again, and I am so sorry that you are still unable to download this book.

    I am just letting you know that since you have been unable to download this book, I have removed this from your download queue for you, and refunded your purchase in the amount of $7.99.

    The credit will be posted to your account in three to five business days.

    Please wait at least two weeks before repurchasing this title. This will give us time to investigate the issue and make any corrections that may be necessary."

    EDIT 2:

    I tried the download again, and it worked.

Share This Page