Zagg Invisible Shield doesn't stay in place.

Discussion in 'iPhone Accessories' started by Brandonsc, Jul 11, 2010.

  1. Brandonsc macrumors member

    Joined:
    Jul 12, 2008
    #1
    I'm wondering if I got a defective IS or is it the iPhone 4? I installed my Invisible Shield over 1 week ago. I noticed that it's almost like it's not set all the way. I can still slide the shield around. It's almost like there is still the installation solution under the shield allowing it to move. I'm wondering if the shield just doesn't adhere very well to the glass. Anyone else notice this?

    EDIT: If you are having a problem with your IS, please note if it is the screen shield, rear shield, or both.
     
  2. nyisles84 macrumors regular

    Joined:
    Feb 4, 2008
    #2
    I've noticed this too. Been 8 days since I let it set for 15hours I cam still manipulate it and slide it a bit. I just ordered in a replacement.
     
  3. iphoneguy123 macrumors regular

    Joined:
    Jun 23, 2010
    #3
    I have the same problem, especially in the heat. My install is perfect no bubbles or anything.

    The IS is generally a poor product. I think that's just the way it is.
     
  4. Brandonsc thread starter macrumors member

    Joined:
    Jul 12, 2008
    #4
    I was afraid you'd say that. It sounds like the glass on the glass doesn't allow the shield to stick very well.
     
  5. iTerpRunner macrumors newbie

    Joined:
    Jun 14, 2010
    #5
    Sgpstore.com Japan-made Body Shield

    Hi,

    You may want to check this out instead:

    http://www.sgpstore.com/product_info.php/cPath/21_28_89/products_id/1452

    I used to use invisible shield but my brother turned me onto this and it is amazing. The feel of the shield is not as sticky as the Invisible Shield and I haven't had any issues at all with the material sliding.:D
     
  6. nunes013 macrumors 65816

    nunes013

    Joined:
    May 24, 2010
    Location:
    Connecticut
    #6
    mine has already come off completely, i ordered a replacement, has anyone noticed that bought it before the iphone 4 came out that it was a little bigger than the phone, hopefully now that they have one it will fit better
     
  7. dennisjr631 macrumors 6502

    Joined:
    Aug 15, 2009
    #7
    I've had mine installed for a week and I don't have any problem. Mine dosent move at all.
     
  8. Brandonsc thread starter macrumors member

    Joined:
    Jul 12, 2008
    #8
    I think your right. I was outside in the heat when I noticed it. Mine slide slighty off the phone and now has pocket lint stuck to it.
     
  9. neworleans-7 macrumors regular

    neworleans-7

    Joined:
    May 18, 2008
    #9
    Hmm...personally I don't have that problem at all. I got my IS the weekend after the release of the iPhone 4 and it doesn't move or anything. The only problem I have is that I can't put any real case on my phone or the front screen protector will come up unless I'm extremely careful. But then again that's not a case problem.
     
  10. Jordan921 macrumors 68040

    Jordan921

    Joined:
    Jul 7, 2010
    Location:
    Bay Area
    #10
    I have Bestskinsever on mine and it's all good. Not zaggs but same thing.
     
  11. liamkp macrumors 68020

    liamkp

    Joined:
    May 29, 2010
    #11
    I prefer BodyGuardz. But $7.99 vs. $24.99? Guess who wins!
     
  12. Full of Win macrumors 68030

    Full of Win

    Joined:
    Nov 22, 2007
    Location:
    Ask Apple
    #12
    Me too. Noticed this Friday night, the top part is coming off. Had an IS on a iPod 5G for almost 5 years and still on there strong. Was on my OmniFocus to call them tomorrow about this.

    Odd thing is that I used GPS Drive for the first time an hour before I noticed this happening. This app really makes the back hot, so I'd be willing to bet that had something to do with it.
     
  13. VSMacOne macrumors 601

    VSMacOne

    Joined:
    Oct 18, 2008
    #13
    Same thing happening with mine and my girlfriends. I put them both on there and left them to cure for a good while.
    I've noticed that the back slides around more than the front which makes sense since the glass is not the same on the front and the back.
     
  14. littleluna macrumors member

    Joined:
    Jul 6, 2010
    #14
    I also have BSE and no problems at all. I've been using their products for a year or two now, and never got the peeling problem. I love BSE!! I have the iP4 skin since 6/30 and it still looks good.
     
  15. gravytrain84 macrumors 6502a

    gravytrain84

    Joined:
    Jun 24, 2010
    Location:
    LA
    #15
    I'm done with zagg for life... I put one of my IP4 and even after waiting 24 hr it peeled up terribly!!
     
  16. Brandonsc thread starter macrumors member

    Joined:
    Jul 12, 2008
    #16
    I think you make a good point. My screen shield is fine, no problems. Its the piece on the back that isn't staying in place. It must have something to do with a coating on the glass or something.
     
  17. the2j macrumors member

    the2j

    Joined:
    Oct 24, 2008
    Location:
    Davis, CA
    #17
    took mine back to best buy today for the same reason.

    I had the "wet" version, and on the way home I picked up the "dry" version.

    can anyone tell me the difference between the two. Should I even waste my time opening and installing the new one ?
     
  18. boshii macrumors 68040

    boshii

    Joined:
    Jul 6, 2008
    Location:
    Atlanta, GA
    #18
    i don't have it installed on the front but the one on the back does slide around a good bit.
     
  19. tekchic macrumors 65816

    tekchic

    Joined:
    Apr 19, 2010
    Location:
    Phoenix, AZ
    #19
    I've had one installed for nearly two weeks and it doesn't move. I do have a bumper around it that's covering the edges, however, so I wonder if that's why?
     
  20. VSMacOne macrumors 601

    VSMacOne

    Joined:
    Oct 18, 2008
    #20
    Both mine and my girlfriend's are doing the same thing. It's worse on the back than on the front.
    I had no idea there was a DRY IS.. anybody have any experience with that? Otherwise, I might be returning this.
     
  21. boshii macrumors 68040

    boshii

    Joined:
    Jul 6, 2008
    Location:
    Atlanta, GA
    #21
    if you try to move it, it will

    it won't do it on its own
     
  22. kr00k322 macrumors 6502

    Joined:
    Jun 20, 2010
    Location:
    Long Beach, CA
    #22
    I had the same problem with it sliding the first time I put it on and it was because I had the phone on still and it heated it up and stopped it from drying. The 2nd time I turned it off for a good 2hrs or so and now it hasn't moved at all.
     
  23. Mx356 macrumors member

    Mx356

    Joined:
    Oct 13, 2008
    #23
    Mine hasn't been too good either. I put one on when I got my phone the day of release and it was good for about a week and then started peeling. Got a replacement in and it started peeling in a couple days. I've applied these to phones, computers, and ipods for awhile so I know its not an installation error. Seems like they aren't sticking to the glass well or they got the product out to fast and its lacking the quality. I plan on ordering one from a new company but not sure what brand I want to try now.
     
  24. Sgt93 macrumors 6502a

    Sgt93

    Joined:
    Jan 31, 2010
    Location:
    Retired'ville
    #24
    I just peeled the front off yesterday as the Zagg is junk. Thumbs down to them and to think I lost $30 on it:mad:
     
  25. Cynikal.Mindset macrumors 6502a

    Joined:
    Jul 6, 2010
    Location:
    Guelph ON, Canada
    #25
    your solutions might have contained too much soap and since the soap doesnt dry and evaporate like water it will stop the glue on the shield to stick on the glass allowing it to slide and move. This could be a problem from zagg if they supply the juice or user error if u make your own solution.
     

Share This Page