zip password recovery

MacMarvin

macrumors member
Jun 29, 2006
30
0
tim86 said:
I forgot the password to an old zip file that I had password protected. Does anyone know of a password recovery utility that works on OSX...?
http://www.goof.com/pcg/marc/fcrackzip.html
http://fcrackzip.darwinports.com/

I've tried it on OS X and it does work. However, if you have chosen a long password and have no idea what it is, it could take a very long time even on a fast machine. The best way is to have a rough idea of what it was and use wildcards or a dictionary attack.
 

tim86

macrumors newbie
Original poster
Do I need to install 'Darwin ports' in order to use the Zip Crack software...? I'm a Mac newbie and have no idea what a ‘Darwin port’ is, much less should I be installing one on my system.

Does anyone know of a standard app that that works without using a command prompt…?
 

MacMarvin

macrumors member
Jun 29, 2006
30
0
tim86 said:
Do I need to install 'Darwin ports' in order to use the Zip Crack software...? I'm a Mac newbie and have no idea what a ‘Darwin port’ is, much less should I be installing one on my system.
Darwin is the name of the core system that OS X is based on. A Darwin port is just a binary that is compiled to run with OS X. The Darwin ports software is just an easy way to access lots of this type of software. There is a program called fink that does a similar thing. They come from the unix side of OS X.

tim86 said:
Does anyone know of a standard app that that works without using a command prompt…?
I don't know of any for the Mac. If you had an Intel Mac, you could run a GUI password recovery program through Windows + Parallels.

I managed to compile a version of fcrackzip for you here:

http://rapidshare.de/files/30959378/fcrackzip.zip.html

That way you don't need to install anything, just unzip the file. It contains the fcrackzip program, the instructions for the tool and an example zip file.

The example zip file that comes with it called noradi.zip. I was going to rename it because odd sounding files always look suspicious but that's what the original developer called it.

All you do is type cd into the terminal and drag in the fcrackzip folder that appeared when you unzip the file and hit return.
This takes you to the folder so that you can execute the program.
Then type
./fcrackzip -b -c a -p aaaaaa noradi.zip

(-b = brute force attack
-c a = use the character set of all lower case a-z
-p aaaaaa = starting password. If you knew the password started with tof for toffee, you might use tofaaa)

This will start guessing all 6 letter passwords (hence the 6 letter a's) against noradi.zip. It finds what are know as false positives - possible passwords which aren't correct. You will know the right one when you see it though.

You can then use this password to extract your file. Bear in mind, this process is not easy and a GUI tool will not make it easy. It is difficult for an obvious reason. This is why it really helps if you have a rough idea of the characters you used and the number of characters. If it's more than 7 or 8 characters and you have absolutely no idea what the password is, I'd be inclined to forget it because it will take way too long.
 

Webber

macrumors newbie
Apr 20, 2008
2
0
I keep on getting the following message:

-bash: cd/Users/myname/Desktop/fcrackzip_directory/: No such file or directory

This appears after dropping the directory on Terminal
 

Hefbe

macrumors newbie
Jan 1, 2009
1
0
I keep on getting the following message:

-bash: cd/Users/myname/Desktop/fcrackzip_directory/: No such file or directory

This appears after dropping the directory on Terminal
Just put a space after the «change directoy» command like so;

cd /Users/myname/Desktop/fcrackzip_directory/

Cheers
 

ZZwka

macrumors newbie
May 5, 2009
1
0
Later Help

I am having trouble with this...
I know its a late reply, but i am having trouble with installing fcrackzip.

I installed darwinports, and i went to put in the code and i got this:

"brad-franks-imac:~ bradfrank$ cd /opt/local/bin/portslocation/dports/fcrackzip
-bash: cd: /opt/local/bin/portslocation/dports/fcrackzip: No such file or directory"

Now maybe im doing this wrong, or something, but i have no clue...
Please help!
 

jamesp11

macrumors newbie
Mar 14, 2011
1
0
I forgot the password to an old zip file that I had password protected. Does anyone know of a password recovery utility that works on OSX...?
you have forget your zip file password and looking for the password recovery utility then try stellar phoenix zip recovery utility. This software is compatible with Mac OSX. Try this; it may solve your problem.:apple:
 

jjon

macrumors newbie
Jun 13, 2011
1
0
i got a problem, too.

i downloaded the fcrackzip-folder from http://oldhome.schmorp.de/marc/fcrackzip.html and unzipped it.
I then went to the file via the cd-command and by dragging the folder in the terminal.
I get the following output.

MAC-Name:fcrackzip-1.0 myname$

I then tried several versions to crack the sample file included:
MAC-Name:fcrackzip-1.0 myname$ fcrackzip -b -c aaaaaa noradi.zip
MAC-Name:fcrackzip-1.0 myname$ fcrackzip -b -c aaaaaa ./noradi.zip
MAC-Name:fcrackzip-1.0 myname$ ./fcrackzip -b -c aaaaaa noradi.zip
MAC-Name:fcrackzip-1.0 myname$ ./fcrackzip -b -c aaaaaa ./noradi.zip

I always get:
-bash: ./fcrackzip: No such file or directory

But in the folder is a file named "fcrackzip.1".
When I type

MAC-Name:fcrackzip-1.0 myname$ ./fcrackzip.1 -b -c aaaaaa noradi.zip
or
MAC-Name:fcrackzip-1.0 myname$ ./fcrackzip.1 -b -c aaaaaa ./noradi.zip

I get
-bash: ./fcrackzip.1: Permission denied

Could anyone help me? What am I doing wrong?
Thx a lot.
 

avajda

macrumors newbie
Aug 14, 2012
1
0
You need to download Xcode to get the backend parts that are needed (if using XCode from App Store then need to also install the "Command Line Tools" component from within Xcode Preferences->Downloads).

Then go to the Terminal window:

1) ./configure
2) make
3) ./fcrackzip ...
4) wait for results