Ziphone 2.0 and anysim

Discussion in 'Jailbreaks and iOS Hacks' started by kabutosan, Feb 14, 2008.

  1. kabutosan macrumors newbie

    Joined:
    Feb 14, 2008
    #1
    Hi all,
    just a question...

    If I unlock my iphone with ziphone 2.0... I need to use anysim anymore??

    TKS.
    Kabu
     
  2. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
  3. kabutosan thread starter macrumors newbie

    Joined:
    Feb 14, 2008
    #3
    this is a great news!!! so, to use all iphone functionality i only need to run the ziphone 2.0?!?!

    This is amazing...

    kabu
     
  4. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
    #4
    That's correct.

    If your bootloader is v3.9, then you need ZiPhone v2.0.

    If you have a v4.6 bootloader you might wish to use ZiPhone v1.0 or 1.1 to preserve future upgrade capabilities.

    See this thread for all the gory details:

    http://forums.macrumors.com/showthread.php?t=433827
     
  5. kabutosan thread starter macrumors newbie

    Joined:
    Feb 14, 2008
    #5
    Ok, thanks for the link...

    But another annoying question.., I bought a brand-new 16GB iphone... can I check the bootloader version before activation?

    I know, I'm really newbie... I'll read more about it... :)

    thx.
    kabu
     
  6. Sergeij2000 macrumors newbie

    Joined:
    Feb 14, 2008
    Location:
    Berlin
    #6
    All 16G phones come with BL4.6! You can use ZiPhone 2.0 with all types of bootloader. For your 16G with BL4.6 or any other phone with BL3.9 use ZiPhone -j -a -u -v. Use the -v (verbose) option, because it seems to cure the apple logo problem.

    Your BL4.6 phone will be jailbreaked, activated and unlocked - but with downgraded modem fw 04.02.13_G (there is no unlock available yet for BL4.6 and modem fw 04.03.13_G)! As a consequence locate-me in Maps.app won't work. As a workaround you can install LocateMe from the installer and run it once _EACH_ time your phone has been rebooted.

    A full unlock with modem firmware 04.03.13_G is only possible, if the bootloader of your phone is version 3.9. ZiPhone -u -v is downgrading the bootloader and unlocking modem fw 04.03.12_G. I did it with a brandnew 16G iPhone and it was working like charme.

    Bottomline: ZiPhone 2.0 can do a jailbreak, activation and unlock for BL3.9 and BL4.6.

    cu/

    Sergeij
     
  7. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
    #7
  8. kabutosan thread starter macrumors newbie

    Joined:
    Feb 14, 2008
    #8
    If I've the bootloader BL4.6... Can I downgrade the bootloader to ver. 3.9 after the unlock procedure? Or, I'll do it before?

    kabu
     
  9. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
    #9
    ZiPhone v2.0 will downgrade your bootloader in the process of unlocking. However this may not be reversable, which is why I have linked the relevant post for your own consideration - you might want to reverse it in the future.

    ZiPhone v1.0 & v1.1 unlock your phone without downgrading the bootloader. The only drawback is that the Maps locate me function doesn't work without a workaround (running Navizon each time you reboot the phone, for example).

    I recommend the later, but that's just me.
     
  10. Sergeij2000 macrumors newbie

    Joined:
    Feb 14, 2008
    Location:
    Berlin
    #10
    Yes, you can unlock on BL4.6 and stay with the result - or you can downgrade to BL3.9 and unlock. It's your decision. But everything can be done by ZiPhone 2.0. If you're not sure what to do, just ziphone -j -a -u -v. This will jailbreak-activate-unlock your phone but you'll keep BL4.6.

    cu/

    Sergeij
     
  11. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
    #11
    That's right. You have to use the -b option to force the bootloader downgrade. Sorry for the misinformation.

    Do as Sergeij says!
     
  12. Sergeij2000 macrumors newbie

    Joined:
    Feb 14, 2008
    Location:
    Berlin
    #12
    You don't need ZiPhone 1.x anymore! ZiPhone 2.0 can do all the things the previous versions did _PLUS_ downgrading the BL and unlocking the bb with fw version 04.03.13_G:

    1) ZiPhone -j -a -u -v keeps the current BL (either 3.9 or 4.6) and jailbreaks-activates-unlocks the iPhone - but the modem fw will be 04.02.13_G after this process if BL4.6 is on the phone.

    2) ZiPhone -j -a -b -v Jailbreaks-activates and downgrades BL4.6 to BL3.9, upgrades the modem fw to 04.03.13_G and unlocks the baseband.

    People who are not sure what they want - and who want to stay on BL4.6 should use 1). People, who want the full functionality of 1.1.3 should use 2).

    cu/

    Sergeij
     
  13. kabutosan thread starter macrumors newbie

    Joined:
    Feb 14, 2008
    #13
    Great! Thanks to all guys! I'll try the second option as soon as possible.

    Kabu
     
  14. gkarris macrumors 604

    gkarris

    Joined:
    Dec 31, 2004
    Location:
    "No escape from Reality..."
    #14
    Just a quick question - I don't get it.

    Just hook your iPhone to a windows machine and run this program and, boom, everything is done?
     
  15. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
  16. annivas macrumors newbie

    Joined:
    Feb 15, 2008
    #16
    Hi, I have succesfuly activated, jailbroke and unlocked my 1.1.2 OTB. I had updated its firmware to 1.1.3 before I did that. The bootloader is 4.6.

    Right now, I am the happy owner of a 1.1.3 iPhone with 04.02.13_G modem firmware.

    I would be even happier though if I some things would act as they should, ie. the Locate Me button in the Maps app. I even tried to install the LocateMe app but it crashes upon launch.

    I am not too sure if there are other things that don't act as they should, YouTube seems to work just fine
     
  17. Sergeij2000 macrumors newbie

    Joined:
    Feb 14, 2008
    Location:
    Berlin
    #17
    LocateMe needs the BSD subsystem installed! It is located in Category System...

    cu/

    Sergeij
     
  18. annivas macrumors newbie

    Joined:
    Feb 15, 2008
    #18
    Thank you! It does work... although, according to LocateMe, I am on a boat!! LOL!! :D
     
  19. annivas macrumors newbie

    Joined:
    Feb 15, 2008
    #19
    EDGE Menu missing?

    I discovered another problem that might(?) have aroused by the ZiPhone procedure... EDGE menu is missing in the Settings-General-Network pane.

    I have already examined the carrier.plist file and it seems to be correct. Any other ideas on how can I get it back and working?
     

Share This Page