ZiPhone 2.4 is out (still BSD root problem)

Discussion in 'iPod touch Hacks' started by PlayWithTV, Feb 17, 2008.

  1. PlayWithTV macrumors regular

    Joined:
    Sep 14, 2007
    #1
    Do not try the ZiPhone 2.4 jailbreak with 16+ GB touches. It still doesn't fix the BSD root... problem. FYI
     
  2. snverhallen macrumors 6502a

    Joined:
    Oct 17, 2007
    #2
    What's the difference between ZiPhone and the Official 1.1.3 Upgrader via Installer or any other one like iJailbreakMobile.

    snverhallen
     
  3. PlayWithTV thread starter macrumors regular

    Joined:
    Sep 14, 2007
    #3
    I've got a Vanilla (not JB) 16GB iPod touch. Ziphone will jailbreak it without having to downgrade the firmware.
     
  4. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #4
    I've talked to the developer of ZiPhone directly and as soon as he has enough money, he's going to buy the 32GB iPod touch and start testing. He's already reserved the site zitouch.org so stay tuned! He knows about us!!!
     
  5. snverhallen macrumors 6502a

    Joined:
    Oct 17, 2007
    #5
    NOICE!
     
  6. joepijee macrumors newbie

    Joined:
    Feb 21, 2008
    #6
    help

    i got ziphone 2.4 full unlock on i touch but i got the whole time bsd root: md0, major 2, minor 0

    plz email me to help:confused::confused:
     
  7. KFCTR macrumors member

    KFCTR

    Joined:
    Dec 28, 2007
  8. PlayWithTV thread starter macrumors regular

    Joined:
    Sep 14, 2007
    #8
    Unplug the ipod USB
    hold home and power until ipod turns off.
    While holding the Home button plug the ipod back in.
     
  9. RobertMidd macrumors newbie

    Joined:
    Oct 10, 2007
    #9
    ZiPhone does not work on the 16gb iTouch models where there are 2 flash memory chips of 8GB but will work on the those with one 16gb chip.

    Mine has 2 chips and I had the same problem but there is a another way to get a jailbreak to 1.1.3 but it will mean downloading 1.1.1 and restoring the firmware.

    Once restored to 1.1.1 then goto jailbreakme.com and install apptap and when you have the installer then install the BSD Subsystem.

    Add http://ijailbreak.com/repo.plist to the sources for the installer and then install the iJailbreakMobile 1.1.1 application and then reboot your ipod (this is important)

    When rebooted then run the IJailbreakMobile application and follow the instructions (Note: autolock must be switched off). The application will download and upgrade to 1.1.3 (this takes a whiile) and then your ipod touch will be jailbroken 1.1.3.

    This worked for me but do this at your own risk.
     
  10. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #10
    This is called a SOFT upgrade. It doesn't actually write the official firmware to the device... Instead, it patches the changes from the new 1.1.3 firmware to the jailbroken 1.1.1 or 1.1.2 and thus causes lots of problems. I do not suggest using this method. Also, if you upgrade straight from 1.1.1, you will not be able to play iTunes purchased music or movie rentals. This is the worst way to jailbreak. Wait for the official Ziphone update for 16GB iPods and you'll have the REAL 1.1.3 jailbreak.
     
  11. Rhosfelt macrumors 65816

    Rhosfelt

    Joined:
    Aug 15, 2007
    Location:
    I don't want to be raped :(
    #11
    Yeah DONT upgrade like TheSpaz said, i could possibly have a bricked iPod because of it.

    iTunes is throwing me the error

    Any help would be amazing at this point!
     
  12. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #12
    Just try restoring it to a fresh 1.1.3. Put it in DFU mode and restore.
     
  13. RobertMidd macrumors newbie

    Joined:
    Oct 10, 2007
    #13
    As far as I remember it does install the 1.1.3 firmware as I watched it download the file which was quite large and took ages.

    I do have the problem with purchased music/videos but this because I upgraded from 1.1.1 to 1.1.3 and in 1.1.2 apple changed the DRM.

    I am now trying again but with the 1.1.2 upgrade but I would tend to agree that this method is not ideal and that a working version of ZiPhone for the 16gb touch would be the better option but I simply cannot wait or hope this is released.
     
  14. cbrain macrumors 65816

    cbrain

    Joined:
    Dec 9, 2006
    Location:
    North-East, UK
    #14
    Yes but it writes the changes from that file I think.
     
  15. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #15
    Exactly right! It downloads a hacked version of 1.1.3 and then writes the necessary changes to the existing 1.1.2 firmware. This is why you cannot play iTunes rentals on 1.1.3 soft jailbreak because it's not 1.1.3 at all.

    It's sort of like... lets say you couldn't upgrade your machine to Mac OS 10.5 Leopard for some reason but, you went and found all the piece parts like the new Dock, Finder, and menu bar. Then you could go around saying that you have Leopard but, it's still the Tiger underpinnings and you're really not running Leopard at all. Would you run into a ton of problems by doing this? YES! OF COURSE you would... this is pretty much what they did with the dev team release of 1.1.3.... it's very very bad.... and it sucks.
     
  16. cbrain macrumors 65816

    cbrain

    Joined:
    Dec 9, 2006
    Location:
    North-East, UK
    #16
    Hmm, from hearing this I might restore, we've got the SDK coming out soon anyway.

    EDIT: Restored
     
  17. Rhosfelt macrumors 65816

    Rhosfelt

    Joined:
    Aug 15, 2007
    Location:
    I don't want to be raped :(
    #17
    I got it, after a while to work right. However now I don't have the right 1.1.3 the Icons don't "wiggle" and I freaking bought the January update, and it's not in my iTunes still wtf? I need to email apple. I am not losing $20, I want mail, maps and so on if I paid for it...right NOW.
     

Share This Page