Ziphone help: BSD root: md0, major 2, minor 0??

Discussion in 'iPod touch Hacks' started by coledog, Feb 26, 2008.

  1. coledog macrumors 6502a

    coledog

    Joined:
    Nov 14, 2006
    Location:
    Roanoke, VA
    #1
    I've been trying to jailbreak my ipod touch using Ziphone. I've tried both 1.1.4. and 1.1.3. They both run until the MAC address appears on the touch screen and then BSD root: md0, major 2, minor 0 shows up and keeps popping up.

    Anyone else have this problem and have come up with a fix?
     
  2. ricardo1064 macrumors member

    Joined:
    Dec 12, 2007
    #2
  3. coledog thread starter macrumors 6502a

    coledog

    Joined:
    Nov 14, 2006
    Location:
    Roanoke, VA
    #3
    I found thy before, what Im hoping someone has is the workaround.
     
  4. ricardo1064 macrumors member

    Joined:
    Dec 12, 2007
    #4
    they came out with a new version today/last night, unfortunately it seems as though they are having the same problems.
     
  5. riqo22 macrumors newbie

    Joined:
    Feb 28, 2008
    #5
    working 1.1.4 16gb ipod touch

    If you're getting a BSD error when trying to jailbreak your iPod Touch, complete the following to get your iPod working and jailbroken with 1.1.4 firmware. This was done on a mac and you'll need the 1.1.3 firmware update

    1. connect sync cable to 'broken' iPod
    2. open iTunes
    3. hold down sleep/wake and home buttons until screen is blank
    4. release sleep/wake button ONLY when screen is blank
    5. release home button when iPod appears in iTunes
    6. press option key + Restore button and select the 1.1.3 firmware file
    7. wait for restore to complete
    8. go through iPod setup wizard, uncheck automatically sync and click sync to synchronize nothing
    9. click on check for update and update the iPod to 1.1.4
    10. wait for update to complete
    11. click sync to sync nothing
    12. Eject iPod and close iTunes
    13. Disconnect sync cable from iPod
    14. hold down sleep/wake and slide to power off
    15. hold down home button and connect sync cable
    16. release home button when iTunes logo appears on iPod display
    17. open ZiPhone
    18. select Jailbreak
    19. click Start
    20. wait for jailbreak to complete

    Job done; fully working, jailbroken iPod Touch running 1.1.4

    Things to do after:

    1. connect to your wireless network
    2. open installer
    3. install BDS Subsystem under System
    4. install Open SSH under System
    5. add the source http://repo.ispazio.net
    6. install 1.1.3 / 4 iPod Full Features 2.1 under iSpazio Unlock Tool

    Job done; fully working, jailbroken iPod Touch running 1.1.4 with Mail, Google Maps, Weather, Stocks, Notes.

    Hope this helps
     
  6. coledog thread starter macrumors 6502a

    coledog

    Joined:
    Nov 14, 2006
    Location:
    Roanoke, VA
  7. kyleissuper macrumors newbie

    Joined:
    Feb 28, 2008
    #7
    Sorry man.

    I have the same problem with ziPhone. Too bad... It doesn't work with 16 gig iPod Touches. However, you can still get it to work. It'll take a bit more effort with the 16 gig iPod Touch, but it's worth it... I think.

    Here's what I did to upgrade to 1.1.3 jailbroken:

    1) Force it to turn off by hold the sleep/wake & home button.
    2) Do not let go of the buttons until it passes the Apple logo, onto the iTunes recovery screen - yes, it works. Trust me.
    3) Restore to whatever... Probably 1.1.4. Restore it completely and don't sync any songs or pictures etc.
    ----- Plz find links online for help on the following steps. Try youtube.
    4) Downgrade to 1.1.1. The downgrade from 1.1.3 works for 1.1.4 as well.
    5) Go to http://www.jailbreakme.com on your iPod Touch, and click the install appsnapp button at the bottom of the site. It will install and reboot.
    6) Open installer, go to install -> sources. Install whichever ones you need.
    7) Once you've refreshed your sources, find BSD Subsystem & oktoprep from "all applications."
    8) Download the 1.1.2 firmware, and shift-click on update if you're using Windows, and alt-click for Mac. Open the 1.1.2 firmware to update.
    9) Download TouchFree Jailbreak, and follow the instructions on the ReadMe.
    10) Repeat steps 6/7.
    11) Search Google for the iPod Touch/iPhone upgrade to 1.1.3 repo.
    12) Install it from "installer."
    13) If need be, install the 1.1.3 apps from whatever sources that are currently reliable.
    14) You've finally gotten through all of this... Have fun and don't screw up again - reread this if you do.
     
  8. pmarcovi macrumors newbie

    Joined:
    Nov 17, 2007
    #8
    Ziphone does not work on Ipod touch 16GB

    It only works on 8GB ...
     
  9. jman4evr macrumors newbie

    Joined:
    Feb 29, 2008
    #9
    Started with a brand new 1.1.3 iPod touch 32 GB. Updated to 1.1.4 through iTunes. Then I jailbreaked with Ziphone 2.4, which appeared to work fine.
    Installed several apps without any problems.

    Jailbreaked AGAIN with Ziphone 2.5 (Bad idea, all downhill from here)

    During this session the MAC address displayed and the following appeared:

    BSD Root: md0, major 2, minor 0
    BSD Root: md0, major 2, minor 0
    BSD Root: md0, major 2, minor 0
    …

    Was able to restore, but haven’t been able to jailbreak again, neither with 2.4 nor 2.5. Each time I try, keep getting the same BSD Root error.

    Downgraded to 1.1.3 and tried again, same result.

    I should mention that I tried iTunes 7.5 and 7.6, same result.

    Finally upgraded back to 1.1.4 and am leaving well-enough alone until the experts can convince me to try again.
     
  10. porge810 macrumors newbie

    Joined:
    Feb 29, 2008
    #10
    i have the same problem and despritely need help.................except i can't restore because my computer isn't detecting my ipod..........any help with that
     
  11. coledog thread starter macrumors 6502a

    coledog

    Joined:
    Nov 14, 2006
    Location:
    Roanoke, VA
    #11
    Not on mine...o well! 1.1.3 is good enough for now...
     
  12. itsadoozy macrumors newbie

    Joined:
    Mar 3, 2008
    #12
    OK, I just recovered my iPod Touch 8GB.

    I Jailbreak'd (broke) my device several months ago with the now regular routine of downgrading from 1.1.3 to 1.1.2, then upgrade etc.. Worked great at 1.1.3 and I downloaded many apps and games.

    I decided I wanted to upgrade to 1.1.4 because I'd seen an iPhone with the icons shaking and allowing you to move them around the desktop...looked a cool feature. To be honest, that's all I wanted from the upgrade..sad I know.

    Anyway, today I did a quick google to see how to upgrade an already Jailbreak 1.1.3 to 1.1.4 and came across the recommendation for http://www.ziphone.org/

    I upgraded my iPod via iTunes to 1.1.4 with no problems.

    Downloaded the ziphone 2.5c app and fired it up and selected the Jailbreak option.

    Easy as eating cake. iPod Touch fully Jailbreak'd

    Then the fun began. The sw had placed a desktop icon for Ziphone Blog which I didn't like. Went into Installer and tried to select a few apps to install, and they all failed.

    After messing around for a while I decided to revert back to 1.1.3 and Jailbreak that so I would be back where I started just a few minutes earlier. Sadly that isn't what happened.

    I selected the Refurbisjh option in Ziphone GUI, and the iPod started to scroll loads of command line stuff and then locked. The GUI Log output shows a wait 4' 00" ....I waited, and waited...eventually I gave up and stopped the process...the iPod remained hung.

    Bugger !!

    Looked like I have turned my iPod into an expensive paper weight.

    Found this forum and the iTune Restore option done on a MAC.

    Held the Power and Home Page buttons on my iPod until it rebooted (takes a few seconds), connected the USB cable and iTune recognised iPod was in recovery mode.

    I don't have a MAC so the procedure for restoring from iTu8nes is to have an old version of sw on your machine. I have a copy of 1.1.1 from when I Jailbroke originally. I have a PC so just used the Hold Shift Key and select Restore from iTunes to select the software.

    iTunes did the rest, and the device is now up and running in 1.1.1 !!

    Now going to upgrade and do the old 1.1.2 - 1.1.3 Jailbreak.

    Oh and by the way. It appears that after I upgraded to 1.1.4 from iTunes, the iPod touch 8GB doesn't do the wobbly icons as per the iPhone!!!

    So all in all a wasted few minutes...

    I'll wait until a more reliable upgrade and hack comes available. I can live without wobbling icons.
     
  13. itsadoozy macrumors newbie

    Joined:
    Mar 3, 2008
    #13
    Additional note:

    Couldn't resist and tried to upgrade and Jailbreak 1.1.4 again...didn't work!

    I did notice however, it's a tricky key combination to get iTunes to see the iPod once its stuck in recovery command line mode (BSD root: md0, major 2, minor 0).

    You have to disconnect the USB, Hold down the power and home keys until the device switches off, then press power on, and wait until you get the connect cable logo on the screen. Connect USB and restore from iTunes. Took me a few attempts this second time round, and I really thought I'd pushed my luck, and killed the iPod....phew, it's back up again and now 1.1.4 not Jailbreak.
     
  14. chafner macrumors newbie

    Joined:
    Mar 23, 2006
    Location:
    Wolfeboro, New Hampshire
    #14
    Worked on 16 gig iPod Touch

    Hey, just a bit of a responce to an issue with the latest ZiPhone. I've unlocked about 10 or so iPod's and about 3 iPhones. While ZiPhone is the easiest (by far) it seems to have the most issues. For now I'll stick with the official dev teams method as I've just not run into any issues with it... anyways on with my point.

    I've recently attempted to unlock a 1.1.4 iPod touch with the most recent ZiPhone. It seemed to go through until I ended up getting nothing but a whole screen of

    bsd root: md0, major 2, minor 0

    After reading this post from kyleissuper I was saved. Holding both the power and home buttons after a force restart booted me back into recovery mode!!! You rock!!! (And yes, this was on a 16 gig iPod Touch)... for now I'm just going back to the dev team method... 1.1.4 doesn't offer me anything (don't care about safari "white" tabs). Thanks kyleissuper!!!
     
  15. supercooled macrumors 6502a

    Joined:
    Sep 6, 2007
    #15
    Thought I bricked it as well but thanksto kyzer solzer (not your name but it sounds cooler).

    I'm just going to stick to 1.1.4 until such time someone says theirs is working without hassles.
     
  16. Xenn0X macrumors regular

    Joined:
    Jan 25, 2008
    #16
  17. ricardo1064 macrumors member

    Joined:
    Dec 12, 2007
    #17
    Just as an FYI,

    I tried every method known to man last night till 3 am...

    from 1.1.3 to 1.1.4 registered, not registered, with itunes on, itunes off, itunes on not registered, itunes on registered, on Windows Xp, Windows Vista and Mac OSX all running the latest and greatest updated versions for everything.

    The only thing I got different is I was able to get past the BSD error message and get to the "Spamming AT, Waiting for a response"...

    Seriously the amount of time i've spent trying to Jailbreak this thing isn't even worth it. Once there is a working fix that isn't related to luck and is related to progress I will post.
     
  18. jman4evr macrumors newbie

    Joined:
    Feb 29, 2008
    #18
    I managed to get this to work on my 32GB iPod, but on the second attempt. Seems to me that the timing of the manual reboot, as shown in the video, was key to success/failure. The first time around I was kind of slow, and I had to restore again. But the second time I was quicker, and it worked like a charm. Note that timing is mentioned in the troubleshooting.txt file as well:

    Timing is fairly important on this. If your phone reboots or ends up in recovery mode, just try again. You might want to look at a clock that shows seconds while you do this. The timing needs to be exact for it to work.

    This whole thing has been a real pain, but in the end I believe it was worth it. The stock iPod touch was a "nice" device, but now it rocks! To those that are still where I was, I say keep trying.
     
  19. ExcelonGT macrumors regular

    Joined:
    Feb 9, 2008
    #19
    worked for me on my 16gb touch! (but on my second attempt). I guess it really is a timing thing. because the second time around I clicked the button less furiously.
     
  20. halfbaked084 macrumors newbie

    Joined:
    Mar 10, 2008
    #20
    Wow

    Alright my suggestion is to NOT use ZiPhone's method of jailbreaking your iPod Touch. I used an 8GB iPod Touch, jailbroke it using ZiPhone's method and I had problems from the get-go. For some reason I was unable to install BSD Subsystem and therefore, was unable to install many other apps onto my iPod. My music and movies were working perfectly fine and I had even had a few games installed thanks to installer.app. For some reason I tried it at midnight (I was drunk) and I was able to do it...just my luck. Everything was going great, I had a bunch of awesome games on my iPod, but then I tried to play my music, and it wouldn't work. The same thing happened with all my movies and tv shows. It was bs. I decided to just start fresh with a new rebooted iPod using iTunes and told myself I wouldn't do that again...that lasted long. The next day I tried to put installer back on using ZiPhone because I wanted to see what caused the problem. I tried to install BSD Subsystem...didn't work. So I tried using the refurbish icon located in ZiPhone's menu screen. It went well at first but then it was in some sort of waiting process for about an hour. I decided to stop the process and that is when all hell broke loose. I got the damn BSD root: md0, major 2, minor 0 text all over my iPod. I thought my phone was f-ed. I tried everything but finally got lucky when i held down the wake/sleep button AND the home screen button until the iPod restarted and the apple DISAPPEARED from the screen. This put the iPod into recovery mode and I was able to start all over. Take my advice people, DO NOT USE ZIPHONE'S STUPID DEFECTIVE METHOD because it will just f up your iPod
     
  21. ricardo1064 macrumors member

    Joined:
    Dec 12, 2007
  22. j.ajamil macrumors newbie

    Joined:
    Mar 17, 2008
    #22
    Following your instructions I was able to recover my iTouch from "crap", thank you! :)
    The only difference was that I used directly the 1.1.4 firmware to restore, and everything went fine.

    Saved for future references :)
     
  23. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #23
    I had similar error so I done the home sleep/wake recovery mode bit then loaded ziphone again and clicked dfu mode and restored to 1.1.4
     
  24. MakoIsFabulous macrumors newbie

    Joined:
    Jan 30, 2008
    #24
    I have 16GB, jailbroken with ZiPhone at 1.1.4... Heres how i did it:

    1.) You NEED to have ZiPhone 2.6b, if you have an earlier version, please go to http://download.ZiPhone.org/ and download it.

    2.) Plug your iPod into the computer

    3.) Hold the Sleep/Wake and Home buttons until the iPod disconnects from iTunes. Let go of the Sleep/Wake button and hold the home button until your iPod goes into recovery mode

    4.) Restore your iPod to version 1.1.4

    5.) Open ZiPhone

    6.) Click on "Fix NVRAM"

    7.) After it is done, click on the "iPod Touch" button next to the Jailbreak button

    8.) Before you do ANYTHING, go into contacts

    9.) Press the "+" button

    10.) Then press the text field labled "First Last"

    11.) Start spamming with the keyboard (DO NOT SKIP THIS STEP)

    12.) After you have spammed random letters for about a minute or so, press "Cancel", press "Cancel" again, and then press the home button

    --Doing steps 8-12 will save you from freezing up later--

    13.) Go into Installer

    14.) Add the source "http://repo.ispazio.net"

    15.) Goto the catagory "iSpazio Unlock Tools" and install "1.1.3/4 iPod Full Features"

    congratz, you now have jailbroken 1.1.4 iPod with $20 apps:)




    I attached some pictures if it helps (I am on windows)
    (click on it to enlarge it, it is hard to see when it is that small)
     

    Attached Files:

  25. BrianSullivan macrumors newbie

    Joined:
    Dec 26, 2008
    Location:
    PA
    #25
    Unique case?

    Ok, so my older cousin did a whole bunch of crap to his iPhone including using ZiPhone to unlock and jailbreak :confused:. Ive jailbroken quite a few iPhones and iPod touches (2nd gen) but by far this iphone seems to be unique.:mad:

    I've tried iPhuc, iBoot / iRecovery/ etc, The thing that stumps me is that the phone goes into restore mode, but sometimes decides that It wont show up in itunes.Ive tried this on 3 macs. DFU mode comes like a breeze for all the other ipods that I've done; not this one. It refuses to show up in itunes.

    It boots up in the bsd root (verbose) mode and never starts. If I get it to go into iTunes, it stays at a "Preparing for restore..." (using both option and factory restores) screen and the farthest I got was a white screen.

    I wish I could get into DFU or at least get it to restore properly.

    Any help would be appreciated!
     

Share This Page