Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

efi

  1. robertcoogan

    Problems with chnages to firmware on boot

    I used to use rEFInd as a boot loader, but with the upgrade to Big Sur there have apparently been changes to the firmware that interferes with rEFInd's operation. So I am back to holding down the option key. Yay. <--(sarcasm) If I tried to boot normally, rEFInd should kick in and take me to...
  2. C

    Clover efi bootloader attack on 2014 Mac Mini?

    I went away for the Christmas holiday only to return to days later to see that my Mac mini head crashed and on the screen was displayed the boot loader screen for the clover efi. I believe clover is related to running macOS on a hackintosh. I don’t know much more about it than that. My internal...
  3. pizzabox

    No Apple Hardware Test on 2012 MBP?

    I am trying to run Apple Hardware Test. When I try to boot into it I get sent to internet recovery, then after a while I get an error on a black screen: Error message: Cannot Load "EFI/DRIVERS/TESTSUPPORT.EFI This thread on the Apple forum suggests it's broken now for older systems. I did...
  4. Matt T

    Possible to use two Bluetooth HCI controllers concurrently?

    I have a 2011 iMac with Bluetooth 2.1, and recently purchased a Bluetooth 4.0 USB dongle required for my new wireless mouse. The dongle works great - I paired my mouse and keyboard to it without issue and used the following terminal command to ensure macOS uses the dongle instead of the...
  5. Matt T

    Possible to use two Bluetooth HCI controllers concurrently?

    I have a 2011 iMac with Bluetooth 2.1, and recently purchased a Bluetooth 4.0 USB dongle required for my new wireless mouse. The dongle works great - I paired my mouse and keyboard to it without issue and used the following terminal command to ensure macOS uses the dongle instead of the...
  6. mothchip

    iMac 4,1 can't update EFI or SMC firmware

    Hello! I hope this is the right place. I tried to post to the Netkas forums but it's not sending me an activation email for some reason. I have an iMac 4,1 I picked up from a garage sale that I'm trying to install Linux to, but can't. I believe the core issue is that I cannot update the boot...
  7. explit

    MP 1,1-5,1 Mac Pro 4.1(5.1) Windows Problem with flashed EFI Cards.

    Hello Guys: I have a Problem with Mac Pro 4.1(5.1). I have flashed 2x Graphic Cards wit mac EFI ROM to have a Boot Screen: MSI R9 280 GAMING 3G MSI R9 280X GAMING 3G Both Graphic Cards works very good in MacOS Mojave, but as soon i start Windows 10 on the Mac Pro, i get a black Screen and...
  8. D

    I tried to install Windows 10 Pro using BootCamp and now the EFI boot screen is blank (black)

    I am using a Mac Pro 2013 6-Core 3.5GHz 64GB RAM Dual D500 machine with a fresh install of macOS Catalina 10.5.3 which was working like a charm (flawlessly) until I tried to install Windows 10 Pro (64 bits) using BootCamp, everything went fine until macOS asked to reboot the machine to continue...
  9. longbottle

    MP 1,1-5,1 Windows 10 x64 on MP 2,1 with 64GB RAM: only 32GB shows usable

    I recently used an old HP with UEFI to install Windows 10 x64 onto a pre-made Boot Camp partition on the hard drive in my MP. Everything went surprisingly well with it, except I'm surprised to find that the RAM only shows 32GB usable, even though Windows detected all 64GB in my MP. I know the MP...
  10. S

    MP 1,1-5,1 GTX 960 SSC EFI flashing For MacPro 5.1

    Am having EVGA GTX 960 SSC using for windows PC ,can be able to flash for MacPro 5.1,Please guide how to EFI flash GTX model,there was any definitive guide for Flashing EFI Flashing same EFI rom can be used for all same category for GTX model example EVGA GTX 960 SSC 2GB ,same EFI rom can be...
  11. ThatGrimshaw

    MacBook Pro Only Boots UEFI Volumes—No Legacy Mode

    Hey everyone, this is my first post on the forums. Since Saturday, I've been fiddling with a Late 2008 MacBook Pro (15"). For whatever reason, it just does not want Windows installed on it. I've tried about 5 different Windows XP ISOs (booting from both CDs and flash drives) and none of them are...
  12. Zaithe

    MP 1,1-5,1 Displayports not working on 1080TI with Mac Pro 5,1

    I have a non EFI flashed 1080TI(11G-P4-6798-KR) using the SATA ports for power (2x 6in SATA Power to 1x 8 Pin PCI Express Video Card Power Cable Adapter) alongside the default gpu power cable i believe to prevent the unexpected shutdown crash (still happens on high load). I was having an issue...
  13. explit

    MP 1,1-5,1 Nvidia Quadro K2000D EFI64 ROM needed

    Hello guys. I have an upgraded Mac Pro 4.1 flashed to 5.1 Upgraded the graphic card with Nvidia Quadro K2000D and running Mojave. Quadro K2000D is running just fine, but i don't see the Disk icons when trying to boot from another drive. I think an EFI64 ROM is needed here. Can someone help me...
  14. nemoryoliver

    How to update EFI BootROM firmware on an aftermarket SSD?

    Besides switching back to the OEM SSD just to update the EFI firmware. Are there other workarounds? Opening the iMac for each OS Update that requires an updated BootROM will be a pain. If my boot drive is an External NVMe SSD (ex: Samsung X5) will I ever have problems with the BootROM when...
  15. KolfMAKER

    MacBook Pro GPU failure: can't disable SIP

    From reading several threads, I am sure the AMD GPU is failing on my 2011 MacBook Pro. I have seen the instructions to boot in safe mode and use commands to eventually turn off the AMD GPU and turn on the integrated Intel GPU. Here's what I did (using the AppleMacFinder procedure...
  16. iglaoftheninth

    External SSD issue: EFI partition missing after reformatting, now can't be read altogether

    (MacBook Pro 13" late 2013, 8 GB RAM, i5 2.4 GHz) Hi all! I recently got a 1 TB Seagate Backup Plus external SSD and was planning to install Mojave on it. After plugging it in for the first time, I opened Disk Utility to change the partition map from MBR to GUID and then started up the...
  17. iglaoftheninth

    External SSD issue: EFI partition missing after reformatting, now can't be read altogether

    (MacBook Pro 13" late 2013, 8 GB RAM, i5 2.4 GHz) Hi all! I recently got a 1 TB Seagate Backup Plus external SSD and was planning to install Mojave on it. After plugging it in for the first time, I opened Disk Utility to change the partition map from MBR to GUID and then started up the...
  18. Fan1s

    MBP9,2 ROM224.0.0.0 Downgrade help

    Hi guys, I am a newbie on this forum, but I am a user of macbook for many years. I have home one Macbook Pro mid2012, i5 2,5Ghz. I was changing a motherboard, but it lost my serial number. I have it form bottom of mac. When I look at "about my mac" the field for serial number is empty. I can...
  19. R

    2 gpus, 1st just for boot screen

    Hi all. I have a mac pro 4,1 (flashed to 5,1) and am looking to beef up the GPU a little (and get mojave/metal compatibility). I know Windows cards can and do work out of the box in later OSX revisions with the caveat that the boot screen won't work. I use filevault and would like a boot screen...
  20. parisinvest

    Some Tests on netkas script's effets after flashing

    AS REQUEST OF EXPÉRIENCED MEMBER, I'D LIKE TO MENTION AT THE BEGINNING, THIS TOPIC IS BASED ON MY OWN TEST, I BOUGHT THESE CARDS, MAKE EFI ROM DIRECTLY ON NETKAS SCRIPT, WITHOUT ANY OTHER MODIFICATIONS, AND FALSHED BACK THEN TESTED ON MAC PRO 5.1, 3.1, SO THIS IS AND ONLY IS A PERSONNAL ADVICE...