1.1.1 to 1.1.3 Jailbroken Guide

Discussion in 'iPod touch Hacks' started by chrisbeebops, Feb 4, 2008.

  1. chrisbeebops macrumors regular

    Joined:
    Jun 8, 2007
    #1
    This worked for me, and was the easiest and fastest way I could find to go from 1.1.1 to 1.1.3 Jailbroken.

    First, make sure you have firmware 1.1.1 installed on your iPod Touch. If not, put your iPod Touch into recovery mode by holding down the Home key as it starts up. Click Restore while holding down the Options key, and select a copy of the 1.1.1 firmware. Once this is done, you can turn your computer off, because you don't need it for the rest of the process.

    Turn on your iPod Touch, open Safari, and open up http://jailbreakme.com . Scroll to the bottom, and click Install AppSnapp. This will jailbreak your iPod. When it finishes, open up the Installer app. Tap the Sources tab. Add ijailbreak.com/repo.plist as a source by tapping Edit, then Add. Then tap Refresh. Tap Install, scroll down to System, and select BSD Subsystem. Install it. Now, go back to the Install tab, scroll to iJailBreakMobile, and select iJailBreakMobile 1.1.1. Install it, then exit Installer by pressing the Home button.

    Now, run iJailBreak. Just let it sit and run... it will automatically do everything, and then restart when it has finished installing 1.1.3. If you get a whole bunch of error messages (file not found, access denied, etc.) and it stops without downloading the 1.1.3 firmware, reinstall BSD Subsystem and iJailBreakMobile 1.1.1. Restart your iPod Touch, and then try running iJailBreak again.

    After it restarts, to finish up, open Installer, tap Install, scroll to iJailBreakMobile, and install Remove 1.1.3 Upgrade Data. This will delete a few temporary files used during the upgrade process.

    You now have a Jailbroken 1.1.3 iPod touch!

    **Optional: iPhone Apps
    First, install the BSD Subsystem again. Then go to iJailBreakMobile, select iPod touch Software Upgrade. Exit installer, and run the iJailBreak application. When it is done, you will have Maps, Photos, Stocks, Weather, and Mail installed. Open up Installer again, and install Fix Mail Passwords from the iJailBreakMobile section.
     
  2. bnizzy macrumors member

    Joined:
    Feb 4, 2008
    Location:
    NYC
    #2
    Does Summerboard, Customize, Apollo, and other apps run well on this JB version?

    Just curious because I am currently in the ipodtouchmaster's JB 1.1.3 version and I am having issues getting them to work...

    Doomnote told me that he is running the Official Dev JB 1.1.3 and it runs well on his, which is what I am about to do. Just wondering if I should wait a few days until there is confirmation that there is another JB that consolidates them all with all the fixes.

    Thanks.
     
  3. nuzreq macrumors newbie

    Joined:
    Jun 23, 2003
    #3
    If you've already paid for the iphone apps, will they automatically re-sync to the iPod touch after completing the jailbreak?
     
  4. zamwi macrumors newbie

    Joined:
    Feb 14, 2007
    #4
    Doesn't work for me. I've tried over and over...now installer doesn't recognize my applications so I can't uninstall ijailbreak.
     
  5. chrisbeebops thread starter macrumors regular

    Joined:
    Jun 8, 2007
    #5
    THe problem is that they don't work with 1.1.3, not that they don't work with a specific jailbreak.
     
  6. chrisbeebops thread starter macrumors regular

    Joined:
    Jun 8, 2007
    #6
    I cannot see why they wouldn't.
     
  7. chrisbeebops thread starter macrumors regular

    Joined:
    Jun 8, 2007
    #7
    Are you getting an error message? I can't really help you if all you say is that it doesn't work. Make sure you are at 1.1.1, you installed both BSD Subsystem and iJailBreak for 1.1.1, and that you are connected to the internet when you run iJailBreak.
     
  8. zamwi macrumors newbie

    Joined:
    Feb 14, 2007
    #8
    I have both the BSD subsystem and iJailbreak mobile installed but I keep getting the same problem.

    I run ijailbreak and it runs through telling me permission denied, it finally stops at line 48.

    I have reinstalled BSD and ijailbreak 5 times, with no luck in upgrading to 1.1.3.
     
  9. Slip macrumors 6502a

    Slip

    Joined:
    Oct 16, 2007
    Location:
    Wiltshire, England
    #9
    Those having troubles could try the Official 1.1.3 Upgrader from the Dev Team. Follow the steps up there to where it says to run iJailbreakMobile.
     
  10. chrisbeebops thread starter macrumors regular

    Joined:
    Jun 8, 2007
    #10
    Make sure you are connected to the wireless. iJailBreak will download files over wireless (1.1.3 update and then a patch file for Jail Break later in the installation). You are getting Permission Denied because the iJailBreak script is trying to execute files which don't exist because the update was not downloaded.
     
  11. zatchzeno macrumors newbie

    Joined:
    Feb 7, 2008
    #11
    try this.

    install BSD
    restart the iPod
    reboot.
    install jailbreakmobile 1.1.1
    restart
    reboot
    run jailbreakmobile 1.1.1
     
  12. xXriderXx7 macrumors 6502a

    xXriderXx7

    Joined:
    Jul 6, 2007
    Location:
    Lake Elsinore, California
    #12
    Worked flawlessly.
    Thank you so much.

    I just let the app run its course, and ended up with a jailbroken 1.1.3 iPod Touch.
    I also installed the iPod software update, and am now running a fully functional iPod Touch.
     
  13. pcinfoman macrumors member

    Joined:
    Feb 18, 2008
    #13
    A couple of questions.

    Is this going to wipe the information/photos/music/videos I have on my iTouch?

    You said to turn on the itouch while holding the Home key as it starts up. This will put it in recovery mode. I turned off my itouch and turned it on while holding the Home key, but it just booked normally. I got no such option to Restore.

    Am I supposed to do this when the itouch is connected to my computer?

    Do I need to connect it to my Mac or is my PC good enuf?
     
  14. lentife macrumors member

    lentife

    Joined:
    Dec 27, 2007
    Location:
    Rome, Italy
    #14
    Help me 1.1.1

    Wow, thanks for this, that's really awesome.
    I installed bsd subsystem and 1.1.1 mobile kit etc..
    that's because I have a 1.1.1 ipod touch and want to upgrade to 1.1.3.
    You can't install OktoPrep in installer (to upgrade to 1.1.2), so I figured out this way using iJailbreakmobile 1.1.1... The problem is that it downloaded everything (took about 25 mins.) and seemed to install it. then it rebooted and it still was 1.1.1.
    what happened?? What can I do??
    I only need to have SSH so that I can have access on the itouch.

    1) is there a way to get SSH or something similar? (installer has no more ssh...)

    2) how can I upgrade to 1.1.3 (or 1.1.2) if I can't install oktoprep?

    3) why did that cool iJailbreakmobile 1.1.1 not work??

    Thanks a lot, please reply!!
     
  15. magicjames92 macrumors regular

    Joined:
    Apr 15, 2007
    #15
    crap im installing right now and i accidentally hit the keyboard..will this screw it up?
     
  16. snverhallen macrumors 6502a

    Joined:
    Oct 17, 2007
    #16
    I have something even simpler. Just use ZiPhone. Go to ziphone.org to download. Takes under 5 minutes, it is a native jailbreak meaning it jailbreaks the software you have now.

    snverhallen
     
  17. idoctor macrumors newbie

    Joined:
    Feb 18, 2008
    #17
    that is ok... but i think the new ziphone will do better!
     
  18. KFCTR macrumors member

    KFCTR

    Joined:
    Dec 28, 2007
    #18
    It downloads the file, then it asks me to replace each file manually. Why doesn't it work?
     
  19. lentife macrumors member

    lentife

    Joined:
    Dec 27, 2007
    Location:
    Rome, Italy
    #19
    The Ziphone works for the 8GB model only! I tried with my 16GB iTouch, but as failed like with many other users...
     
  20. pcinfoman macrumors member

    Joined:
    Feb 18, 2008
    #20
    Yes, it works only with the iphone. It totally crashed my 32GB itouch.
     
  21. smiddlehurst macrumors 65816

    Joined:
    Jun 5, 2007
    #21
    Hmm, quick question that hopefully someone can help me with.

    I'm upgrading an iPod Touch 16Gb from 1.1.1

    To make sure previously installed apps didn't get in the way I've done a software restore using the 1.1.1 firmware and then unlocked the phone as outlined in the original post. iJailBreakMobile 1.1.1 was downloaded through installer and is currently running on the device. It's downloaded the 1.1.3 firmware and has also done the patch.zip file. The application is now showing the following:

    Patching filesystem...
    mount :/var: unknown special file or fie system
    If you get a mount :/var: unknown special file or file system error, it is completely normal.

    That in and of itself isn't a problem, but it's been like that for about thirty minutes or more at this point. From those that have done this install, is that normal or do I need to start thinking reboot / restore?

    Update Left it for over an hour on that screen and did a hard reset (power and home). Came back up with the 1.1.3 firmware and installer but could not install any applications as installer gave a 'you don't have the BSD subsystem tools installed' message. Not a major problem except that it gave this message when trying to install the BSD subsystem itself... Cue another reboot and sweaty palms. Thankfully when it came up this time installer was back to its usual reliable self, BSD went on without a problem and everything seems fine again. Summerboard is co-operating and, in a suprising move to me at least, google maps is the full 1.1.3 version with location mapping.

    One question though, I've installed the remove 1.1.3 upgrade data application but there's no icon to run it. Is this right, does it run automatically or have I missed something?
     
  22. bigspoiltbrat macrumors newbie

    Joined:
    Feb 23, 2008
    #22
    I tried using jailbreakme.com and I have the iJailBreak icon up, but when it starts to download the update, it times out at about 40-70% and stops. I have to restart the ipod and reinstall it to try again, but this happens over and over.

    Is there any other way to do this manually? Or does anyone know why it's timing out?
     
  23. ExcelonGT macrumors regular

    Joined:
    Feb 9, 2008
    #23
    How long is this thing supposed to take. I'm definitely approaching the one hour mark and it seems stuck at this:

    Archive: patch.zip​
    inflating: ./patch.sd3​
    Patching filesystem...​
    mount: /var: unknown special file or filesystem​
    If you get a mount: /var unknown special file or filesystem error, it is completely normal​


    its been here for about 30 mins. How much longer am I supposed to wait :(
     
  24. ExcelonGT macrumors regular

    Joined:
    Feb 9, 2008
    #24
    my 16gb touch seems totally unresponsive at this point. I reset it and it has rebooted with 1.1.3 instead of 1.1.1 before the process. However, the installer is now gone.
     
  25. bryant24 macrumors newbie

    Joined:
    Feb 23, 2008
    #25
    Hi i have the 1.1.1 firmware on my touch now i added the source and installed the BSD but when i go back to all the apps the ijailbreak app is not there and i am not sure why.
     

Share This Page