120GB OWC Mercury Extreme Pro 6g *issue*

Discussion in 'Mac Pro' started by Johnnyizz, Sep 3, 2011.

  1. Johnnyizz macrumors newbie

    Joined:
    Sep 3, 2011
    #1
    Hey been running my MacPro4,1 with this drive for a least a month now. One problem I have with my drive is when I enter boot manager (hold option at startup) the ssd does not appear in the list of bootable drives. I partitioned it with lion in one and snow leopard in other. Can't see either. I have another drive installed with bootcamp on it, and previously had snow leopard on that too. Computer sees that drive no problem. But when it comes to the ssd, boot manager can't find it 90% of the time. Note that if I dont enter boot manager at startup, the computer boots from the default OS on the ssd fine. So the drive works fine.

    Things I have tried to fix it:
    - disconnect all external USB and FireWire devices
    - turn off all Bluetooth devices
    - Reset MSC.
    - disconnect power cable and hold power button for 10s.
    - reformat drive and reinstall OS lion
    - reformat drive and reinstall snow leopard
    - ran apples hardware test and 3rd party (no apparrent problems with drive or computer)

    Nothing has worked. In the process of updating the drives firmware to the latest one.

    Any suggestions??:confused:
     
  2. Chunk72, Sep 3, 2011
    Last edited: Sep 3, 2011

    Chunk72 macrumors member

    Chunk72

    Joined:
    Mar 16, 2008
    Location:
    Durham, UK
    #2
    I would wager your drive is formatted as MBR and not GPT (GUID). Check with Disk utility.

    From my own experience I had to wipe the drive and reinstall to get it to show in the boot menu. Someone else may know better.
     
  3. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #3
    Have you tried partitioning in 10.6 instead of 10.7's diskutility?

    10.7 disk utility is pretty buggy.
     
  4. Johnnyizz thread starter macrumors newbie

    Joined:
    Sep 3, 2011
    #4
    Thanks for that, I'll try formatting in OS X 10.6 install DVD instead and making sure it's being formatted in GUI not MBR. I don't think that I've been formatting in MBR, I've been just formatting using disk utility on default settings. And the ssd does show up some times in boot manager. But most times it won't.

    I'll check both those, thanks.

    ----------

    Sorry, and partition in OS X 10.6.
     
  5. Johnnyizz thread starter macrumors newbie

    Joined:
    Sep 3, 2011
    #5
    Ok, I can confirm that I've been partitioning with GUID. And I tried formatting and partitioning with 10.6 instead of 10.7 disk. And only installed 10.6... Still same problem.

    Not looking good.
     
  6. TinHead88 macrumors regular

    TinHead88

    Joined:
    Oct 30, 2008
    #6
    Have you tried OWC support? They are usually good with supporting their products. Let us know how that goes as some of us may be interested in their 6g drives.

    Cheers
     
  7. Johnnyizz thread starter macrumors newbie

    Joined:
    Sep 3, 2011
    #7
    Yeah, I spoke with them an they said that it's strange, they have never seen that issue. They put me onto some senior support tech or something and they ended up ending the live chat. I emailed them back after that, but no reply.

    Anyways, I tried putting the SSD in bay two to see if it made a difference. It did. Tried it 10 times successfully. Then I moved it back to bay one. And then it worked ten times in a row there too. So now I'm confussed lol. It appears to be working for now :).

    One thing I did notice tho, when you put a 3.5" drive into a bay, just under the Sata plug is a metal contact. And it gets pushed in when a drive is put in. When I put the 2.5" SSD drive in with the 2.5"-3.5" adapter, the drive doesn't reach the contact.

    I assume the contact is one if two things. A temperature sensor, or switch telling the computer a drive has been placed there.

    Could anyone confirm what it is and could this cause issues?

    Cheers.
     
  8. Johnnyizz thread starter macrumors newbie

    Joined:
    Sep 3, 2011
    #8
    heres an image
     

    Attached Files:

  9. handheldgames macrumors 6502a

    handheldgames

    Joined:
    Apr 4, 2009
    #9
    My samsung 470 is floating in dvd bay 2. Didn't waste time or $$$ on sleds. Not one issue
     
  10. Johnnyizz thread starter macrumors newbie

    Joined:
    Sep 3, 2011
    #10
    Good to see everything is working well for you. I don't have the option of using the second DVD space, I have 2 DVD drives. And I'm a bit weary about leaving things floating around not screwed down. So I wouldn't do that, unless I could get an adapter to screw it down secure..

    Anywho, everything is working well now.. Whatever was going wrong fixed itself lol. Happy camper :).
     
  11. phpmaven macrumors 68040

    phpmaven

    Joined:
    Jun 12, 2009
    Location:
    San Clemente, CA USA
    #11
    Sounds like it just wasn't seated properly in the drive bay. It happens with all of the dust and heat etc...
     
  12. WardC macrumors 68030

    WardC

    Joined:
    Oct 17, 2007
    Location:
    Fort Worth, TX
    #12
    I will say the same as said above. I had this issue with a Toshiba SSD I bought on eBay...I formatted it as Mac, but the partition map was MBR (Master Boot Record), which is the standard partition Map for Windows. It will boot on a Mac, but it will take longer to boot at startup. When you hold option at startup it will only recognize disks with the GUID partition map. GUID is what you need for intel Macs to be a bootable "Startup Disk" -- otherwise it will NOT show up in Startup Disk control panel.

    What you need to do is to backup your data, boot from another disk or from the System DVD disc, open Disk Utility, and then Choose your volume (120GB SSD, the volume, not "Macintosh HD" and then choose "Options" and click the "Partition" tab, choose 1 volume, and select "GUID Partition Map", then you can "Erase" -- it will partition your SSD as Mac GUID Partition Map, and make the disk/SSD recognizable in Startup Disk. Then you can restore your data or re-install your OS. I would recommend mirroring or cloning your disk to an external first, and then restoring the mirror to your SSD once you have it partitioned as GUID and erased, so all of your data is there. You will need to be booted from an External disk or System DVD to do the restore.

    I learned this the hard way, I went through like 4 or 5 restores and boot ups until I discovered that you need to reformat and repartition the SSD as GUID Partition Map to make it an Intel Mac recognizable boot disk.

    Good luck with this, I am sure this is probably your issue. If you have any questions about this whatsoever, I am here to help.

    Good luck,
    Ward
     

Share This Page