17" white iMac - Folder with question mark

Discussion in 'iMac' started by SPNarwhal, Nov 6, 2011.

  1. SPNarwhal macrumors 65816

    SPNarwhal

    Joined:
    Apr 22, 2009
    Location:
    illinois
    #1
    So I inherited a broken iMac, 17" white. When it turns on, it shows a gray screen with a folder that shows a ? and the Mac happy face. I know it means that it can't find or boot to the operating system, but don't know how to fix this.

    When I put an OS disc into the iMac, and hold C, nothing happens. I hold option and it boots to a screen that shows two squares, one is refresh, one is an arrow pointing to the right >

    I click both and nothing happens.

    I took the harddrive out and re-installed the OS to it, reinstalled it, nothing happens. The harddrive runs perfectly fine so no problems there.

    What gives?
     
  2. SPNarwhal thread starter macrumors 65816

    SPNarwhal

    Joined:
    Apr 22, 2009
    Location:
    illinois
    #2
    update: so I installed snow leopard to an external harddrive and tried to boot from there but it doesn't show up, nothing shows up, not a thumb drive, not a cd, not an external harddrive. All that can happen is one of the two thing.

    1.) It will give me the folder that blinks the question mark / happy mac

    2.) I can hold the Option key down and it brings me to a blue screen with a square on the left that has a refresh signal on it (circle with an arrow) and on the right it shows a box with an arrow pointing right >

    (Which I've now found to be this screen
    [​IMG]
    But without any of the boot options.)

    Those are the only two screens I can get to show up.

    I know that the USB Drives work, so not sure why it won't show the external harddrive or thumb drive. The optical drive should work, so don't know why it won't show a CD. And the Harddrive itself works, so I don't know why it won't boot up. The only thing I can think regarding the harddrive is that there's something wrong with the sata or power connection, but that's not the problem since it won't boot to anything else either.

    Help!
     
  3. tom vilsack, Nov 7, 2011
    Last edited: Nov 7, 2011

    tom vilsack macrumors 68000

    tom vilsack

    Joined:
    Nov 20, 2010
    Location:
    ladner cdn
    #3
    did you try resetting the pram?

    http://support.apple.com/kb/HT1379?viewlocale=en_US

    also try restting smc if above doesn't work

    Shut down the computer.
    Unplug the computer's power cord.
    Wait fifteen seconds.
    Attach the computer's power cord.
    Wait five seconds, then press the power button to turn on the computer.
     
  4. spacedrabbit macrumors member

    Joined:
    Nov 7, 2011
    #4
    Is this a 17" iMac G5? if so, you wont be able to boot to a Snow Leopard drive as it is not supported on a PowerPC iMac (older version). You can tell what model you have by taking the serial number of the iMac (on the bottom of the stand) and plugging it into support.apple.com.

    As for the CD... broken optical drive probably. I would try installing tiger/leopard to an external drive and trying to boot to that.

    And what OS did you reinstall on the internal HDD?
     
  5. SPNarwhal thread starter macrumors 65816

    SPNarwhal

    Joined:
    Apr 22, 2009
    Location:
    illinois
    #5
    Yeah it's a PowerPC model, and I finally got it to boot up on Leopard.
    Problem solved I guess, that and the harddrive had to be partitioned into Mac Bits or something like that. I still don't understand why it wouldn't acknowledge any connections though, external harddrive, cd, thumbdrive, internal harddrive.

    Anyway. It's fixed now! Thanks for the responses you guys.
     

Share This Page