2.0.1 Killed All My Apps - possible solutions for SOME

Discussion in 'iPhone Tips, Help and Troubleshooting' started by macduke, Aug 4, 2008.

  1. macduke macrumors 603

    macduke

    Joined:
    Jun 27, 2007
    Location:
    Central U.S.
    #1
    Updated thread title and adding this bit...this worked fine for me, only inconvenience so far is that I haven't used the app store on the iPhone. I will load some apps from this tonight to test. I have been stable for 4 1/2 days now, even with the original version of Netshare installed and various new app syncs to iPhone. Let me stress, I had really serious problems and tried all the troubleshooting tips I could think of and found online. I was doing a restore every night for about a week. Now I'm gold. The other setting I changed was using terminal to disable auto backups. On your mac open up terminal in the Applications > Utilities folder. Quit iTunes and type this into terminal and hit enter:

    Code:
    defaults write com.apple.iTunes DeviceBackupsDisabled -bool true
    Reopen iTunes and sync. It shouldn't take as long as it skips the backup. I was wondering if my constant canceling of the backups somehow corrupted the application data that was being copied over. You can still manually backup if you choose by right clicking or option clicking your iPhone on the left and selecting "Back Up". Its a handy trick that I love. I will try doing a backup 2 days from now after I have confirmed that the app store on the iPhone is fine. Then I will be back to normal iPhone use. I'm staggering my testing to make sure that things are stable to pinpoint the problem if anything new happens. I'm being as patient as I can with this. I'll list out real quick what I did EXACTLY to make it work, ever since the restore:

    1.) Did a restore the day before
    2.) Synced all files
    3.) Everything worked fine until the afternoon the next day, just like always
    4.) Held down an icon on the home screen until it wiggled, clicked on every (x) of every app. Halfway through iPhone reboots. Some of the deleted apps came back from the dead. About a 2/3 the way through it crashes again, reboots and have about 10 apps left. Delete the rest and reboot.
    5.) Went into iPod on iPhone and confirmed that media was back!
    6.) Made a list of all my apps so I could remember them
    7.) Deleted every app in iTunes except Netshare and phoneSaber...moved to trash
    8.) Went through my list and redownloaded them all
    9.) Used terminal command to disable auto backups and shut down iTunes and rebooted my MBP
    10.) Reopended iTunes and just synced new apps, not Netshare or phoneSaber
    10.) Everything stable for 2 days
    12.) Synced some new apps, only downloaded in iTunes
    13.) Installed Netshare, original file, stable for 2 days

    Future tests:

    14.) Will be testing iPhone app store downloads tonight to see if that corrupts the apps
    15.) Will try transferring purchases back to iTunes after 2 days
    16.) Will try a back up 2 days after that

    Hopefully the last 3 will work, then I will be 100% fixed. Right now I'm about 95%...just slightly inconvenient to always use iTunes to install.

    Last update:

    I think we may have found a solution!!

    After corresponding with Steve Jobs and Dan Erlewine, Manager, iTunes & iTunes Store Customer Experience, I think we may have found a permanent fix. At least until iTunes updates to 7.7.2...lol.

    Go through your iPhone and manually remove every single app by holding down on an icon until it wiggles and then press the (x) button on the corner of each one. Doing this was pretty buggy on my iPhone and needed two restarts to complete. Then go into your iTunes account and delete every single app. Before deleting, make sure that the app is still available in iTunes. Apps such as PhoneSaber and Netshare are now gone, so I saved those to test.

    Basically, updating to iTunes 7.7.1 corrupts some data in the app files...probably DRM which is why your iTunes media also disappears. After removing every app, before redownloading them with no 3rd party apps on my iPhone made all my media on my iPod reappear. After redownloading the new files to iTunes on my MBP (NOT IPHONE) they all worked again. It's been a little over 3 days now and everything is still working fine. Mind you, I was doing restores EVERY DAY so this is a good sign. I also reinstalled the NetShare app that I kept and thank God it wasn't corrupted. So apparently this only affects certain apps. As to which apps, I'm not sure. It may be random. Either way my apps and media are back!

    One thing that I have done though is I HAVE NOT USED THE APP STORE ON THE IPHONE. I will be testing this after I go another day using Netshare stable. There might be problems with the app store on the iPhone interfering with the DRM from 7.7.1. I have used the app store to browse apps and view them, but have only used iTunes on my MBP to install. So if you use this method and have problems, avoid the built-in app store.

    I hope this helps some of you that are going through iPhone hell right now. I feel for you and this could potentially be the fix you are looking for. Apple confirmed with me that before using this method, I had used every single troubleshooting technique that they could think of. Good luck everyone!

    - duke



    Here is my original post in this thread:

     
  2. iphone3g28 macrumors newbie

    Joined:
    Aug 4, 2008
    Location:
    Charlotte, NC
    #2
    Same thing here, not one App will work besides the ones that came with the phone. I've tried to remove and reinstall, but nothing is working.
     
  3. macduke thread starter macrumors 603

    macduke

    Joined:
    Jun 27, 2007
    Location:
    Central U.S.
    #3
    What apps do you have installed? Did you ever have a corrupt install that caused the iPhone to not be able to finish installing and did it give you a message about connecting it to iTunes to finish installing the update? This happened to me yesterday. After restoring it was fine but now its dead.
     
  4. eddiec312 macrumors 6502

    eddiec312

    Joined:
    Jul 19, 2008
    Location:
    Miami, FL
    #4
    Best thing for both you would be to just do a complete restore via Itunes.

    I updated to 2.0.1 and everything works fine for now. Funny though, I still got typing lag via SMS app only. Doesn't bother me all too much but Apple will get it right eventually right?
     
  5. Excellerator macrumors 6502a

    Joined:
    Aug 3, 2008
    #5
    Same problem here on my 3G, I also noticed that my Ipod mode has nothing in it. But according to Itunes its all still there. What do I do to fix that?
     
  6. macduke thread starter macrumors 603

    macduke

    Joined:
    Jun 27, 2007
    Location:
    Central U.S.
    #6
    Holy crap, I didn't even realize all my music and videos were gone too!! Alright, Apple, stop screwing up my phone every other day...dammit. This is getting to be effing ridiculous.
     
  7. Excellerator macrumors 6502a

    Joined:
    Aug 3, 2008
    #7
    I agree. This is ridiculous!!!! I have had this phone for only a couple weeks now and have had to restore it 3 times.
     
  8. macduke thread starter macrumors 603

    macduke

    Joined:
    Jun 27, 2007
    Location:
    Central U.S.
    #8
    It didn't used to be like this. I'm probably more tolerant because I've been using the iPhone since the first launch and know how great it is. I have just never had so many problems until 2.0 and my 3g. Its sad that you never got to use an iPhone that "just works" as the original one mostly did.
     
  9. Jase2008 macrumors newbie

    Jase2008

    Joined:
    Jul 9, 2008
    Location:
    Scotland UK
    #9
    Updated my firmware just now and fingers crossed all my apps and ipod content is there and workin fine.....


    Will update if this changes.
     
  10. doug0365 macrumors member

    Joined:
    Jun 23, 2008
    #10
    I wasn't so lucky none of my apps works.... they just open and close right away. I had to manually delete it from the my itunes & iphone and then install the app again and that seem to fix it. But The apps that I payed for like Enigmo and Solitare city charged me again for download. I thought you could re-download your purchases again?? I sent a email to apple about this.. Oh and by getting my apps to work I lost all my settings within the apps.. :mad: So far Iphone 2.0 has and still is buggy
     
  11. mcorf macrumors member

    Joined:
    Jul 25, 2008
    #11
    No issues with my wife's 2G or my 3G phone. Everything works fine.
     
  12. transer macrumors newbie

    Joined:
    Oct 19, 2006
    #12
    Same problem here. Preinstalled apps work just fine, but all third party apps crash immediately. iPod is empty too.

    What's most annoying for me is that my phone worked almost perfectly with 2.0, just a rare crash. Now very little works!
     
  13. hawaiiHEMI macrumors newbie

    Joined:
    May 24, 2008
    #13
    this happened to me with ver 2.0 and i tried to install ver 2.0.1 and still the same..
     
  14. Medic macrumors member

    Joined:
    May 31, 2008
    Location:
    London, UK
    #14
    Everything works fine on mine as well. Not had any of the problems described. 3G reception same, GPS works, everything in iPod...that others are experiencing such issues is more than strange. Have you jailbroken your iPhone by any chance? :rolleyes:
     
  15. jpvaz macrumors member

    Joined:
    Jun 25, 2008
    Location:
    Portugal
    #15
    I think i'm one of the lucky people out there...

    Firmware 2.0.1 toke less then 4 minutes to download, dispite the fact that it was a 250Mb file, toke about 15 minutes to install, didn't have to recover any data from a previous backup, didn't get any "corrupt backup file" messages like some people got, my app's didn't revert to previous versions like they did with some users that updated iTunes, all the apps are fully working, changing menu pages if way faster then before, boot time is way less then before....

    Now i just need time to test out the other 2 major problems i had, GPS accuracy and SMS/EMAIL dictionary (could not personalize it, and teach it new words).

    All in all... i'm happy.... for now....

    Update: the 2 major problems i had are not solved. If i type the letter A it still changes it to AO as it does with several other letters and words despite the fact that i press the little X when it tries to correct the word, and now the GPS does not work 95% of the time, and when it works it has a accuracy margin of over 1 kilometer....

    All in all... i'm not very happy... for now...

    [​IMG]
     
  16. macpbr98 macrumors newbie

    Joined:
    Mar 21, 2008
    #16
    Me too! >:-(

    Uggh - me too...

    Apps don't launch except the pre-installed ones. iPod Library is completely gone but they all show up and play fine within iTunes (using the files in my iPhone)

    GPS didn't work at first but then I did a reset using preferences. But still have no apps working.

    Did another reset but manually - hitting the power button and home buttons for 10.

    Most apps still crashing some work now like tip but most apps totally crash.

    Doing a restore now...

    >:-(
     
  17. Excellerator macrumors 6502a

    Joined:
    Aug 3, 2008
    #17
    I did a restore and all is much better now. I wonder if there is some sort of bug in the upgrade process???
     
  18. transer macrumors newbie

    Joined:
    Oct 19, 2006
    #18
    I finally was able to get apps working. In iTunes, with the iPhone connected, I selected the restore option, which reset my phone back to the factory settings. I then restored from a backup, and viola (well, after 30 minutes of waiting) everything appears happy again-not a single app crash since.
     
  19. macpbr98 macrumors newbie

    Joined:
    Mar 21, 2008
    #19
    I finished the restore and re-synced all my apps.

    All seemed to be working just fine. I was reconfiguring my apps (logging into my accts) etc.

    And just out of nowhere, my iphone is busted again! :-(

    Apps are showing the first screen and then shutting back down. Exact same symptoms as before.

    UgggggghhhhH!!!
     
  20. iphonics macrumors member

    Joined:
    Aug 4, 2008
    #20
    hey all, i talked to some one at iphone support and they walked me through some steps to 'FORMAT' the iphone... note: you WILL lose everything including CONTACTS... but it works perfectly now and its super quick!!!
    if you wanna try it its SETTINGS>GENERAL>RESET>ERASE CONTENT AND RESET SETTINGS..... takes about an hour! plug it into itunes and it will automatically update to 2.0.1 MAKE SURE YOU SELECT .... SETUP NEW IPHONE!!!!! and then everything will work... it did for me at least!
     
  21. ewiley28 macrumors newbie

    Joined:
    Jul 7, 2008
    Location:
    Austin, TX
    #21
    Don't get too excited though. I've done that and the problem came back after I installed 3rd-party apps again. Based on what I've gotten from apple support and genius bar, the only thing you can do is not install any 3rd-party apps on your phone (included ones that apple took money for as well). The genius guy also recommended not setting up mobile me to sync with the phone because that was one of the things they were looking at as a possible cause.

    This really doesn't sound like a viable solution to me. But, what else can you do? I haven't seen any reference to this error in blogosphere or news or any acknowledgment by Apple that it exists. It seems to be pretty recognizable (the part where your phone reads as having no content in the iPod, but the space is still taken up from the stuff you synced seems to be the identifying feature), but maybe it's in a small component of phones? I'm really surprised that those who are reviewing apps for blogs have not mentioned the problem because they likely have had and do have a lot of apps on the phone.
     
  22. macpbr98 macrumors newbie

    Joined:
    Mar 21, 2008
    #22
    So what the heck is going on then? This is huge. And it is absolutely ridiculous for Apple (or anyone else) to say don't download non-native apps! I really hope Apple fixes this...
     
  23. mrgoat macrumors newbie

    Joined:
    Jul 23, 2008
    #23
    Exact same thing happened to me yesterday and today. pulled the phone out of my pocket, tapped an app, and it crashed. GPS thought it was about 600 miles away and all of my music | podcasts | videos were "unavailable" but i only had 8 gb of free space. Something is definitely screwed up in the new patch. Also none of my backups will work to restore the phone (even those made after the upgrade) so i have to set it up new each time. :mad:
     
  24. andyblila macrumors 65816

    andyblila

    Joined:
    Jul 8, 2008
    Location:
    On My iPhone, or my iPad?
    #24
    I plugged in the iPhone downloaded the update and installed. No problems whatsoever. Every App works and the lag times are gone. Plus reception is up. I did reset the phone after the install. :D:apple::D
     
  25. ewiley28 macrumors newbie

    Joined:
    Jul 7, 2008
    Location:
    Austin, TX
    #25
    Is your iTunes 7.7.1? That's actually my current theory about what's wrong with them based on what I've read today. It went up late late Thursday night and these problems started being reported Friday.

    Now, this could very easily be wrong, and if you are still using 7.7.0 and have this bug, I'd love to hear it because it means this theory is wrong.

    I haven't taken the time to find the file and go through the process of downgrading to 7.7.0 to see if it fixes the issue, but it definitely is something I'd recommend trying if you're stuck.
     

Share This Page