2.1 not good enough. Still lagy, still crashing

Discussion in 'iPhone' started by Nickb, Oct 9, 2008.

  1. vega07 macrumors 65816

    Joined:
    Aug 7, 2006
  2. ucfgrad93 macrumors P6

    ucfgrad93

    Joined:
    Aug 17, 2007
    Location:
    Colorado
    #27
    Same here.
     
  3. jaduffy108 macrumors 6502a

    Joined:
    Oct 12, 2005
    #28
    ditto...no issues for me. Sorry to hear you folks are having problems.

    Stop the hate....Obama 08!
     
  4. CocheseUGA macrumors member

    Joined:
    Aug 27, 2008
    #29
    I am too. Safari crashes the most on forums, trying to reply.

    I can't believe this hasn't been fixed yet.
     
  5. question fear macrumors 68020

    question fear

    Joined:
    Apr 10, 2003
    Location:
    The "Garden" state
    #30
    I have all sorts of weirdo bugs, and I am on an original iPhone (4gb)

    1) Safari crashes: usually after more than 15 minutes of prolonged use. Not often that I use it that much, so it's a minor point.

    2) Lag in the UI. If I haven't rebooted recently, this happens every time I switch apps or return to the home screen. Very annoying.

    3) Phone app/SMS/Mail lags: Argh. Wildly unpredictable, except that if I need to call someone or answer an important text or email, its pretty much a lock that there's a delay.

    4) Twice now reboots have ended with a "connect to itunes for activation" message. The first time I freaked, turned it off and then back on, and it was fine (and I got a pop up that said "iPhone is activated.") It happened again the other night but I wasn't surprised by it this time and the same thing happened (reboot got me back to normal). What worries me is why this happens...

    5) App store "quirks". Never knowing if it's going to let me download an app or just leave me in an endless loop of buy/install/buy/install/buy/install where the stupid install button turns back into buy, and then eventually it just tells me the store is unavailable. Buh?

    So even v1 iPhones are not immune to the strangeness.
     
  6. fluff macrumors member

    Joined:
    Jan 2, 2008
    #31
    1st Gen

    1st Gen running 2.1 is about as solid as it gets, dont know if I would ever want to change. Love the quickness of installs BTW.....
     
  7. ob81 macrumors 65816

    ob81

    Joined:
    Jun 11, 2007
    Location:
    Virginia Beach
    #32
    Not for me. It has been fine thus far. No dropped calls or anything. *Crosses fingers*
     
  8. Ninja Dom macrumors 6502

    Ninja Dom

    Joined:
    Feb 12, 2007
    #33
    I'm another one. While I believe that 1.1.3 was the champion firmware, 2.1 is running fine so far for me.
     

Share This Page