2006/2007 Mac Pro (1,1/2,1) and OS X El Capitan

Discussion in 'OS X El Capitan (10.11)' started by Mr. Zarniwoop, Jun 8, 2015.

  1. flyinmac macrumors 68040

    flyinmac

    Joined:
    Sep 2, 2006
    Location:
    United States
    #3926
    It would be interesting to find out if there are any modules / api’s, coding, etc. in the rest of the 2018-001 update that have any dependencies on the updated kernel.

    It could be that the kernel portion is more stand alone and only addresses the cpu vulnerability.

    But if the updates are meant to work together, then we could have a potential problem somewhere.

    I’d be curious if we could come up with a hack similar to Boot64 that would prevent the kernel from being overwritten. Or even possibly script it to put the old kernel back prior to reboot or during reboot.

    Like a boot audit that interrupts the startup long enough to verify the kernel, and replaces the kernel with the old one if it determines that it’s not there. And then rebuilds the links as needed.
     
  2. jbarley, Jan 28, 2018
    Last edited: Jan 28, 2018

    jbarley macrumors 68040

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #3927
    Might be of interest to some, this 2018 update fails even on my so called El Capitan supported MacPro3,1.
    Same ole "boot-loop", same kernel swap needed to fix it.
    edit:
    found a workaround for this, cloned a fully updated El Capitan system complete with ehe 2018-001 security update from my wife's laptop to my MacPro 3,1 and it works.
    Now just have to do some cleaning up and get rid of all her "stuff".:(
     
  3. plentyoftimeto69 macrumors member

    plentyoftimeto69

    Joined:
    Jul 15, 2016
    Location:
    Tampa
    #3928
    Took the 2018 pactch on my 2,1 and borked it. Easy fix is to create a Pikify USB boot, extract the 2017 kernel from the 005 patch, copy it to the Pikify disk, then boot the Pikify in the Mac Pro. You have to remount /Volumes/Macintosh HD as read/write and then you can use the Terminal util on the install disk to copy over the Kernel. Follow the steps in the previous how-to, just adjust paths as needed.
     
  4. Mystere65 macrumors newbie

    Mystere65

    Joined:
    Nov 2, 2015
    Location:
    Firenze (Italy)
    #3929
    And for the next updates? In practice, the Mac would become a Hackintosh
     
  5. rthpjm, Jan 29, 2018
    Last edited: Jan 29, 2018

    rthpjm macrumors 6502a

    rthpjm

    Joined:
    Jan 31, 2011
    Location:
    U.K.
    #3930
    The next Security Update will most probably contain the same "problem" kernel file, or another updated kernel with similar issues.

    I agree that we are now "hacking" the OS to keep "up to date". However, as I stated earlier rolling back the kernel seems to work, but may introduce unexpected behaviour due to incompatibilities, now or at some point in the future.

    Having decided that the issue lay with the kernel file, I gambled that the changes were going to be specific for MacPros that are affected by Spectre and Meltdown. I assumed the changes to the kernel were unlikely for other aspects, therefore rolling back to the previous kernel would be a workable solution. My assumption is that Apple rarely change the kernel, and that they would not necessarily change the El Capitan kernel beyond what was absolutely deemed necessary since it is 2 generations older than the current OS that is in development (High Sierra). I did no NO investigation, I guessed. I do NOT know what the impact will be. There was no code-base to check (although I might go and take a look at the Open Source web site later, just from professional curiosity).

    The "safe" thing to do is to stop at 10.11.6 and the all updates up to and including Security Update 2017-005. This is no different to many end-of-life situations. The MacPro 1,1 and 2,1 should have stopped at 10.7.5. All of the work that has happened since has enabled us to continue to operate with the newer versions of Mac OS X up to El Capitan. Those of us that chose to do so have been operating "at risk".

    Ultimately, only you (the person reading this) can make the decision about what level of risk you are willing to take.
    --- Post Merged, Jan 29, 2018 ---
    Exactly!
    --- Post Merged, Jan 29, 2018 ---
    I'll take a look. If I can I will update Boot64.

    Warning: don't hold your breath!
     
  6. dreamersofeden macrumors member

    dreamersofeden

    Joined:
    May 26, 2011
    Location:
    Spain
    #3931
    Well,

    I got my borked Mac Pro 2,1 back to work simply by taking the kernel from my sister's iMac with 2017-005 update installed. I did the touch thing ("sudo touch /System/Library/Extensions") ando also verified and repaired disk permissions.

    Now, the only issue I'm having is that when installing nVidia Web Drivers, it fails since the kernel is "untrusted".

    This is what log shows:

    How can I force system to make that swapped kernel trusted?

    Thanks in advance and hope we can make this badass aluminum machines live longer!
     
  7. rthpjm macrumors 6502a

    rthpjm

    Joined:
    Jan 31, 2011
    Location:
    U.K.
    #3932
    • Boot into your Recovery HD
    • Turn off SIP
    Code:
    csrutil disable
    • reboot to your usual MacOS
    • use a Terminal
    Code:
    sudo -s
    {type your usual password}
    cd /System/Library/Kernels
    chflags restricted kernel
    
    • reboot into your Recovery HD
    • Turn SIP on
    Code:
    csrutil enable
    • reboot to your usual MacOS

    Try that. There's no guarantee. Nvidia may be checking independently, we're in an odd situation now, the kernel will be older than expected.
    --- Post Merged, Jan 29, 2018 ---
    Hmm, replying to myself. Is that the first sign that I'm going MAD!
    o_O:p

    Anyway, The Open Source web site has not yet been updated (as far as I can see).

    I took a closer look at the two kernels. There are some new functions (symbols) and some existing symbols are changed/moved in the binary

    New symbols
    _NMIPI_enable
    _cpshadows
    _cpu_data_master
    _dblallocs
    _dblmapL3
    _dblmap_base
    _dblmap_dist
    _dblmap_max
    _dblsyscall_patch_point
    _doublemap_init
    _dyn_dblmap
    _dyn_ldts
    _hdescseg
    _idt64_unix_scall
    _idt64_zero_div
    _ks_32bit_entry_check
    _ks_64bit_return
    _ks_dispatch
    _ks_dispatch_kernel
    _ks_dispatch_user
    _ks_idt64_debug_kernel
    _ks_idt64_nmi_kernel
    _ks_kernel_trap
    _ks_return
    _ks_trap_check_kernel_exit
    _ldt_alias_offset
    _mldtsz
    _npz
    _pcid_data
    _pmap_alias
    _pmap_uanchor_zone
    _scdatas
    _scdtables
    _scfstks

    changed/moved symbols
    __intr_0x20
    :
    : There is a large number of these symbols, presumably interrupts. The symbols increment in number
    :
    _hi64_syscall
    _hi64_sysenter
    _idt64_alignment_check
    _idt64_bounds
    _idt64_db_task_dbl_fault
    _idt64_db_task_stk_fault
    _idt64_debug
    :
    : There are a large number of these idt64 prefixed symbols
    :
    _master_ktss64
    _master_ldt

    The new NMI PI (non-maskable Interrupt) seems to me to be the most likely candidate for our troubles... Those with more chip/hardware experience might be able to throw more light on the subject...
     
  8. Macschrauber macrumors regular

    Joined:
    Dec 27, 2015
    #3933
    I made a copy of my El Capitan (pre Security update 2018-001) and fiddled a bit:

    in few words: Backed up the old Kernel to Desktop, run the Security update 2018-001, rebuild in Recovery)



    >
    before security Update 2018-001

    reboot in recovery


    open Terminal:

    csrutil disable


    reboot into system


    open Terminal:

    cd /system/library/kernels
    cp kernel ~/desktop


    do security Update 2018-001


    after security Update 2018-001

    bootloop, shut down,


    boot into recovery

    in Terminal:

    mount -uw /
    touch /volumes/yourharddrivename/System/Library/Extensions
    cd /volumes/yourharddrivename/System/Library/Kernels
    cp kernel kernelsecurityupdate

    (just to have a backup)

    rm kernel
    cp /volumes/yourharddrivename/Users/yourusername/desktop/kernel kernel



    (reboot)

    (System got up)

    nvidia driver was disabled - as I had a supported GPU in it asked for an update without glitch
     
  9. Xenomorph macrumors 65816

    Xenomorph

    Joined:
    Aug 6, 2008
    Location:
    St. Louis
    #3934
    Thank you for the updates! I had to look up this thread again after my Mac Pro went into a boot loop from the 2018-001 update.

    I was able to get back up and running:

    * booted to 10.7 / Lion on another partition
    * download the El Capitan 2017-005 update
    * extracted the 2017 kernel from it using Pacifist
    * copied the 2017 kernel over the 2018 kernel on my El Capitan partition
    * ran 'touch /System/Library/Extensions' on the El Capitan partition

    My system booted right back into 10.11!
     
  10. Macschrauber macrumors regular

    Joined:
    Dec 27, 2015
  11. Mystere65 macrumors newbie

    Mystere65

    Joined:
    Nov 2, 2015
    Location:
    Firenze (Italy)
    #3936
    Restoring the old Kernel I would not consider it a real solutiono_O
     
  12. mani girafe macrumors member

    mani girafe

    Joined:
    Aug 12, 2016
    Location:
    FRANCE
    #3937
    So for my part, I just made the updates SAFARI and ITUNES, hidden the 2018-001 while waiting for a solution.

    Otherwise I cloned my hard disk, and I will try the update soon. We'll see about that.
     
  13. Morpheo macrumors 65816

    Morpheo

    Joined:
    Feb 26, 2014
    Location:
    Paris/Montreal
    #3938
    For me the it's not worth the trouble, considering these chips are not even affected... If 2017-005 is the last security update to be installed on my 2006 Mac Pro, so be it! :)
     
  14. Inspector42, Jan 30, 2018
    Last edited: Jan 31, 2018

    Inspector42 macrumors newbie

    Inspector42

    Joined:
    Nov 8, 2015
    Location:
    Germany
    #3939
    I have to admit that my knowledge has become quite rusty as the last time I did hard core assembler programming and processor boards design was in the times of the 8086. However I took the plunge, downloaded the https://software.intel.com/sites/default/files/managed/39/c5/325462-sdm-vol-1-2abcd-3abcd.pdf and started reading. Now in the old days NMIs were triggered by a signal to one of the processors I/O pins only, the modern processors allow a software trigger (INT n, where n=2 triggers the NMI). That has been available since the Pentium days at least.
    Don't really know, for what that non-maskable interrupt is used for in a Mac, in the old days it was used to drive the display routines that needed to adhere to Tube-TV timing.
    So without gaining any insight into where the interrupt vector tables are stored and what addresses they contain, this is a dead end for me.
    Someone posted that the verbose mode did not really reveal any useful hints regarding the cause of the reboot either and I don't know, if there is more information logged elsewhere.
    The only other hint I saw in the postings was the case where the same boot loop occurred on a compatible MacPro3,1 - but the solution of cloning another hard disk form a compatible laptop does also not ring any bell.

    So in conclusion, a lot of words but no real progress :(

    Update: Found some more documents and it seems the NMI in a MacPro is triggered either by ECC-RAM errors or in debug-mode.
    https://developer.apple.com/library/content/qa/qa1264/_index.html
    I have not found any circuit diagrams to get more info about involvement of the SMC in this.
     
  15. the bug macrumors regular

    the bug

    Joined:
    Feb 21, 2014
    #3940
  16. prosinader macrumors newbie

    Joined:
    Nov 7, 2008
    Location:
    Iowa
    #3941
    Hello, I am having the same issue of reboot loop after updating to the security update (didn’t even think about it until the problems started). To protect against updates, I’ve always maintained a second hard drive with 10.11 on it to copy the EFI file back when things don’t work.

    Naturally, I (still without thinking) booted into my “backup OS” and copied the EFI file and tried booting and still had the reboot loop.

    So, my question is - can it be saved still using my backup OS drive? Is it as simple as copying the kernel over?
     
  17. joeberk macrumors newbie

    Joined:
    Feb 20, 2016
    #3942
    Like a few others, the kernel copy seems a bridge too far and it looks like I should start saving to replace my old Mac Pro 1,1 with a newer machine that isn't older than both of my children.

    I share this because I wanted to offer a heartfelt THANK YOU to everyone who has invested time and effort to create and share the tools needed to keep old Mac Pros running for this long.
     
  18. Inspector42 macrumors newbie

    Inspector42

    Joined:
    Nov 8, 2015
    Location:
    Germany
    #3943
    Good catch - however I am afraid it is just a coincidence.
    Those reboots happen randomly after installing the Intel provided microcode updates for the processors through Firmware of the computers/mainboards. The only firmware update included in the security update 2018-001 for the MacPros was for the 6,1. Those are based on Ivy Bridge architecture and considering the struggle Intel went through to provide those updates to the more recent processors suggests that there are no microcode updates for Ivy bridge included, but that is just my 5 cents.
    --- Post Merged, Jan 30, 2018 ---
    The culprit is not a replaced boot.efi by the update.
    There seems to be an incompatibility with the updated kernel - only option for now is rolling back the kernel.
    Please follow instructions in post #3896 by @rthpjm.
     
  19. Rocketman83, Jan 31, 2018
    Last edited: Jan 31, 2018

    Rocketman83 macrumors member

    Joined:
    May 29, 2015
    Location:
    Skaneateles, NY
    #3944
    After I encountered the boot loop issue, I used Recovery Mode to restore my pikified Mac Pro 2,1's main drive from Time Machine. I chose a dated backup created shortly before I had installed the problematic security update. I knew it was a risky move, but I restored onto my El Capitan OS drive (rather than a fresh drive) effectively erasing everything on it. (If I couldn't boot into the El Cap drive, the data on it wasn't much use to me anymore anyway.) Long story short, the restore worked pretty seamlessly. I was back up and running in maybe 3 hours. I cleared the PRAM on my next reboot. It hiccupped a bit during the boot up process, but eventually booted up normally. After several days now, my machine seems to be working perfectly. I have since hidden all Apple updates on the App Store.
     
  20. nebojsak, Jan 31, 2018
    Last edited: Jan 31, 2018

    nebojsak macrumors newbie

    nebojsak

    Joined:
    Jan 2, 2014
    Location:
    Belgrade, Serbia
    #3945
    Got stuck in a boot loop twice before reading this thread updated. Fortunately I have been able to boot into recovery mode and then boot from Time Machine backup, then install Safari and iTunes updates manually. Everything is working fine by now, except the boot screen is now black with a white Apple logo, and it used to be old white one. Any ideas on it? o_O

    edit: Radeon 5770 original one from OWC, not a PC version
     
  21. Argyboy macrumors newbie

    Argyboy

    Joined:
    Feb 26, 2017
    Location:
    Dublin, Ireland
    #3946
    You can still continue to use this machine on El Capitan. As others have said, we've been running an unsupported OS since 10.7.5. No reason to stop now, really, especially seeing as our Xeon chips don't seem to be affected by the recent security issues.

    Or, why not just install Windows 7/10 on it? I've had both Windows 7 and Windows 10 on my 2,1 and they both run great. Lots of life left in these machines yet!
     
  22. joeberk macrumors newbie

    Joined:
    Feb 20, 2016
    #3947
    Oh, I'll keep using it, but in a year or two ... too many of the apps I use will no longer support El Cap. I'd rather save up some money and be ready when the right machine or deal comes along ... heck, if I save up waiting for a new Mac Mini, I might be rich by the time a new model is actually released...

    I spent $250 on my 1,1 a couple years ago and probably spent $200 on WiFi, Bluetooth, better graphics, and a couple drives. I got my money's worth and then some.

    I'm not that desperate! I get enough Windows at work! ;)
     
  23. chrisinoakland, Jan 31, 2018
    Last edited: Feb 1, 2018

    chrisinoakland macrumors newbie

    chrisinoakland

    Joined:
    Mar 23, 2016
    #3948
    Thank you! This was exactly the quick info I needed after rather clumsily applying the 2018-001 update earlier this evening. My steps were even easier as I had a backup of the previous kernel file (CCC saves the day).

    You (and all the others that worked through this issue) got me back up and running really quickly!

    Oddly, I am now experiencing my MacPro's 1,1 internal Bluetooth not being found with this update installed; it's reporting "Bluetooth: Not Available" but I can live with that for now until I can suss that out.

    Thanks again everyone. This thread has kept me happily using my 1,1 far longer that I would have ever expected.
     
  24. Mjsais macrumors member

    Joined:
    Feb 29, 2012
    #3949
    ---------------
    Did the safari update worked? I hid all the updates in order o prevent an accidental problem.
     
  25. waimtrp macrumors member

    waimtrp

    Joined:
    Sep 20, 2008

Share This Page