2008 iMac bad graphics card cause failure to boot?

Discussion in 'iMac' started by JonCosman, Jun 7, 2016.

?

Logic Board or Graphics Card?

  1. Graphics Card

    1 vote(s)
    100.0%
  2. Logic Board

    0 vote(s)
    0.0%
Multiple votes are allowed.
  1. JonCosman macrumors newbie

    JonCosman

    Joined:
    Jun 5, 2016
    Location:
    Saint John, NB
    #1
    Hello everyone. New to to the forum.

    I just got a new logic board off eBay. Doesn't come with the Graphics Card but I have one. I cannot seem to get the system to boot unless into Safe Mode. I can do things like surf web but there are purple lines and pink screen at startup / very slow. Replaced Hard drive, no luck, cleaned logic board for signs of corrosion near power source. Seemed to be only spot. Fired it up and still pink screen with apple logo/loading bar then grey screen till infinity.

    Anyone know if this is just the logic board or would it be Graphics card too? I think its just the Graphics card.

    **I also have all 4 led lights turned on at startup**
     
  2. havokalien macrumors 6502a

    havokalien

    Joined:
    Apr 27, 2006
    Location:
    Kelso, Wa
    #2
    lines on screen are graphics. It may be the cable connection is damaged but thats still a graphics issue.
     
  3. JonCosman thread starter macrumors newbie

    JonCosman

    Joined:
    Jun 5, 2016
    Location:
    Saint John, NB
    #3
    Thanks for reply. I ended up removing Logic board and then removed the GPU. soaked it in Isopropyl Alcohol and then baked it for 10 minutes at 375 Fahrenheit. (I know what your thinking haha). Anyway it worked and the machine runs like new. Too bad i ordered a new logic board for nothing. 50$ but still. Im in Canada so, I'll be able to sell it for a loot more haha.

    Cheers.
     

Share This Page