2010 mbp SSD OSX Install Problems

Discussion in 'macOS' started by nissin, Jun 22, 2016.

  1. nissin macrumors newbie

    Joined:
    Mar 19, 2008
    #1
    I’m working on replacing the hdd on my friend’s 2010 or 2011 13” mbp- it still has an optical drive. It began when the laptop had trouble booting, sometimes it would hang on the progress bar when booting, other times it would boot and he could log in, but Finder would consistently crash rendering it unusable. He took it into an Apple store and they ran a hardware test and said he should think about backing the drive up if possible and replacing, but everything else tested fine.

    He brought it to me and asked if I could swap out the standard hdd for a ssd. We decided it was best just to do a clean install and drag whatever files he still needed over separately.

    I first plugged an Ethernet cable in, did a cmd+opt+r boot, and went to do an internet recovery. It loaded for about 5 seconds, then failed and displayed “apple.com/support” then underneath, it displayed “6002F”. I never found what this meant on the internet, but later when I spoke with an Apple tech, they said the error relates to hard drive, but never said how.

    I turned off the computer, then did simply a cmd+r boot, that ended the same way. I never get to the disk utilities window.

    I then tried a booting while holding “C” to boot from media (which is a thumb drive with Yosemite install files because that’s what I had handy). This will show a menu with an option to connect to a wireless network, then the only to boot is “Install Yosemite”. I choose that, and the Apple logo is displayed, then it loads/installs halfway and then hangs. I’ve left it alone overnight to see if it was just taking an incredible amount of time, and little to no progress was made.

    I then tried booting while holding the “Option” key to go to a disk select menu, and this just automatically goes into the Apple logo, then it loads halfway and fails.

    I have also reset the NVRAM and MC and repeated all of these different boot options, still with no success.

    Another oddity is that the SSD will not show when plugged into a usb dock, in either Win or OSX. It will show and format just fine when installed on a Win 10 machine and connected to the mobo via SATA cable. It may be because my dock is almost 7 yrs old? I have attempted to install OSX on the SSD with it only partitioned and not formatted, then also with it formatted as exFAT. Both yield the same result.

    Yet another facet to this mess is that I have once again repeated all of these options with a spare 2.5” hdd that I had lying around, and get the same results. It will show just fine in the usb dock though, in either OS, for what it’s worth.

    I’ve heard that holding cmd+L during an install hang will show you the log file of what it’s working on, however, I have not gotten that to work yet.

    I have also tried booting into terminal, then installing by an installer -pkg command, but I can't seem to get it correct as I get an error saying what I'm typing is not a command.

    My two options going forward are to install OSX on the spare 2.5 hdd via USB dock with a working MBPr, then attempt to install the SSD and boot it in the old laptop. I would get a replacement SSD from Samsung just to remove that as a factor. The other option is to boot the old laptop into target-disk mode with the SSD in place, and attempt to install OSX from my MBPr.

    It’s almost personal at this point to get the laptop running, but I’m in dire straits. If these last two options don’t help, I’m not sure what I have left other than to send him back to the Apple store.

    Any ideas? Sorry for the ridiculously long post



    TL/DR:

    Can’t install OSX on Samsung Evo 850 in 2010/2011 mbp. Tried basically everything. Any ideas?
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    You need to format the SSD as Apple Extended Format (Journalled) with a GUID partition map if you want it to be bootable. Macs will not boot from disks partitioned in a Windows format like ExFat.
     
  3. nissin thread starter macrumors newbie

    Joined:
    Mar 19, 2008
    #3
    I would have done that if the laptop would've seen the ssd, which it never did. However if I plugged it into my windows machine it showed up right away and was able to be formatted. The Apple tech I was on a chat with said if it wouldn't show in Mac normally, I could format it as exFAT in Win then during install, the OS would see it and reformat it. I never got to the Disk Utility window to format during install though.
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    All of the unibody MacBooks and Macbook Pros are prone to having problems with the cable that connects the disk to the computer. You can pretty much verify this by putting the new SSD into an external housing, and most likely the install will complete successfully there.
    iFixit sells the cables but you may be able to find them elsewhere for less.
     
  5. nissin thread starter macrumors newbie

    Joined:
    Mar 19, 2008
    #5
    Tried that. External wouldn't help the SSD show up in OSX. It showed up immediately in Win10. Other disks worked in the external dock.
     
  6. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #6
    Time to put the non-working SSD into the drawer, and try a different SSD, I reckon ...
     
  7. nissin thread starter macrumors newbie

    Joined:
    Mar 19, 2008
    #7
    That's what it sounds like. He's taking it into the shop this week. I'd sort of be surprised if it's the drive, I'm wondering if (hoping) a cable is bad like chrfr said.
     

Share This Page