2011 Mac Mini power LED does not turn on

Discussion in 'Mac mini' started by micrors4racer, May 23, 2012.

  1. micrors4racer macrumors 6502

    Joined:
    Apr 19, 2012
    #1
    I just picked up a used late 2011 Mac Mini base model with 8 gigs of ram. It was restored before I bought it. Everything works fine on it but the front LED does not light up white. Is there a setting for this or could it be a hardware problem? It is still under warranty until August.
     
  2. FrankHahn macrumors 6502a

    Joined:
    May 17, 2011
    #2
    Probably, the Power/Infrared connector is loose or broken. This connector is pretty fragile. When the logic board is pulled out, this connector may be broken. If it is still under warranty, you can just take it back or take it to a genius.
     
  3. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #3
  4. micrors4racer thread starter macrumors 6502

    Joined:
    Apr 19, 2012
    #4
    Yea its still good until August so i'm covered. I have only ever warrantied iDevices and with those you get a brand new one at the store if theres any hardware problems. How does it work with a Mac?
     
  5. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #5
    i use the apple website to setup an appointment at the apple store at my local shopping mall. i bring the gear in and they let me know if it can be fixed or if they want to give me a new piece of gear.


    If you have a long time on the warranty I would wait to fix it. my logic is if a 2012 mac comes out and you need a replacment you may get a 2012 mac vs a 2011
     
  6. micrors4racer thread starter macrumors 6502

    Joined:
    Apr 19, 2012
    #6
    That makes sense. Has that ever happened to anyone before?

    How does the warranty for the new mac work? If I warranty it now will the new mac still only have warranty till august or is it another 1 year or 90 days.
     
  7. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #7
    getting a new mini for an old one has happen to me 2 times. I am not a normal user of minis in that I buy them and upgrade them then sell them. So I have had 200 plus minis in the last 6 years. Not many go bad I may have had 6 bad minis out of the 200.

    as for the second question I am not sure if you mean the mini you have on hand. you said the warranty was good until august of 2012. If it is repaired and returned. it will be under warranty until august 2012.

    If it is replaced the replacement will be covered until august 2012. You do have the option to add applecare 2 more years gets tacked on.
     
  8. minik macrumors 65816

    Joined:
    Jun 25, 2007
    Location:
    Bellevue, WA
    #8
    I have the same IR/LED board malfunctioning on my Mid-2010 Mac mini server too. However, I didn't purchase AppleCare on this refurbished unit. Let's see how it goes tomorrow at the local Apple Store.

    Last year, they replaced the logicboard and yet messed up the serial number.

    As last check, the 922-9558 Infrared Board w/cable costs $9 from Apple.

    That Apple part works with Mac mini Server (Mid 2010),Mac mini (Mid 2010),Mac mini (Mid 2011),and Mac mini Server (Mid 2011).
     
  9. micrors4racer, May 25, 2012
    Last edited: May 25, 2012

    micrors4racer thread starter macrumors 6502

    Joined:
    Apr 19, 2012
    #9
    Update us on what happens. Good luck!


    Since I bought this used and the ram is upgraded to 8tb and I don't have the original 4gb would it be a problem? If apple were to replace the logic board or whole machine can they give me back my upgraded ram and they can keep the stock ram?
     
  10. minik macrumors 65816

    Joined:
    Jun 25, 2007
    Location:
    Bellevue, WA
    #10
    Turns out there's a lose connection between the cable and the logicboard socket. The connector goes in between the RAM slots and fan after you open the cover. The Genius used a black stick to secure them and he's surprised it booted up normally before the fix.
     
  11. iamsen47 macrumors regular

    Joined:
    Aug 18, 2012
    Location:
    Kobe, Japan
    #11
    Not really related, but I would like to disable the LED.

    Is it an un-wise thing to do?
     
  12. NIPRING macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Waukesha WI
    #12
    Well, i can tell you (as someone with a brand new late 2012 mini) my led doesn't work because i damaged the connector base on the logic board while adding a second internal drive :(. The IR still works, in fact everything seems to be working fine except the LED. Seeing as I just paid $1K for this mini, it kinda bugs me. I dont know if just unplugging that connector all together would have the same result or if the LED and ??? would not be working. If there is more than just the LED to that connector, I dont know.
     
  13. Jeknight macrumors newbie

    Joined:
    Sep 3, 2013
    #13
    Thanks! I was able to fix my LED not working.

    The LED on my MAC was not working after Apple Store replaced the logic board again; the first replacement had a graphics issue. I was hoping I wouldn't have to drop off the MAC mini AGAIN, so I am glad I saw this thread.

    Thanks to minik, I was able to open the cover and see that the connector was not fully seated (I has to be pushed flat using a small flat tool tip.) once I did that, I powered up and all is well!!! Thanks again minik!
     
  14. minik macrumors 65816

    Joined:
    Jun 25, 2007
    Location:
    Bellevue, WA
    #14
    Oh good! The connector is getting tinier these days.
     

Share This Page