2011 Macbook Pro 13 + Crucial C300 256GB SSD

Discussion in 'MacBook Pro' started by LS417, Mar 18, 2011.

  1. LS417 macrumors regular

    Joined:
    Oct 30, 2009
    #1
    I recently purchased a 2011 Macbook Pro 13in, the i7 flavor. Also purchased a crucial C300 256GB SSD to go along with it.

    I've been pulling my hair out for the last 2 days trying to get this combination to work.

    Regardless of what I do I can't get OS X to finish an installation on this drive. I've tried resetting SMC, NVRAM, and PRAM.

    I've run the drive through every diagnostic software I can find and it reports clean every time.

    After an extensive google search, I've noticed ALOT of people having issues with the 2011 13in mbp + SSD drives, namely the crucial c300.


    Has anyone been able to use this combo successfully? If so, have you made any system changes at all? Or taken other steps?

    I will be contacting crucial support as soon as I finish typing this...hopefully will have some answers soon.

    Thanks guys.

    Regards,
    Liran
     
  2. kirk.davis macrumors newbie

    Joined:
    Mar 25, 2006
    #2
    I have one of these SSD's and a 15" 2011 MBP; I didn't have any issues installing but have had an issue with the machine shutting down (see my other post) I'm not sure if that's related or not.

    Everything seems to be ok for me at the moment; hope you resolve your issue soon.
     
  3. LS417 thread starter macrumors regular

    Joined:
    Oct 30, 2009
    #3
    So just as I finished typing out my post my OS X installation completed successfully.

    Up until now I have been doing the following:

    1. Boot from osx cd
    2. Partition / Format SSD
    3. Rename SSD "Macintosh SSD"
    4. Quit disk utility
    5. Start installation

    This time,

    I followed a pretty similar cycle, except I decided to leave the disk labeled "untitled" as opposed to renaming it...

    Not sure if this was simply a coincidence, or not...

    So far everything seems to be working smoothly, I will post Xbench scores as soon as I am back at my apartment.

    Will report back soon!
     
  4. ddehr026 macrumors 6502

    Joined:
    May 1, 2010
    #4
    Maybe it has something to do with the space in the name? I dunno...
     
  5. LS417 thread starter macrumors regular

    Joined:
    Oct 30, 2009
    #5
    Okay, some results.. I apologize ahead of time for the large screenshots.


    First up, 2011 MBP 13in 2.7 i7, 8GB Crucial 1333, Crucial 256GB C300 SSD.
    fyi: clean install, nothing installed except firefox.
    [​IMG]


    For comparison, late 2009 MBP 13, 2.53 C2D, 4GB 1033, STX Momentus XT 500GB Hybrid.
    fyi: OS cloned from previous HDD, so not fresh..Also ~200GB free.
    [​IMG]

    From cold start, the SSD machine is usable before the XT even loads the apple on the white screen.
     
  6. LS417 thread starter macrumors regular

    Joined:
    Oct 30, 2009
  7. hellrising macrumors newbie

    Joined:
    Mar 20, 2011
    #7
    i bought the c300 right when i got my 2011 13inch macbook pro i5...i have no problems with it whatsoever. osx installed smoothly. i was worried when i read the issue it has with the 2011 macbooks but luckily i didnt run into any problems.
     
  8. hvgotcodes macrumors member

    Joined:
    Feb 2, 2011
    #8
    I put a 256gb c300 in my 2010 17" MBP. Looks like mine is a bit slower than yours, probably due to sata2 vs sata3.
     

    Attached Files:

  9. skp574 macrumors 6502

    Joined:
    Jan 16, 2005
    Location:
    greenwich.london.uk
    #9
    I bought a 2011 13" MBP Core i7. I've got a C300 256GB SSD which I pulled from my previous MBP. It worked a dream in my 2.53GHz 13" MBP.

    I imaged the stock 500GB drive to the SSD and swapped it out. Everything appeared ok, booted up fast and logged in fine. After about 5 minutes uptime, the fans started running at full speed and process usage topped out at 190+%. I managed to install iStat and monitor processor using from the menu bar and could see syslogd was hogging the processor for some reason. Then shortly after that any apps running just beachballed. Force Quit failed to work, so pretty much stuffed. In the five minute window before it started going haywire, I stopped Spotlight from indexing as I could see if was trying to just to see if that could be causing the issue with increased disk reading. It seemed to help a bit but can't be 100%. It just prolonged the time until is froze.

    I decided to wipe the SSD and try a clean install from the recovery disks just to see if that would solve the problem. Unfortunately, OS X fails to install. The SSD was formated with a single partition and labeled 'Macintosh HD'. Checking the installer logs, it was having trouble writing packages to the SSD.

    I had to pull the SSD as I need a working laptop. So I've reverted back to the stock 5400RPM 500GB HDD for the time being until a fix is found.

    I really miss having an SSD. My Parallels VMs fired up so quickly along with all other disk intensive apps.

    If anyone knows of a fix for this could they please update this post or point us in the right direction.

    Cheers.
     
  10. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
  11. LS417 thread starter macrumors regular

    Joined:
    Oct 30, 2009
    #11
    Hey, I went through similar issues today when trying to re-install osx (after application permission issue that was entirely my fault, not related). My install kept failing until I zero'ed out the drive. After that my install went through no problems.

    I also did SMC/PRAM/VRAM reset right after I zero'ed the drive, before booting from OSX dvd.

    Keep us posted.
     
  12. skp574 macrumors 6502

    Joined:
    Jan 16, 2005
    Location:
    greenwich.london.uk
    #12
    I did zero out the drive (single pass) when I reformatted it and no change, the install still failed.

    I didn't reset the SMC though. I'll give it a go but reading in other forums, it doesn't solve the issue.
     
  13. Guy Mancuso macrumors 6502a

    Joined:
    Mar 28, 2009
    #13
    Try making a partition. So zero it out again than make a 1 partition of it. That seemed to work for someone else. I will be doing the same tomorrow with Intel 510
     
  14. LS417 thread starter macrumors regular

    Joined:
    Oct 30, 2009
    #14
    So I seem to be making progress..

    I jumped into the energy saving prefs and disabled "put the hard disk to sleep when possible" while on battery power, as well as when plugged in.

    I did this earlier today and have been problem free since. This has been the longest amount of time without a random freeze for 1min+.

    I'm keeping my fingers crossed.
     
  15. j.k.t. macrumors newbie

    Joined:
    Apr 6, 2011
    #15
    Crucial C300 not working in 2011 MacBook Pro

    I treated myself to a new Crucial C300 (rev. 0006) for my 2011 MacBook Pro 17" 2.2GHz, 8GB RAM. What a disappointment! Despite several days of trying *everything*, I was unable to get through the OS X install.

    I've tried every "workaround" listed on this and other forums, plus a few of my own. ZERO luck. The drive is properly recognized and can be managed (partitioned/erased) via Disk Utility, but the install always fails when the packages are being decompressed.

    As a last resort, I gifted the Crucial SSD to my wife, and installed it into her 2009 13" MBP. The drive so far appears to be working perfectly in that system. There is clearly something specific to the new MBP models (6GB SATA?) that is broken. I hope Apple/Crucial recognize this. Crucial's web site should NOT be listing this combination as "compatible".

    If you have a 2011 MBP, save yourself the headache and avoid the Crucial C300 SSD!
     
  16. NikFinn macrumors 6502a

    NikFinn

    Joined:
    Jun 22, 2009
    Location:
    MA
    #16
    Because you mentioned the 6Gbps, did you have the C300 installed in your hard drive bay as opposed to the optibay?
     
  17. LS417 thread starter macrumors regular

    Joined:
    Oct 30, 2009
    #17
    I pretty much gave up on this combo. I've tried everything and could not stop the random 30-40 sec beachballs from happening under any sort of load.

    I ended up returning the 2011 macbook and reverted back to my 09 2.53 c2d machine. Popped the SSD in and its running like a dream.

    I will wait until this mess gets sorted out before I take the 2011 dive.
     
  18. johnnj, Apr 7, 2011
    Last edited: Apr 7, 2011

    johnnj macrumors 6502a

    Joined:
    Dec 11, 2008
    Location:
    Not here
    #18
    I have two C300 drives in my 15" 2011 i7. None of these problems at all. Just jammed these suckers in with a ball peen hammer and OSX installed just fine.

    [​IMG]
     
  19. LS417 thread starter macrumors regular

    Joined:
    Oct 30, 2009
    #19
    lucky lucky, Enjoy that beast!
     
  20. j.k.t. macrumors newbie

    Joined:
    Apr 6, 2011
    #20
    MacBook Pro != Crucial C300 SSD

    No, mine was a standard HD bay installation. I used the standard "MacBook Pro 17-inch" media (10.6.6. -- 10J3210) that came with my system, and the standard OS X installation options.

    I tried many variations, never with any success.

    I ended up going to a 500GB WD Scorpio Black and it worked flawlessly, after updates the OS stands at 10.6.7 (10J3250).
     
  21. JustCorz macrumors newbie

    Joined:
    Mar 31, 2011
    #21
    MacBook Pro 2,2 17" 2011 & C300 ssd on Sata 3 Fail!

    I too tried all or most whats been mentioned on this site and crucial forums with no no joy getting this drive to work in the main hd bay:mad:

    But i have this drive working succesfully in my maxupgrades optibay:)

    what i would like to know is if this is actually a big loss in performance as it only working at sata 2 speeds?
     
  22. RockPortTech macrumors regular

    Joined:
    Mar 10, 2011
    Location:
    South Texas
    #22
    No reason in the world a product from Crucial, a company known for excellent memory, should be having such issues.

    I really hope this gets resolved by either party Crucial or Apple since I was SO CLOSE to pulling the trigger on one. Perusing the forums on Crucial revealed this specific issue as well.

    Still will not alter my opinion of Crucial, I have installed their products on our home systems with blind faith for years, but I use this Macbook Pro to help make ends meet. I hope it gets resolved.
     
  23. brentsg macrumors 68030

    Joined:
    Oct 15, 2008
    #23
    Memory is one thing. SSD controllers and firmware is a different beast entirely.

    The sad fact is that the list of SSDs worth owning is shorter than many think.
     
  24. fm2503 macrumors member

    fm2503

    Joined:
    May 5, 2009
    Location:
    North Wales
    #24
    My 256GB C300 (FW 0002) has been successfully transplanted from my C2D 15" UMBP to a brand new i7 15" MBP. Had to re-install OS X to get it to boot, but otherwise running solid as a rock, and even faster thanks to SATA III.
     
  25. johnnj macrumors 6502a

    Joined:
    Dec 11, 2008
    Location:
    Not here
    #25
    I have to think that the problems these guys are having are either because the drives are defective or there are subtle variations in the logic board chipsets. Is this only with current 13" machines or is this across the current MBP line?

    Come to think of it, I neve actually did a clean OSX install onto these Cruicial drives. Because I didn't have them yet when I first got the new machine and because I had pre-sold my old 2009 15" to a friend from work, I had to get creative with my installs and transfers. Basically I did a clean install of OSX from an image of the disk that came from the new one onto the stock hard drive. Then I just did a series of Time Machine backups and restores from one storage setup to another.

    My point is this: has anyone tried just doing a TM restore onto one of these drives, using Disk Utility to format just before the restore?
     

Share This Page