2011 MacBook Pro - SSD/SATA 3 Issues.

Discussion in 'MacBook Pro' started by revelated, May 21, 2011.

  1. revelated, May 21, 2011
    Last edited: May 22, 2011

    revelated macrumors 6502a

    revelated

    Joined:
    Jun 30, 2010
    #1
    Question.

    The C300 doesn't work in my 17". Nothing new, known issue. However, some have stated that they have bought newer MBPs that do not have the problem and work successfully. I'm not trying to Optibay, I just need a working SSD.

    So...I have two options. Wait for Apple's Engineering to tell me they can't help me since it's not their drive (Which isn't SATA 3, thus moot), or sell this MBP and buy a new one. I'd rather not have to do that - but I do need my machine to work the way I need it to work.

    What I planned to do was check for a MBP that was manufactured sometime in late April or May and see if it had the issue using the 14-day trial period. If not, I return it and get my money back. If so, I sell the current one. It would also give me the opportunity to see inside of both and see what might have changed. But with the newer serial format, it's difficult to know what to look for on the box.

    So for those who:
    - Got a recent 17" MacBook Pro
    - Is using a third party SATA 3 SSD (Intel, Crucial, OWC, whatever)
    - Is NOT using Optibay

    Can you or will you share just the first six characters of your serial? NOT THE WHOLE SERIAL, just the first six. That will tell us if it came from Quanta, as well as roughly when it was manufactured. Want to see if there's an easy way to tell if they have April or May models or if they're still sitting on February/March stock (they don't have many MacBook Pro buyers).
     
  2. revelated thread starter macrumors 6502a

    revelated

    Joined:
    Jun 30, 2010
    #2
    So, I have some information I've gathered thus far. I bit the bullet and bought a new(er) 17" MacBook Pro. Here is what I have gleaned from the experience.

    - There is definitely changed hardware. That much is obvious. What's not obvious is exactly what changed. They appear to be identical boards and cables. It got me to thinking - what if the drive was simply underpowered? But that wouldn't make sense as the SSD should in theory require less power to operate continuously.

    - The C300 attached fine in the internal slot, negotiated @ 6Gbps. I used my existing drive attached via USB/SATA to boot into Snow Leopard and tested file copy and delete. No issues, performance was on the upper crust as expected.

    - Tried to do a Snow Leopard install onto the C300 from directly within Snow Leopard. It went fine, then rebooted into the DVD and continued...then threw an error. I repeated this vicious cycle for over 10 hours with no success.

    - Created a USB installer for Snow Leopard thinking maybe the SuperDrive was bad. It said it successfully installed, but took over an hour, and it wouldn't boot after it was done.

    - Put my regular drive inside the laptop, USB/SATA on the C300, installed Snow Leopard without an issue (though it still took an hour for some reason). Booted it from the USB drive, no issue. Put it inside the laptop, kernel panic right away. Tried again and it started, but took 5 minutes to boot.

    - Tried again a second time with verbose on. It was choking on the "inflate" error. But it did eventually finish the boot cycle this time in a shorter period.

    - Rebooted again just to strength test it. It came up with what appeared to be a transparent blue screen where I could see the background behind it and the mouse moving, but couldn't do anything. After about 5 minutes it went away.

    - Rebooted again. This time it just sat at the spinning gear for however long, and I killed it out of impatience.

    - Booted again. Booted lightning fast, but the login window had a beachball and was nonresponsive for about 2 minutes. Came back, got logged in, and it was going in and out. It would be responsive, then beachball and unresponsive for a minute, then back responsive, then beachball for a minute, etc. After about 15 or so minutes of this it finally stabilized and became fully responsive. Disk tests showed it was performing at peak.


    So...it works as a standard drive. It works as a primary boot SATA3 drive, just not consistently and with no pattern to the failure. Once I'm in Snow Leopard and fully loaded I can write to or from it without issue. But it can't handle the basics of UI navigation and chokes during the boot - EFI, is it? - phase. But the question is what did they change?

    The guy at the Apple Store said that some of the engineers were talking about "pins" needing to be set on the board. I have never seen pins on the Apple logic boards, and I did scour iFixIt to see if I could find any, and failed. Does anyone know if there's anything to this?
     
  3. dagamer34 macrumors 65816

    dagamer34

    Joined:
    May 1, 2007
    Location:
    Houston, TX
    #3
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    I think I read there is ver. 007 FW update for the C300... you might try that.

    Also, I read a post here from a user that "acquired" 10.6.8 and that fixed his SSD problems.
     
  5. revelated thread starter macrumors 6502a

    revelated

    Joined:
    Jun 30, 2010
    #5
    Firmware is 007. Doesn't help. In fact I had more issues after I did the firmware update than before.
     
  6. revelated thread starter macrumors 6502a

    revelated

    Joined:
    Jun 30, 2010
    #6
    Current status:

    On the new MBP, I can boot straight into Boot Camp without an issue. Windows 7 is lightning fast with the SSD. No boot delays, no Window delays.

    Booting into Snow Leopard - not happening. I've let the spinning gear sit for 3 minutes and just can't get in.

    In other words, the drive is fine, the hardware is fine, Snow Leopard is definitely the problem. I have software that I believe might address the issue. However I can't apply it since I can't log into the damn thing.
     
  7. mikado63 macrumors newbie

    Joined:
    May 26, 2011
    Location:
    Montréal, Canada
    #7
    My story with MBP & SSD sata 3

    @revelated :

    I've just registered to share my story.
    I had the same issue with my early 2011 MBP 17 inch.
    1) bought on march
    regular freeze with sata 3 ocz vertex 3
    2) i get reimbursed by apple (RMA)
    i read on the internet it was resolved in newer models
    so i took a chance and bought one on craigslist
    3) 6 first digit of my serial number : C02FP0
    do you know what does it mean ?
    when it was made ? (week number)
    4) same issue with this 'May' model
    I'm going to a Genius Bar the evening

    I will follow this post ;-)
     
  8. b0rg, May 26, 2011
    Last edited: May 26, 2011

    b0rg macrumors member

    Joined:
    Oct 5, 2009
    #8
    I had the same issues with my Vertex 3 and Macbook Pro 17" i bought in march.
    I called apple and they replaced my Macbook with a newer model from April.
    You can check your manufacturing date here

    The one from April is working now great without any problems.
    Serial Number (system): C02FK044****
    Group1: MacBook
    Group2: Pro
    Generation: 83
    ModelCode:
    Machine Model: MacBookPro8,3
    Model introduced: 2011
    Production year: 2011
    Production week: 16 (April)
    CPU speed: 2.2GHz
    Family name: Become a pro user to see this information. (sorry)
    Screen size: 17 inch
    Colour: Please tell us what colour this MacBook is.
    Factory: C0 (Quanta Computer (Susidiary = Tech Com))
     
  9. mikado63 macrumors newbie

    Joined:
    May 26, 2011
    Location:
    Montréal, Canada
    #9
    Thanks, I found this URL on the forums.
    My new one is :
    Production week: 20 (May)
    Factory: C0 (Quanta Computer (Susidiary = Tech Com))

    I read on some forums that it could be resolved by a software update,
    I'm starting to think it could be right.

    My SSD wasn't formated since my old MBP 2011,
    I've just put it on the new one, and it still hangs, freeze...

    Maybe I'll try a fresh install of Leopard because I used Developer Preview 3 of Lion
     
  10. HighSeasCaptain macrumors member

    Joined:
    Feb 11, 2010
    #10
    Well this is kind of sad news. I was going to go into the store today and check all the serials of the 17" stock to find one with the latest build date and exchange mine for that, but from what you guys say it still sounds like a roll of the dice whether or not SATA III will work, even with the newest models.

    There doesn't seem to be any rhyme or reason as to which/how/why the SATA III will work correctly in some models and not others (as well as having both ports being 6/6). I have found many reports of those with the SAME exact build week and model of MBP as mine with no issues. What the hell is going on here?

    If it matters, mine is:
    Generation: 83
    Production week: 14 (April)
    Factory: C0 (Quanta Computer (Susidiary = Tech Com))
     
  11. revelated thread starter macrumors 6502a

    revelated

    Joined:
    Jun 30, 2010
    #11
    I don't know what's going on either, but I just gave up and returned the computer. I will be returning the drive tomorrow. It's really unfortunate, as I was looking forward to the higher speeds. From what little I could experience, the speed for vms was excellent.

    If I had to guess I would say that Apple released a bunch of macbooks that had the bad intel chipsets. Of course they will never admit it.
     
  12. Kariya macrumors 68000

    Kariya

    Joined:
    Nov 3, 2010
    #12
    The chipset itself is fine it's probably just the cabling. Apple never got a bad batch of chipset. All tests have shown they're using the revised boards.
     
  13. revelated thread starter macrumors 6502a

    revelated

    Joined:
    Jun 30, 2010
    #13
    There's no other logical explanation for why the models purchased in February/March exhibit worse SATA 3 issues than the ones manufactured in April/May except a hardware change. No other theory makes sense than something wrong with the hardware, and I don't think it's just the cable. I swapped the newer cable with the older MacBook Pro to test that theory and had the same results.
     
  14. revelated thread starter macrumors 6502a

    revelated

    Joined:
    Jun 30, 2010
    #14
    So update:

    AppleCare Tech Support basically told me to kick rocks because "...it works with our drive". Which is true. But it doesn't negate the fact that there's an issue.

    AppleCare Customer Relations told me that they would be happy to set up a mail-in repair, which would leave me without a MacBook for "...about 5-10 days". Which doesn't work. The Big Apple is used every day for work, being without one for even one day isn't acceptable. The alternative they suggested, "...you can always go online and order up a new MacBook Pro if you think something's been fixed in the newer hardware, then try and sell the current one." In other words, spend another $3,000 and cross my fingers while giving another customer what amounts to a defective machine.

    Apple Store was sympathetic but their hands were tied.

    Local Apple repair shop hadn't even heard of the issue.
     
  15. b0rg macrumors member

    Joined:
    Oct 5, 2009
    #15
    I Think the only solution is buy a OCZ Vertex 2 with SATAII maybe that's why apple is putting in SATAII SSD drive in their own macbooks?

    Also at OWC Larry posted an update regarding this issue.
     
  16. mikado63 macrumors newbie

    Joined:
    May 26, 2011
    Location:
    Montréal, Canada
    #16
    I went to the nearest Apple Store Genius Bar, they told me it could be patched by a future EFI update, like they did before while they enabled Sata 3 on iMacs for example.

    So, I'll try to reinstall my system from scratch.
    But, it's strange, they took my MBP in their repair room, in fact to repair my trackpad issue (weird feedback when I clicked on it) and since that moment, I can use it without hangs or freezes ;-)

    Maybe, they have a solution but prefer to repair without letting you know.

    Wait & See
     
  17. moreifp macrumors newbie

    Joined:
    Jun 3, 2011
    #17
    snow leopard version

    I installed a240gb OWC sata 3 SSD drive on my MBP 15""
    and tried to install the OS getting always a kernel problem. Spent hours with the OWC technical people to no avail. I took the computer to the genius bar and they saw the version of the OS I was trying to install was 10.6.4 and said that in general the macs will not work with a version prior to the ones they were shipped with. They installed OS 10.6.7 and the drive is working perfectly. For people getting the kernel problem (it tells you to power down the machine) check if you are installing the OS that came with your computer.
    Anybody knows how I can check the transfer speed of my drive and confirm the 6gb/s?
    Fausto
     
  18. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #18
    Option click the Apple in the top left of the menu bar and select System Profiler then select Serial-ATA. Then look in the right pane and you will see Link Speed: and Negotiated Speed:. You want those both to say 6 Gigabit.
     
  19. Philflow macrumors 65816

    Joined:
    May 7, 2008
    #19
    I'm having similar problems with a Crucial M4 and Corsair Force 3 in my MBP 2011 13". Production date: March.

    Vertex 3 works fine. SATA II SSDs too.
     
  20. jnpy!$4g3cwk macrumors 65816

    jnpy!$4g3cwk

    Joined:
    Feb 11, 2010
    #20
    I read *somewhere* that it is the *cable*. [I forget where, so, don't do anything until this is verified true/false!!] It may be that the chipset/drive negotiates 6 Mbps, but, the cable has too much crosstalk at 6 Mbps. Since laptop cables are not generic, I'm not sure what you can do about it. Possibly there is some way to force the drive to 3 Mbps?
     
  21. nailofwit, Jun 6, 2011
    Last edited: Jun 7, 2011

    nailofwit macrumors newbie

    Joined:
    Jul 18, 2009
    #21
    Hi guys,

    I've had this issue with both a Vertex 3 SSD and now an OWC Extreme Pro 3G SSD.

    I have a 15" i7 MacBookPro8,2, production date February running 10.6.7 - and with both drives the following happens: -

    * When the MBP boots up via an external disk, with the SSD when attached via the SATA connector it does not display within System Profiler, Disk Utility, or Start Up Disk setting within System preferences.

    * Unable to install OS X when SSD is connected via the SATA controller or use Disk Utility to format the drive.

    * If OS X is installed on the drive when it is attached via USB, then subsequently attached via the SATA the Mac crashes instantly on startup

    * If the SSD is cloned and then attached via the SATA, the Mac is unable to boot up with flashing question mark icon.

    I am using the OS X disc that came with my MBP.

    On some occasions both the vertex 3 and the OWC drive would spaz out on startup with this message: -

    [​IMG]

    I've taken the MBP to Apple on two separate occasions, the first time the "Genius" suggested I try another drive form a different manufacturer. I did that (got the owc drive) and then when I returned to the store they trotted out the old "we don't support 3rd party drives" line. But that ignores the issue, the issue is with the SATA III controller.

    I've complained in writing to Apple regarding this and have yet to receive a reply. All I want is a working machine. Any ideas?
     
  22. Philflow macrumors 65816

    Joined:
    May 7, 2008
    #22
    I think the work arounds are:
    -trying a different SATA cable. Here's someone that it worked for.
    - get a SATA I SSD.

    In my experience Kingston V+ 100 and Samsung 470 have the highest sucess rates with Apple notebooks. These are the controllers Apple uses in their MBA line too.

    Of course these drives ares slower than a Vertex 3, but during normal usage it will be very hard to notice a difference. I have both the Vertex 3 and Kingston V+ 100 here.
     
  23. Timur macrumors 6502a

    Timur

    Joined:
    Oct 14, 2008
    #23
    Install the Intel RST driver and do *not* turn off LPM (via Registry hack). Use that configuration for some time and please report back if you get stalls (30-60s).

    I'm also on a Mai MBP and had no issues installing OS X. But I got some stalls on both OS X and Windows, which very likely are connected to LPM (Link Power Management). The Microsoft AHCI driver has that turned off by default, the Intel driver has it turned on, the OS X driver likely also has it turned on.
     
  24. revelated thread starter macrumors 6502a

    revelated

    Joined:
    Jun 30, 2010
    #24
    Already returned the Crucial. In its place is a Samsung 470. SATA2, but hell, it's fast enough for what I need. Faster than the X25-M by a wide margin.

    I just don't have the time or the patience I had in my youth to keep fighting an uphill battle. Apple's internals are the problem, and until they own up to it and fix the issue for existing Macs, the dice roll methodology just doesn't work for me. It's hard enough finding SSDs locally, having to order them online, wait, then waste time installing and configuring, only to have it not work, then roll back, purge the drive and return it and wait for hundreds of dollars to be refunded. Way too much inefficiency there. I should be able to put ANY SATA3 drive into this chipset and it should work without a problem.

    At this stage I'm going to stick with the Samsung 470 as it's already impressed me to no end. If in a future revision Apple openly acknowledges and accepts responsibility for SATA3 support I'll consider it.
     
  25. JronMasteR macrumors 6502

    JronMasteR

    Joined:
    May 4, 2011
    Location:
    Switzerland
    #25
    Hi everyone
    I've just installed my new Vertex 3 in my 17" Macbook Pro. Mine was built in the first week of March. The SSD is working perfectly so far. The drive was recognized as a 6G SSD at the first boot. Cloned it with Carbon Cloner by the way.
    The SSD was delivered with Firmware 2.06.
     

Share This Page