2011 MBPro SATA cable

Discussion in 'MacBook Pro' started by stuworrall, Sep 13, 2017.

  1. stuworrall macrumors newbie

    Joined:
    Aug 31, 2011
    Location:
    North Wales, UK
    #1
    Hi

    My early 2011 MBpro recently had problems booting and after lots of fault finding I got the problem down to the main HDD bay as my boot disks worked fine out of the DVD bay.

    Ive got 3 boot disks (2 x SSD and 1 mac HDD) which all boot fine on the second bay but wouldn't on the main. After trawling online I found the problems with the SATA cables so I ordered a replacement for part 821-1198-a.

    The replacement part has arrived and Ive just fitted it but its still not seeing the disk on boot (flashing folder).

    Does anyone know of my next option if its not the cable? Im thinking at the moment its the motherboard or Ive received a faulty replacement cable but Ive no way of testing it.

    Does anyone know if I can get any support in the UK for an out of warranty mbp?
     
  2. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #2
    Where did you get the cable? Could the replacement cable be defective too?
     
  3. stuworrall thread starter macrumors newbie

    Joined:
    Aug 31, 2011
    Location:
    North Wales, UK
    #3
    It was off a company on Amazon. Brand new and looked like a genuine part but it could well be faulty. It means either sending it back or buying another to confirm.
     
  4. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #4
    Is the boot drive seen by disk utility in recovery mode?
     

Share This Page

3 September 13, 2017