2015 Retina Macbook - shuts down and restarts difficult - is this a known issue ?

4sallypat

macrumors 6502
Original poster
Sep 16, 2016
416
391
So Calif
So my 4 year old rMB 12" (CTO/BTO) started to shut down after logging in.

Opening the display, the login icon shows, I enter password and then shuts down.

I try to restart it, but a normal press of the power button does not start.
I have to press the power button down for 10 seconds and then press it again to start again.

Would work for a day and then the next day, it does it again.

Something known about this or am I alone ?

OSX 10.13.6, 8GB, 512GB, Macbook8,1, Early 2015 rMB 12"
 

objektør

macrumors regular
Nov 25, 2014
242
16
At home
I have some similar issues but I think it's my battery and (room)temperature.
I shut down my rMB during the night. At start up the next morning when it's cold it behaves like yours.
I put it on charge to start and it is ok. It works flawless during the day.
Looks like when I put it on charge straight away it starts up normally.
How is your battery?
 

4sallypat

macrumors 6502
Original poster
Sep 16, 2016
416
391
So Calif
I have some similar issues but I think it's my battery and (room)temperature.
I shut down my rMB during the night. At start up the next morning when it's cold it behaves like yours.
I put it on charge to start and it is ok. It works flawless during the day.
Looks like when I put it on charge straight away it starts up normally.
How is your battery?
Yes, same conditions here too.

Cold start up restarts every time.
This morning did the same, followed your advice and plugged her in and started up quickly compared to pressing the power button for 10 seconds...

Battery fluctuates between 70% and 80% - both conditions reporting "GOOD" by Apple and Coconut Battery:
 

bsamcash

macrumors regular
Jul 31, 2008
236
88
Cupertino, CA
Have you tried resetting the PRAM? Not sure if that will fix it, but it’ll at least reset the parameters to eliminate that as the issue.
 

4sallypat

macrumors 6502
Original poster
Sep 16, 2016
416
391
So Calif
Yes, I did reset the PRAM and the SMC.
Did a full battery cycle calibration that took a day.

Still having problems with the shutdowns when cold...
 

objektør

macrumors regular
Nov 25, 2014
242
16
At home
I'm no expert but I would think so. The 'issue' started last winter when my battery got worse. I plan to get a new battery in April when I am in Europe. It's 5 years old then and has served me well.