2016 15" MBP with Logic X and plug ins - crashing?

Discussion in 'MacBook Pro' started by Roopster, Jan 7, 2017.

  1. Roopster macrumors newbie

    Joined:
    Jan 7, 2017
    #1
    I was hoping there may be some other Logic Pro users on here running the same system as I have just bought to see how they are finding it.

    I have a 2016 15" MBP 2.9 i7, 16gb ram, 1TB, 450 gpu. Os 10.12.2 , Logic Pro 10.2.4.
    I've been slowly installing 3rd party plug ins due to crashing switching between single instances of some instruments and effects.
    Arturia and Izotope particularly have problems that Apple have also replicated on a 2016 MBP.

    I have to decide whether to hold on until updates are worked on for these plug ins (and potentially any others I'm yet to install from NI, Waves, Soundtoys and many others) or give up and get a 2015 MBP (as the Apple tech I spoke to originally tried replicating my crashing on an iMac with the same OS and version of LpX, & it was fine and did not crash...leading him to believe it was a hardware issue that required revisions from the 3rd party plug in manufacturers).

    I guess i'd like to know if anyone else is having these problems and if so with what plug ins?
     
  2. Boneheadxan macrumors regular

    Boneheadxan

    Joined:
    Jul 19, 2009
    #2
    That is terrible news. I've mostly only heard of OS incompatibilities. This is the first time I'm hearing certain plugins being incompatible with certain hardware until it's upgraded. Some of the devs take months to upgrade their software.
    I am planning on picking up the new machine and was just going to migrate my current system. Are you sure these aren't just macOS Sierra incompatibilities?

    Do you have a source for this?
     
  3. Roopster thread starter macrumors newbie

    Joined:
    Jan 7, 2017
    #3
    The source is me! I have a brand new machine that came pre installed with the OS spec in my post and Logic Pro.

    I installed fresh downloads (so the latest installers) of Arturia V5 collection (just purchased the upgrade from V4). Izotope Music Production 2 Bundle (along with Iris 2 & Stutter edit) Korg Legacy and Soundtoys V5 Native.

    I decided to take a break from installing and start to activate the Korg and Izotope plugs which require you to open up an instance in LPX and type in the serial. The Korg ones were fine but when opening up Ozone after Neutron the machine crashed. I restarted and tried switching between different Izotope plug ins and some combinations were fine, others crashed.

    I then started opening the Arturia ones (which are already authorised through their software centre when downloading). Synclavier, CS80 and Arp switching always caused LPX to crash.

    Logic plug ins are fine. I think I had a crash with Soundtoys but can't remember as I stayed focused on the ones I knew were definitely an issue.

    I emailed Arturia and Izotope tech support.

    I then contacted Apple support.

    We first tried logging in as a new user and running LPX in safe mode. Same crash.

    Then we reinstalled the OS.

    Same crash.

    Then we wiped the drive and did fresh OS and LPX installs. I started by only installing synclavier, arp and cs80 from Arturia and no other 3rd party plug ins, no audio or Midi drivers either so just using the internal audio.

    Same crash.

    I then contacted Apple again and spoke to someone in their Pro app team in Ireland who was very helpful.

    His test machine was an iMac running the same OS version and same LPX version. He signed up to Arturia and downloaded demo versions of Synclavier and Cs80. He watched as I made it crash on my system and tried to do the same on his. And couldn't.

    That's why it's not an OS specific crash.

    I then asked if he could get hold of a new 15" MBP and try the test again. He did and called me back to say he had replicated the crashing. So he thought it was a specific issue with some 3rd party plug ins that are fine on the same OS and LPX version on an older machine, but not on the new hardware architecture of the MBP. What specifically he didn't know and would have to report to the techs in America.

    Arturia have only responded saying they have passed it to a level 2 tech. I can't give them any crash logs or any more info as they've said not to reply to any emails as it will get pushed back down to level 1. Ridiculous! I've since tried installing an older version of cs80 and arp, and that also crashes.

    Izotope asked for crash logs and system configuration and confirmed they have not tested their software on the new MBP yet. They've passed it to their software engineers.

    My suspicion is a graphics issue and I'm going to try use gfx card status to force the machine to only use the internal Iris graphics (I've tried turning off switching in preferences so it only uses the card and that didn't help). My machine has the 450 card, but the Apple techs machine had the 455 card so the specific model of card isn't the isssue.

    I could also try to install the beta of OS X 10.12.3.
     
  4. Boneheadxan macrumors regular

    Boneheadxan

    Joined:
    Jul 19, 2009
    #4
    Hmmm, interesting. Do you have any DAW which supports VST, like Ableton or Reaper to replicate the crashes?

    Over on LogicProHelp there are some workarounds for the auvaltool crashing on Sierra: https://www.logicprohelp.com/forum/viewtopic.php?f=1&t=127198&start=80

    I'll probably be able to test only once I get the machine later this month. I was hoping the transition doesn't require me to re-install everything again.
     
  5. Jaekae macrumors 6502a

    Joined:
    Dec 4, 2012
    #5
    I have audio production problems with 2016 mbp also.. coreaudio crashes and kernel panics if i have my apogee ensemble tb2 audio card connected with the apple adapter. Works flawless on my 2012 rmbp.. and also au validation crashes and cpu meter go to max when using only one plugin sometimes

    These 2016 have garbage drivers for everything it seems like..
     
  6. Roopster thread starter macrumors newbie

    Joined:
    Jan 7, 2017
    #6
    The auvaltool isn't crashing on my machine. It's logic that crashes when you try and switch between different plug ins on a track, or open a plug in on a new track. To me it seems very specific to certain plug ins but it crazy that these very reputable developers haven't tested their software on the new machine?

    I only have an older version of Ableton that I haven't installed on this machine yet. I only use it rarely so making sure logic works is the most important thing for me.
     
  7. Boneheadxan macrumors regular

    Boneheadxan

    Joined:
    Jul 19, 2009
    #7
    Wow, that is bad. Apple should ensure seamless transition. I really don't expect every dev to update drivers whenever a new Mac is released. Some of my plugins get updated maybe once a year.
    Not sure what I'm going to do. I have unfinished projects for clients which I can't risk plugin crashing issues with. Also, would love to be able to open my old sessions. I really hope driver/OS updates at Apple's end fixes this.

    Upcoming Logic update might probably have an answer. Hopefully in a week or two.

    Thanks for the heads up.
     

Share This Page