2016 MBP TB: kernel panic - sleep wake failure

Discussion in 'MacBook Pro' started by ManuCH, Mar 2, 2017.

  1. ManuCH macrumors 6502

    Joined:
    May 7, 2009
    Location:
    Switzerland
    #1
    So I got my first kernel panic on my 15" 2016 MBP. I have never seen this: the event is "Sleep Wake Failure" and the stackshot reason is "Watchdog".

    It happened when resuming the MBP from sleep. It was asleep in clamshell mode, connected to an Asus MX27UC 4K display via USB-C. Up to now, it had always resumed properly from standby when opening the lid while connected to the 4K display.

    In the console, if I search for powerd events I find several of the following:

    ---

    com.apple.message.domain: com.apple.sleepwake.failure
    com.apple.message.signature3: Wake
    com.apple.message.signature: Interest Failure
    com.apple.message.value: 1921
    com.apple.message.summarize: NO

    ---

    I am also attaching the full kernel panic log.

    Has anyone experienced anything similar? Could it still be a bug with 4K USB-C displays? I have read of crashes with such setups, but nothing similar regarding kernel panics etc.

    Thanks!
     

    Attached Files:

  2. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #2
    It might just be a glitch unless it continues to happen I wouldn't worry about it.
     
  3. Calby macrumors 6502

    Calby

    Joined:
    Dec 30, 2015
    Location:
    Sweden, Gävle
    #3

    It's a software bug, it's because it was connected to a display during deep sleep.
     
  4. ManuCH thread starter macrumors 6502

    Joined:
    May 7, 2009
    Location:
    Switzerland
    #4
    Interesting. How can I prevent it from going to deep sleep? I don't really need that, as it's always connected to power, so I don't really care for deep sleep.
     
  5. Calby macrumors 6502

    Calby

    Joined:
    Dec 30, 2015
    Location:
    Sweden, Gävle
    #5
    I don't know it right now but it's in console google for disable hibiration
     
  6. canberksenolsun macrumors newbie

    canberksenolsun

    Joined:
    Mar 3, 2017
    #6
    To all of you that are suffering from this problem, these kernel panicks are almost always caused by 3rd party kernel extensions UNLESS you have a hardware failure.

    To see the 3rd party installed kernel extensions, open Terminal and type:
    Code:
    kextstat | grep -v apple
    You will see the 3rd party extensions listed there. I suggest that you go thru the regular uninstallation procedures of all the software that are related to those extensions. If you don't know the software that is responsible from that extensions OR if the kernel extensions is still there even after the installation, I suggest that you go ahead and manually remove the .kext folder from your system. The steps are as follows:

    The kernel extensions are stored in 2 locations. Either
    /Library/Extensions
    or
    /System/Library/Extensions

    Once you located the 3rd party .kext folder in either of these paths, remove the extensions by typing the following command:
    Code:
    sudo rm -R type_the_name_of_the_3rd_party_kext_file.kext/
    of course by replacing the word type_the_name_of_the_3rd_party_kext_file with your .kext file's name.

    Once you removed the kernel extensions, reboot your computer and enjoy. If you are still facing with issues, then you have a hardware problem and need to send your device in for repair. Oh, you're welcome.
     
  7. compukortschnoi macrumors newbie

    Joined:
    Aug 9, 2015
    #7
    @ManuCH: Same here. And by the way: no third-party kernel extensions.

    Did you do something in the meantime (contacting Apple, tuning the sleep mode etc.)?
     
  8. ManuCH thread starter macrumors 6502

    Joined:
    May 7, 2009
    Location:
    Switzerland
    #8
    I disabled deep sleep mode and didn't experience the issue anymore ever since. So yes, there probably is a deep sleep bug, but I don't really care as I don't need it.
     
  9. compukortschnoi macrumors newbie

    Joined:
    Aug 9, 2015
    #9
    How did you disable it?
     
  10. ManuCH thread starter macrumors 6502

    Joined:
    May 7, 2009
    Location:
    Switzerland
    #10
    Here are the commands I used:

    Code:
    sudo pmset -a hibernatemode 0
    sudo rm /var/vm/sleepimage
    
     
  11. upup macrumors newbie

    Joined:
    Friday
    #11
    I can't delete sleep image because haven't got permission. I am Admin and SIP is off, also can't switch (read and write) option for everyone on this file

    Thx
     

Share This Page