2019 Macbook Pro cannot play Youtube Peru 8k?

Discussion in 'MacBook Pro' started by jpiszcz, Jun 7, 2019.

  1. jpiszcz macrumors 6502

    Joined:
    Mar 28, 2010
    #1
    I ran test with a 2019 MacBook Pro (base configuration) at a local electronics store using Google Chrome to play the following 8k video at 4320p60: [1]

    It was stuttering and buffering. I tested various PC laptops at the electronic store and they were able to maintain playback 4320p60 without any stuttering or buffering.

    I also tested the YouTube video on a separate i9900k system (Windows 10) it played it flawlessly- although there was 80-82% CPU utilization.

    Can anyone on this forum play this video at full quality without stuttering or buffering, perhaps with the higher end VEGA card? While testing make sure to change the quality to the maximum 8k [1]

    [1] Link:
     
  2. mathemabeat macrumors member

    Joined:
    Sep 1, 2009
    Location:
    Cincinnati, OH
    #2
    My 2018 6 core Mini with Vega 56 eGpu is having the same stuttering and buffering issue along with pegging the cpu at nearly 100%.
     
  3. MikesGravity macrumors 6502

    Joined:
    Oct 29, 2008
    Location:
    Southeast MI
    #3
    My 2018 MBP 2.6GHZ 6 Core i7 / 560X stuttered too with automatic graphics switching off.

    What's weird is that it buffered plenty and barely broke 10% CPU usage. I wonder what the deal is?
     
  4. vaugha macrumors 6502

    Joined:
    Nov 3, 2011
    #4
    I confirm my 2019 2.4ghz 8-core, 555x mbp 15" stutters every few seconds as well.
     
  5. Costino1 macrumors 6502a

    Costino1

    Joined:
    Oct 1, 2012
    #5
    Yep. Same here. 2018 15" MBP....stuttering and buffering issues.
     
  6. Thysanoptera macrumors 6502a

    Joined:
    Jun 12, 2018
    Location:
    Pittsburgh, PA
    #6
    I don't think you'll be able to. When I run it on my '18 2.2 the 555x is not even active, everything goes through Intel. But even if did use it - when I run it my desktop with RTX 2080Ti, the GPU utilization is 70%.
     
  7. Glockworkorange macrumors 68000

    Glockworkorange

    Joined:
    Feb 10, 2015
    Location:
    Chicago, Illinois
    #7
    I have the 8 core i9 2019 15 inch with the 560X. I hear the music, but the screen was black. It froze the machine. I had to hard restart.

    For giggles, I tried to run it on a loaded 2017 5K iMac and there's a lot of buffering.
     
  8. LogicalApex macrumors 6502

    Joined:
    Nov 13, 2015
    #8
    My guess is that Apple needs to update their coding for VP09.

    I was able to play it smoothly only Windows Desktop with a GTX 1080 Ti and that reported 90% video decode utilization on my GPU.
     
  9. zwt macrumors newbie

    Joined:
    May 31, 2019
    #9
    2019 13" macbook pro CTO with the highest specs plays for about 10 seconds then buffers then play then buffers. CPU utilisation is around 90%. The 4k version plays fine with 50% CPU usage.
     
  10. twanj macrumors 6502

    twanj

    Joined:
    Sep 10, 2015
    Location:
    Pompano Beach, FL
    #10
    But you don't have a 8K or even 4K screen on a MBP?
     
  11. jpiszcz thread starter macrumors 6502

    Joined:
    Mar 28, 2010
    #11
  12. fokmik macrumors 68040

    Joined:
    Oct 28, 2016
    Location:
    USA
    #12
    Whats the point in 8k here? On 1440p or 1800p displays? Or 4k 5k?
    Why you dont try 16k video,i bet it doesnt runs well
    The mac pro is perfect for 8k streaming/editing etc
     
  13. donawalt macrumors 6502

    donawalt

    Joined:
    Sep 10, 2015
    #13
    I have the 2019 MacBook Pro with Vega 20, 8 core i9, 32GB. I clicked the little gear icon in the post here, and the max I saw was 1080p60, which played flawlessly full screen. How do I get 4320p60? I checked on Chrome too, the little gear icon didn't even show any different resolution options.
     
  14. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #14
    8k video seems to be pushing against the edges of the envelope for current computer hardware, even on PC's.

    I could play it on my setup (2018 Mini i7), but there were interruptions that appeared to be coming "from the YouTube end" (though I'm not absolutely certain about this).

    Solution:
    Just play it in 4k for now.
    It should do fine on a 4k display.
    Looks great, even on my 1080p display.
    (Perhaps 8k might look better when viewed on a 5k iMac)

    Aside:
    This probably has something to do with YouTube's compression, but I've found that "4k" videos actually look BETTER on my 1080p display when viewed in either 1440p or 4k (rather than just leaving the YouTube setting on 1080p, which would seem to be "the correct choice")...
     
  15. donawalt macrumors 6502

    donawalt

    Joined:
    Sep 10, 2015
    #15
    Nobody has mentioned this, but I have read articles that have stated to stream 8k requires at least 50 Mbps and could even require 80-100 Mbps. I assume some playing this here at 8k don't have sustained bandwidth that fast - that would certainly explain the buffering delays.

    Also - How do I play this video in 4320p60? When I click the settings gear, the best it shows is 1080p60 on my 2019 MacBook Pro.
     
  16. Queen6 macrumors 604

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Flying over the rainforest at dawn - Priceless
    #16
    Beauty of poor optimisation and weak GPU's. Apple needs to decide if the MBP is about sales and marketing for the masses or a high end professional product. My primary W10 notebook copes without issue, YT at 8K is the very least of my concerns, however stability, performance and reliability is...

    Q-6
     
  17. petvas macrumors 601

    petvas

    Joined:
    Jul 20, 2006
    Location:
    Mannheim, Germany
    #17
    I played the video on my 27" iMac with no problems, apart from the buffering from the YouTube site, despite the fact that I have 1Gbps Internet connection
     
  18. ghostface147 macrumors 68030

    ghostface147

    Joined:
    May 28, 2008
    #18
    Machu Picchu. Birthplace of my father (town below).
     
  19. HDFan macrumors 65816

    Joined:
    Jun 30, 2007
    #19
    Same here on an iMac Pro set to maximum resolution.
     
  20. slayerizer macrumors 6502a

    Joined:
    Nov 9, 2012
    #20
    you need to use Chrome
     
  21. LogicalApex macrumors 6502

    Joined:
    Nov 13, 2015
    #21
    Firefox works as well.
    The same reason Apple defaults to an equal of 1680x1050 on the MBP 15” Retina. Supersampling gives a clearer picture.
     
  22. Maven1975 macrumors 6502a

    Joined:
    Aug 24, 2008
    #22
    My Lenovo X1C 6th Gen plays it fine in Chrome. (Intel HD620)
     
  23. sapibobo macrumors newbie

    sapibobo

    Joined:
    Mar 13, 2013
    Location:
    Jakarta, Indonesia
    #23
    Is there any chance or link to download the video. I am curious wether it can play 8K or not.
     
  24. Donnation macrumors demi-god

    Donnation

    Joined:
    Nov 2, 2014
    #24
    It plays on my iMac 5K with just a tad bit of buffering. Now I'm really sucked into those videos though, so beautiful.
     
  25. fokmik macrumors 68040

    Joined:
    Oct 28, 2016
    Location:
    USA
    #25
    for me it plays like any other, but in chrome since safari....can't support
    Im on 300Mbs if that matters, but like other said, i think with 100Mbs can also work without any issues
     

Share This Page

33 June 7, 2019