3.0 or 3.1

Discussion in 'iPhone' started by upper, Sep 11, 2009.

  1. upper macrumors newbie

    Joined:
    Jul 2, 2009
    #1
    right now i have 3.0 on my 3gs, i'm scared to update it to 3.1, i dont know if i will lose the jailbreak or not. any ideas?
     
  2. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #2
    Should be in iPhone Hacks forum, but yes. You will lose it.

    You can always re-jailbreak but if you are also Unlocked you may lose that forever. You should wait and browse around the Hacks forum for more info.
     
  3. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #3
    Also, keep in mind that you can't downgrade a 3GS once it is running 3.1. Apple has changed allot with 3.1, 3GS and iTunes 9.0.
     
  4. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
  5. upper thread starter macrumors newbie

    Joined:
    Jul 2, 2009
    #5
    i'm using at&t, so no unlocking needed for me. i'm just concerned about the jailbreak part if i update it right now, will i still be able to use cydia and the apps stuff?
     
  6. redplanet2005 macrumors newbie

    Joined:
    Jun 26, 2009
    #6
    Yes, you will not be able to use cydia and other apps. Wait for the release of 3.1 firmware jailbreak software. Hopefully it won't be long.
     
  7. mstier09 macrumors regular

    Joined:
    Jun 22, 2009
    #7
    If your asking if you can use Cydia and other jailbroken features once your phone is updated to 3.1 then NO you cannot. There will need to be a jailbreak for 3.1, and then you will have to rejailbreak, which will be a while down the road. And keep in mind once you update to 3.1 there is no going back, so you'll be stuck with the stock iPhone. I, for one, am going to hold off on 3.1 as I know most of the jailbreak community is doing.
     
  8. upper thread starter macrumors newbie

    Joined:
    Jul 2, 2009
  9. stockscalper macrumors 6502a

    stockscalper

    Joined:
    Aug 1, 2003
    Location:
    Area 51
    #9
    You can restore to 3.0 and I'm going to do that because 3.1 gives me worse battery life than 3.0.
     
  10. mstier09 macrumors regular

    Joined:
    Jun 22, 2009
    #10
    this is only true if your using 3g or 1st gen, not true if your using 3gs
     
  11. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #11
    No you can't. The Dev Team has warned that future jailbreaks for the 3GS may not work due to the ECID, iBES and iBSS. This is a very big warning the Dev Team has said ever since it was discovered in June.

    If you don't have those files, I suggest you capture them.
     
  12. Maverick1337 macrumors 65816

    Maverick1337

    Joined:
    Nov 4, 2008
    #12
    Please tell me how to do this, i tried all day today and kept getting error 1015.
     
  13. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #13
    Well if you already have the ECID, iBES and iBSS then they said you'll be able to jailbreak later. You can't go back to 3.0 though. I suppose to be safe... I'd just wait. Glad I have a 3G now. :D
     
  14. iMrNiceGuy0023 macrumors 68000

    Joined:
    Jun 5, 2009

Share This Page