3.1 Still does not fix the SMS alert!?

Discussion in 'iPhone' started by michael31986, Sep 11, 2009.

  1. michael31986 macrumors 68030

    Joined:
    Jul 11, 2008
    #1
    i recieved a text a while ago and it did not make the alert sound. i have my phone on ringer and it has alerted me all day with texts. i have set up as new phone when i upgraded to 3.0, so that can't be it and i never had this problem before. We should all send feedback to apple, because this is seriously something that needs to be fixed.
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    You are the only one then. Mine works fine. Also, call Apple up see if they can help, at this time it looks more like a hardware issue. [You have done all the steps I would have told you to do]
     
  3. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    #3
    it is not only me. i made a thread in the past and 10+ people also had the problem. Don't say im the only one. and hardware would not cause a phone to mess up an alert once every few 1000 of texts.
     
  4. daihard macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #5
    No offence, but if it's only 10+ people, I doubt Apple would take it seriously.
     
  5. TonyC28 macrumors 65816

    TonyC28

    Joined:
    Aug 15, 2009
    Location:
    USA
    #6
    I had the same problem with 2.0 until they fixed it. Same problem with 3.0. And now it's still a problem with 3.1.
    And for what it's worth, when I first got my 3G and was experiencing this problem I called Apple several times and they always made it sound like I was the first person they talked to with that issue. It wasn't until the 10th call or so that I finally got the guy to admit that he had gotten a lot of calls about it.

    Don't disappoint me Apple apologists, I just put it on a tee for ya...
     
  6. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    #7
    Ok seriously its just an expression. I dont know how many people. its obviously more than 10+ i didn't count how many posted in my old thread. And once again most people dont' notice it, because
    a) they don't receieve enough texts
    b) they aren't aware of the problem so if one alert doesn't go off they dont even pay mind to it or notice it.

    How would it be hardware?

    and thanks person above for agreeing with me and explaining how the problem started.
     
  7. daihard macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #8
    In other words, the problem, even if existent, does not bear much importance to them.

    I still would not rule that out. Working in the software industry for 10+ years, I've met enough customers who assure us that it "could not possibly be a hardware issue," which later turns out to be exactly that - a hardware issue. :)
     
  8. gforce216 macrumors 6502a

    Joined:
    Jun 17, 2009
    #9
    It's a rare thing that happens to the phone when you get an SMS. It's happened to me since 2.0 with my 3G and even with 3.0 on my 3GS. I haven't had it yet with 3.1. Honestly it is usually because you use a ringtone not made through iTunes. That's when I had the problem, but it only happens 1 out of 100 messages I guess. No real big deal. I check my phone anyway cause it still vibrates.
     
  9. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    #10
    once again like the person above. I had the problem with 2.0 then it was fixed and now since 3.0 i have had it. It is not a HARDWARE problem! it happens very very rarely. it happens alot less than when i had 3.0, but its still not completely fixed. Idk why you keep saying hardware. If it was hardware it would be more common or the alert would not work at all.
     
  10. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    #11

    i bought a ringtone through the new precut ringtone section, so it can't be that, and yes it does happen ever 100 or more so you are right it is very rare. And yes the phone does still vibrate. i guess i just notice it more now. It was very very bad with 3.0, but 3.1 fixed it a bit. im glad to knwo its not only 3G and it was also in the 3GS
     
  11. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
  12. PCboarder macrumors member

    Joined:
    Aug 19, 2009
    Location:
    California
    #13
    I have actually experienced this problem too. It seems that if you leave your messaging app open and then lock the phone, the alert does not always go off (it will still vibrate tho). Whenever I close the messaging app and then lock the phone, the alert seems to go off every time.

    I dunno if that is what is happening with you, but I just get in the habit of closing my message app whenever I lock the phone
     
  13. daihard macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
  14. daihard macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #15
    Is it even possible to use a custom ringtone for the SMS notification without jailbreaking?
     
  15. mackmgg macrumors 65816

    mackmgg

    Joined:
    Nov 2, 2007
    #16
    I was wondering the same thing
     
  16. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    #17
    No it's not possible. Apples only let's you use the ones the have on the phone. Btw to the person who says leave the app closed when u lock it. That may work but that's not how the iPhone should work. Lol
     
  17. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    #18
    can i send feedback more than once or apple only see it once?
     
  18. acfusion29 macrumors 68040

    acfusion29

    Joined:
    Nov 8, 2007
    Location:
    Toronto
    #19
    So today I got a text and it was a sound that I never heard before. I use Tri-tone, but it wasn't that or any of the other 5 included with the phone. My iPhone is not jailbroken.
     
  19. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
  20. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    #21
    bump anyone else...? and yes it seems like if you keep the sms app open as in you keep a conversation that your in open and you hit the power button it will not make a sound and only vibrate a nd if you exit the app you have a better chance of the alert working? has anyone else reported this bug?
     
  21. orange42 macrumors 6502a

    Joined:
    Apr 12, 2009
    #22
    I still have this problem. Since this problem started with 3.0 I've kept my phone on vibrate and ring. It always vibrates when I get a text, but sometimes still doesn't ring. It's annoying.
     
  22. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    #23

    and you didn't have this before 3.0 right? see its not hardware like one user said.

    BTW u should sent a complaint on the feedback link.
     
  23. michael31986 thread starter macrumors 68030

    Joined:
    Jul 11, 2008
    #24
    And for anyone saying restore and new iPhone. I did that with 3.0 and problem was still there. U don't have to restore as new iPhone to fix bugs like this. If we needed to restore as new phone then apple would make you do that because they would tell us that the new 3.1 bug fixes would only work with a restore. And that's not the case since they just say to update it. Never had this problem before 3.0
     
  24. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #25
    I've had the problem since I originally got my iPhone in November...
    I've had it replaced and it still does it. Just sometimes it wont alert me, and others it works fine. It can get really annoying....
     

Share This Page