3g not working on 3GS?

Discussion in 'iPhone' started by Liquinn, Jul 27, 2011.

  1. Liquinn Suspended

    Joined:
    Apr 10, 2011
    #1
    Hmm, my iPhone 3GS 3G isn't working... I'm not sure why.

    Can anyone help?

    Thanks
     
  2. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #2
  3. Liquinn thread starter Suspended

    Joined:
    Apr 10, 2011
    #3
    Hmm, I recently restored the iPhone and the 3G isn't working. When I connect to Safari via the iPhone while 3G is on... Safari says: "Safari cannot open the page because it could not connect to the server".

    Should the 3G be working?
     
  4. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #4
    What caused your iPhone 3GS to stop working in the first place?
    How long was it inactive?
    Does it currently have an active SIM card?
    Can you currently make phones calls?
    If you don't have 3G, do you at least have EDGE (E)?
    Is the 3G set to ON (Settings> General> Network)
     
  5. wordoflife macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
    #5
    Are you sure it is enabled under mobile network settings?
     
  6. Liquinn thread starter Suspended

    Joined:
    Apr 10, 2011
    #6
    1. Don't know.
    2. 4 months or so.
    3. Yea
    4. I don't have EDGE.
    5. Yep.

    Something isn't right with this :(
     
  7. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #7
    Since your phone just became operable again very recently, what SIM card did you use for your iPhone 3GS? and does it have a Data plan attached to it?
     

Share This Page