8.0.2 Wi Fi issues-should I return?

Discussion in 'iOS 8' started by rp2955, Oct 2, 2014.

  1. rp2955 macrumors member

    Joined:
    Mar 14, 2011
    #1
    Hi all,
    My 14-day return policy is up tomorrow and trying to decide whether I should return my iPhone 6 to Verizon for a replacement or not. I am having the same issues that a number of other folks are having with wi-fi disconnects. I have tried both 2.4 and 5Ghz and have the same issue. None of my other devices are having issues (wife's 4S, Ipad 3, computer, etc).

    I tried Reset Network Settings and that helps for awhile but then it will come back. Is it normal to see the LTE indicator when you first go to unlock the phone and then the wifi signal to kick in a little later? Sometimes I see the wifi indicator on my lock screen and sometimes I see LTE. Wasn't sure if this is normal behavior?

    It looks like folks with wifi issues are in the minority now after the latest update so wondering if this is just a bad phone. Thoughts?
     
  2. Orlandoech macrumors 68040

    Orlandoech

    Joined:
    Jun 2, 2011
    Location:
    Salt Lake City, UT
    #2
    This is a software issue, not a hardware issue.

    You said it yourself "I am having the same issues that a number of other folks are having with wi-fi disconnects.". So why would you return it?

    :confused:

    The phone is fine. No, its not normal behavior, its a bug in 8.0.2. You can always try a clean DFU install of iOS 8.0.2.
     
  3. macduke macrumors 604

    macduke

    Joined:
    Jun 27, 2007
    Location:
    Central U.S.
    #3
    WiFi issues seem to crop up with every iOS 8 release. I have them nearly every time—especially at work on the university network. They tend to get better with updates. Not sure why this happens every year but I hate it.
     
  4. Woochifer macrumors 6502a

    Joined:
    Apr 22, 2007
    #4
    Those other devices also use older chipsets that don't support 802.11ac.

    First thing you should do is make sure that your router is running the latest firmware. Also, you might want to try setting your router to "Wireless N-only" if you don't need backwards compatibility with 802.11b or 802.11g devices.

    In the past, some newer iOS devices didn't play nice with older routers, so you want to verify the cause of the problem first before proceeding.
     
  5. rp2955 thread starter macrumors member

    Joined:
    Mar 14, 2011
    #5
    Yes, I have it set to "n" only. No other devices in my house have seen disconnects. I have an Asus RT-N66U router that has been rock solid. I can see the Phone dropping from the list of wireless clients on the router administration page when it refreshes.

    Here are more variations of what I am seeing:
    -Randomly disconnects from Wi Fi and stays disconnected. When I try to reconnect, it says I have the wrong password (when I know I don't). If I go and connect to another network and come back to that same network, it will connect using the same password it previously said was wrong. This seems to happen with 5ghz the most.
    -Randomly disconnects from Wi Fi for a few seconds, but then reconnects
    -Go into list of wireless networks, the circle will spin and not find any networks at all. Turning wi-fi off and on sometimes work, sometimes it doesn't and have to reboot the phone.
     
  6. daihan123 macrumors newbie

    Joined:
    Sep 19, 2012
    #6
    Same here

    What you have described is my exact issue too, word for word. The wrong password one really is driving me bonkers. I have to reset my router to get the password to work sometimes. So weird! I hope this is fixed soon.
     
  7. bozzykid macrumors 68020

    Joined:
    Aug 11, 2009
    #7
    Apple surely hopes so or they will be in a world of hurt. It is only affecting the iPhone 6/6+ and the iPad Air which uses a similar broadcom chipset so it is likely a driver issue.
     
  8. blhoward2 macrumors 6502

    Joined:
    Sep 19, 2012
    #8
    What's weird is that my wife is having this issue and I'm not. Same router, etc. Both on iPhone 6s. Both set up as new phones (not restores).
     
  9. funkymonkeyboy macrumors regular

    Joined:
    Aug 17, 2010
    Location:
    Northern Scotland
    #9
    I do hope Apple fix this issue soon as it's driving me crazy.
     
  10. jayes macrumors regular

    Joined:
    Oct 11, 2011
    #10
    ^^ Me, too! In fact, it happened this afternoon.
     
  11. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #11
    I've had good results by changing the 5GHz channel. I previously had my 5th Gen AEBS manually set to channel 153 and our iPad Airs could barely load a webpage and showed signal connection data rates as low at 6Mbps (as opposed to 300). I set the AEBS to Auto (it selected ch. 149) and all is basically normal, with normal data rates of the max of 300Mbps. I say "basically" as it sometimes shows issues connecting with iTunes (though I think that's more to do with the latest iTunes update).

    While I could, I did downgrade back to 7.1.2 to verify ch 153 still worked just as well as it always did, which it did, so I don't really know why it failed - at least from an interference standpoint. Currently running 8.0.2.
     

Share This Page