"Add Wi-Fi Calling to Other Devices" button does nothing

Discussion in 'iOS 9' started by Steve.P.JobsFan, Sep 17, 2015.

  1. Steve.P.JobsFan macrumors 6502a

    Steve.P.JobsFan

    Joined:
    Jan 27, 2010
    Location:
    Cincinnati
    #1
    I'm on iOS 9 with an iPhone 6 Plus I purchased from AT&T, but I'm now using with T-Mobile. I have been using Wi-Fi Calling since iOS 8.

    I want to enable Wi-Fi Calling Continuity, but tapping the button does nothing.

    I can use my iPad to make calls when my iPhone is on Wi-Fi calling when nearby, but I cannot be away from my iPhone and have it work.

    Does this "Add Wi-Fi Calling For Other Devices" button work for anyone else? I tap it and nothing happens. I did get a carrier settings update today to T-Mobile 21.1. I was hoping that would fix it, but no dice.

    Anybody else have luck? Photo of what I'm talking about is attached.
     

    Attached Files:

  2. LewisChapman macrumors 6502a

    LewisChapman

    Joined:
    Jan 10, 2015
    #2
    I have been running the beta of iOS9 and was very surprised to see that Apple released the final version with this option included.

    The button does nothing for me either running iOS 9.1.
     
  3. chrf097 macrumors 68040

    chrf097

    Joined:
    Dec 16, 2011
    #3
    There's issues currently with iMessage/FaceTime Activation, Wi-Fi Calling Activation, and Personal Hotspot Activation on T-Mobile currently with iOS 9.
     
  4. Steve.P.JobsFan thread starter macrumors 6502a

    Steve.P.JobsFan

    Joined:
    Jan 27, 2010
    Location:
    Cincinnati
    #4
    Gotcha. Do you have a source? :)
     
  5. chrf097 macrumors 68040

    chrf097

    Joined:
    Dec 16, 2011
    #5
  6. Steve.P.JobsFan thread starter macrumors 6502a

    Steve.P.JobsFan

    Joined:
    Jan 27, 2010
    Location:
    Cincinnati
    #6
    This just popped up... :)
     

    Attached Files:

  7. Billymac19 macrumors regular

    Billymac19

    Joined:
    Apr 29, 2011
    Location:
    Phila, PA
    #7
    ive been on ios 9 since first beta, worked perfect til yesterday. my macbook connects but ipad no longer does, so you must be right
     
  8. Billymac19 macrumors regular

    Billymac19

    Joined:
    Apr 29, 2011
    Location:
    Phila, PA
    #8
    were u able to get it working on the ipad yet?? my macbook does, but ipad enable wifi gets no pop up still
     
  9. rigormortis, Sep 19, 2015
    Last edited: Sep 19, 2015

    rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #9
    it works just fine, thank you for asking. I've tried it a couple times and i was able to make cellular calls on my iPad when my iPhone was turned off. a macbook would require el capitan

    here is the support article

    https://support.apple.com/en-us/HT203032

    i was having difficulty with this. i called t-mobile and they weren't much help.
    they put me in touch with Christopher from applecare. he lied to me and he had no idea what he was talking about
    and he was saying that the iPhone and iPad had to be on the same wifi network

    the support article recommends waiting 2 minutes between each step

    if you have issues, try powering down and reseeding the sim card
    turn off iPhone
    eject sim
    turn on iPhone
    wait until iPhone boots up, unlock iPhone and the home screen loads and it says no sim
    insert sim

    and then


    turn on wifi calling
    turn on calls to other devices
    (with other phone carriers like AT&T or iOS 8 these two options cannot be turned on simultaneously )

    wifi calling will ask you to update e911 address and it might say upgrade to wifi calling on the iPhone

    once you go to your other device, like your iPad and go to facetime and do the same thing
    like enabling calls from your iPhone, it will set up a pairing code.

    once the pairing code is entered you should be getting a message eventually saying that this feature is activated

    you cant make any calls until your iPad says that feature is now on

    so far as i can figure out, if you turn off your iPhone and it had wifi calling turned on, or you connected your
    ipad to a different wifi network, you need to wait 2 minutes before a phone call will be allowed or it won't go through.

    one issue i had was with my cellular iPad. i am not sure if the phone # on that sim card would effect wifi calling in anyway so I when i test this i turn off the cellular data.

    if you cannot turn wifi calling on at all, it might be because you are on a t-mobile prepaid account. i saw a graph on t-mobile where you compare plans and it said that the per minute plan doesn't come with wifi calling

    in order for calls to other devices to work , your iPhone must say "T-Mobile WFI" in the upper left hand corner. if it is just connected to the LTE network, i don't think you can make and receive calls on other devices, but its only 3 days and i haven't fully messed around with it


    i have a walmart $30 plan and it works, the walmart plan works with music freedom too

    i was getting an error for a while telling me to call t-mobile and ask them to add wifi calling to my account. when i called them , they were stumped. thats when i tried reseeding and it seemed to fix it
     
  10. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #10
    when i told christopher that ios 9 has a new feature where if i have t-mobile, i can leave the iPhone home, take my iPad to mcdonadls and make a telephone call, he said this was not true. he said that in iOS 8 the iPhone and iPad had to be on the same wifi network and had to be in close proximity. iOS 9 just allows you to be further apart but be on the same wifi network

    i told him it was not true, he wouldn't look it up, when i hung up, i got it to work, i emailed him at his apple .com email address and he never replied. i dd the apple survey and rated him terrible and i wrote a letter to apple got tell him how bad applecare treated me
     
  11. perkedel macrumors 6502a

    perkedel

    Joined:
    Dec 30, 2014
    Location:
    California
    #11
    When I tap the "Add Wi-Fi Calling For Other Devices", it adds two of my Macbooks, then it disappears after those two machines are listed.

    [​IMG]

    I don't have an ipad to try it, so I don't know if the calls will work on the macs (needs 10.11). You should go to some free wifi places and turn off your phone. Then attempt make calls. See if that works; from what I read, that's how it's supposed to work in ios 9.
     
  12. kmichalec macrumors 6502a

    Joined:
    Aug 14, 2010
    #12
  13. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #13
    if you don't have anything ios 9 to try it on , then it won't work
    your macs need to be running 10.11


    i would say turn off wifi calling and just go back to regular allow calls on other devices
    have you tried ejecting the sim card , or putting the iPad into airplane mode, but enabling wifi and bluetooth

    are running 9.1 PB on all devices ?

    whenever i upgrade to new iOS i sometimes feel like i have to uncheck handoff on all devices and turn it back on
     
  14. perkedel macrumors 6502a

    perkedel

    Joined:
    Dec 30, 2014
    Location:
    California
    #14
    Yes I already know that, that's why I mentioned it in my post above.
    What OP needs is to try it out with his ipad.
     
  15. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #15
    oh ok , heh

    i think they key here is to wait 2 minutes or longer and do one step at a time
     
  16. E3BK, Sep 20, 2015
    Last edited: Sep 20, 2015

    E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #16
    This is sweet! I just tested it on my iPad after following your instructions on Post #9. I do have post-paid TMO so I knew this was something they had been working I turned my iPhone off and made a call to my landline via my iPad. it worked!

    But I can't seem to get it to work on my MacBook Pro. Running El Cap, I don't see the option in FaceTime to use WiFi Calling and so I never get the code to pair it.
     
  17. kmichalec macrumors 6502a

    Joined:
    Aug 14, 2010
    #17
    I haven't tried ejecting the SIM card or putting the iPad into airplane mode, with Wifi/bluetooth on. Will try that.

    But yes, both are running iOS 9.1 PB, and I've unchecked everything on both devices, logged out of iCloud on both, rebooted, so I was starting from scratch, and still the same thing. But I'll try what you mentioned above. I might also try doing a reset all network settings on the iPad. The strange thing is I know they are communicating, because as soon as I hit the Upgrade to Wifi Calling link on the ipad, and select enable, the iPhone prompts automatically for a PIN from the iPad, but the iPad never shows a popup with a PIN.

    Are you running the same setup (iPhone and iPad on iOS 9.1 PB) and does it work for you?
     
  18. kmichalec macrumors 6502a

    Joined:
    Aug 14, 2010
    #18
    I just tried Airplane mode, and reinserting the SIM, and reset network connections, and nothing fixed it. Still not getting the PIN on the iPad to enter into the screen on the iPhone.
     
  19. Billymac19 macrumors regular

    Billymac19

    Joined:
    Apr 29, 2011
    Location:
    Phila, PA
    #19
    same here, has too be a 9.1 bug with the ipads
     
  20. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
  21. Steve.P.JobsFan thread starter macrumors 6502a

    Steve.P.JobsFan

    Joined:
    Jan 27, 2010
    Location:
    Cincinnati
    #21
    Logged a complained with AppleCare a few days ago. Upgrade to Wi-Fi Calling button on my iPad is jank... Couldn't get a PIN to appear. On 9.1 Public Beta. Was supposed to be called back on Friday. Didn't happen. :(

    Glad to see I'm not the only one.
     
  22. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #22
    whatever you do , if you get a call back from Christopher B , hang up
     
  23. kmichalec macrumors 6502a

    Joined:
    Aug 14, 2010
    #23
    I think we are having two different issues. You were trying to get your Macs to show on the iPhone as available devices. We are trying to get the iPads to turn on WiFi Calling. It seems that 9.1 has an issue where it won't show the PIN on the iPad to enter into the iPhone prompt.
     

Share This Page