Adium/MSN SPAM

Discussion in 'Mac Apps and Mac App Store' started by anschris, May 5, 2008.

  1. anschris macrumors newbie

    Joined:
    Oct 1, 2007
    #1
    I have been getting pestered by p0rn spam messages coming into my Adium from random MSN users who I don't know. All of them want me to go watch their webcam. Not interested.

    HOW ON BLOODY EARTH do I make Adium block all messages that come through from accounts that are NOT on my contact list? Is there NO WAY to do this? If not, I will delete the program and find something else.

    Thanks!
    Andrew
     
  2. karenflower macrumors 6502a

    karenflower

    Joined:
    Dec 7, 2007
    #2
    Go to Adium in the menubar, choose Privacy Settings and set your Privacy level as 'Allow only contacts on my contact list'. That should do the trick!
     
  3. redeye be macrumors 65816

    redeye be

    Joined:
    Jan 27, 2005
    Location:
    BXL
    #3
    So annoying and such an easy solution.
    I was getting so fed up with those messages. Idiot fracking spammers.

    Thanks for posting this you two!
     
  4. kalex macrumors 65816

    Joined:
    Oct 1, 2007
    #4
    haha, thanks for the fix, I've been getting them as well and its annoying
     
  5. trabera macrumors newbie

    trabera

    Joined:
    Jul 26, 2008
    Location:
    Los Angeles, CA
    #5
    Man this has been driving me crazy forever and I NEVER spotted that setting! I was always looking under the Preferences...

    Dur...

    Thanks!

    -Josh
     
  6. carlosap macrumors newbie

    Joined:
    Apr 22, 2008
    #6
    Thanks men! :D no more spam


     
  7. willcodejavafor macrumors regular

    Joined:
    Dec 4, 2007
  8. esphil macrumors member

    Joined:
    Oct 19, 2008
    #8
    I was about to go nuts, I tried to find the settings but couldn't locate it. I have got at LEAST 100 spam IM's all this week during work!!:eek:
     
  9. bossfn macrumors newbie

    Joined:
    Feb 24, 2008
    #9
    Wow, +1 !!

    The setting must have got reset on me when I reinstalled os x. I haven't had a problem with Adium in well over 2 years, and I was getting pretty freakin' upset over this!

    A million thanks!
     
  10. TheReef macrumors 68000

    TheReef

    Joined:
    Sep 30, 2007
    Location:
    NSW, Australia.
    #10
    Thanks!
    They really need to put this under preferences, I've never noticed this before as I always hit [ command - , ] :eek:
     
  11. pulsewidth947 macrumors 65816

    pulsewidth947

    Joined:
    Jan 25, 2005
    Location:
    squarefrog.co.uk
    #11
    Haha awesome - I was getting fed up with this. Knew there must have been an easy solution, but like others I was looking in preferences.
     
  12. yieldtomac macrumors newbie

    Joined:
    Nov 30, 2008
    #12
    Umm

    A simple solution is always great if it works. The accolades are rather amusing when you realize it doesn't.
     
  13. CaffeMacchiato macrumors member

    Joined:
    Nov 10, 2008
    #13
    Hi I am getting spam from my own contacts. What should I do? Is there a way to check if the spam is originated from me or my contacts?
     
  14. Narcosynthesis macrumors member

    Joined:
    Dec 21, 2008
    #14
    If it is getting sent from one of your contacts then it will likely be their account has been borrowed by some spammers.

    The new contact spammers have been driving me mad too, and only became an issue when I got my mac and adium... On my old computer I only rarely got messages like that, which has increased to many during an evening now - a problem with adium somewhere?

    This should still let people try and add me when their email is unknown, just not send me a message until i accept?
     
  15. bossfn macrumors newbie

    Joined:
    Feb 24, 2008
    #15
    It's unlikely their account was "borrowed" -- it's much more probable that particular contact has spyware/malware/virus on their computer which is sending messages to their contacts without their knowledge.

    Luckily, you're on a Mac and most likely safe. Close the message and tell your friend to scan their computer.
     
  16. verolynne macrumors newbie

    Joined:
    Jan 6, 2009
    #16
    Finally! It can end!

    I'm glad I wasn't the only one!
    Thanks so much for posting this guys!
     
  17. Nitrocide macrumors 6502

    Nitrocide

    Joined:
    Sep 24, 2005
    Location:
    Bristol, UK
    #17
    Geez, ive been putting up with this for weeks. +1 for the preference panel.
     
  18. MecPro macrumors 6502

    Joined:
    Mar 6, 2009
    Location:
    London
    #18
    The thing is, my friend who I got the message from this morning is ON A MAC. The problem is Adium, as I have tried the whole privacy thing before and it has NOT WORKED. :mad:
     
  19. stylinexpat macrumors 6502a

    Joined:
    Mar 6, 2009
  20. Kuhnaydeein macrumors newbie

    Joined:
    Dec 26, 2007
    #20
    "Ignoring me would be the biggest mistake you ever made sexy!"

    it wouldn't be so bad, but I have Adium read ALL my incoming messages to me...

    Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!! Thank You Guys!!!
     
  21. alumac macrumors member

    Joined:
    Mar 31, 2009
    #21
    haha.. this is one of the reasons i stopped using adium. the other reason is that i got a new mac and never bothered installing and setting up adium.

    well, maybe i'll get it again now. thanks!
     
  22. CitiXen macrumors member

    CitiXen

    Joined:
    Feb 9, 2009
    #22
    Thank you! I had the same problem.
     
  23. macintoshi macrumors 6502

    macintoshi

    Joined:
    Dec 11, 2008
    Location:
    Switzerland
    #23
    Wrong

    Well wrong, because the contact has at the momment no pc and there is no pc she be on, when the spam is comeing in adium:

    14:36:20 contactisoffline@hotmail.de: http://HotPiczz.com/?user=myhotmailname&image=DSC00245.JPG ?!?

    ... HAHAHA!!


    How to prevent this? Greetz
     
  24. Howard Brazee macrumors 6502

    Howard Brazee

    Joined:
    Oct 24, 2006
    Location:
    Lafayette CO
    #24
    I told Adium to only use my contacts. But it changes to "multiple privacy settings are active" and I get spam. Worse, I cannot mark such spam as Spam, with this setting.

    It seems every time I restart Adium, it resets this.
     
  25. grahamrb macrumors newbie

    Joined:
    May 29, 2009
    #25
    Thank you for this. This should so be the default setting for Adium!
     

Share This Page