smockonallama

macrumors newbie
Original poster
Feb 7, 2008
5
2
I am posting this because I could not find this answer anywhere.

Did you upgrade to Catalina Server and have issues getting AFP to work?

Does it connect and then prompt that you have no access to the files?

Well, search no further for your solution.

  1. Open System Preferences.
  2. Click Security & Privacy.
  3. Click Privacy.
  4. Click Full Disk Access.
  5. Unlock the pane.
  6. Click "+".
  7. Select /System/Library/CoreServices/AppleFileServer/Contents/MacOS/AppleFileServer.
  8. Ensure it is checked after.
  9. Connect to AFP from a client and you will have solved the world problems for Apple legacy support.
Enjoy!
 

nikushima

macrumors newbie
Oct 12, 2020
1
0
Thank you for the fix. I have a external HFS+ hdd that is connected to Mac Mini 2018 (non server OS X). When I upgraded to Catalian I can mount the hdd. But could not see the files inside.

Giving full access to AppleFileServer in the Privacy Preference fixed it. Only thing is I could not open the "Contents/MacOS/AppleFileServer" in "/System/Library/CoreServices/AppleFileServer". So I just gave full access to "/System/Library/CoreServices/AppleFileServer" and it worked! Thanks again!
 

simply180

macrumors newbie
Dec 10, 2011
2
0
I know this post is a little old however I am running into issues connected to my macmini server thru my VPN connection. We just moved offices and to set the server and VPN back up.

Getting message "There was a problem connecting to the server xx.x.xxx.xx" using the VPN then connecting to server using afp:/xx.xx.xx.xx

  • All computers connect to the VPN.
  • 3 out of the 6 computers connect to the server using the AFP command fine.
  • 1 computer that can connect and one that cant are using the same iOS version
  • I have shutdown and restarted countless times
  • I have cleared memory of user credentials for the server
  • I have tried from a totally brand new computer.
  • I have the same setup on all my computers and one never was able to connect, and the other connected and now wont connect again.
Please help me solve this. I tried doing what was recommended on this thread however similar to the last post, the only thing is I could not open the "Contents/MacOS/AppleFileServer" in "/System/Library/CoreServices/AppleFileServer" and it does seem to have worked. I also checked on and off the "send all traffic...."

I am running Catalina 10.15.7.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.