after OS update Ethernet port DEAD

Discussion in 'Mac mini' started by Phil in ocala, Aug 16, 2016.

Tags:
  1. Phil in ocala macrumors 6502

    Phil in ocala

    Joined:
    Jul 14, 2016
    #1
    I have a mid 2011 & I must connect by wifi as the ethernet port is DEAD...I read that Apple Developer Geeks disconnected it when the OS was updated..... I bought a Auxkey that uses USB to Ethernet...it worked for about a week and its now dead. Anyone else with this problem and how did you or not solve it.
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    So just to clarify, the Ethernet has been dead for some time? You could always try reset PRAM/SMC... beyond that, it may be best to take it to an Apple Store.

    If you're looking to fix your adapter, an OS update wouldn't have bricked that. It's more likely the adapter itself gave up the ghost.
     
  3. Phil in ocala thread starter macrumors 6502

    Phil in ocala

    Joined:
    Jul 14, 2016
    #3
    Tried to reset Pram..did nothing to help...bought two of these...both failed.
    Maybe Apple did this as they feel the ethernet port is not necessary...like wired earbuds for iPhone 7?
     
  4. jpietrzak8 macrumors 65816

    jpietrzak8

    Joined:
    Feb 16, 2010
    Location:
    Dayton, Ohio
    #4
    I'm running a 2010 Mini on El Capitain right now. It's on Ethernet, and always has been; I've tested its Wifi from time to time, but never found a reason to use it.

    I really doubt that Apple has anything against using Ethernet. There are many situations where being able to connect by wire is significantly better than going wireless...
     
  5. Phil in ocala thread starter macrumors 6502

    Phil in ocala

    Joined:
    Jul 14, 2016
    #5
    I was being sarcastic.....but you have no answer to my problem?
     
  6. jpietrzak8 macrumors 65816

    jpietrzak8

    Joined:
    Feb 16, 2010
    Location:
    Dayton, Ohio
    #6
    Well, honestly, I've never had (or even seen) the problem you're describing. :(

    The built-in Ethernet port should be running on a different bus than a USB Ethernet dongle would. The fact that both have failed makes me wonder if there's something particular about the Ethernet setup at your location... Do you have other Ethernet based devices that are working without problems? (For example, Ethernet is not designed to supply power via the cable; as such, I could believe that a power surge running through the line could disable hardware.)
     
  7. mdgm macrumors 6502a

    Joined:
    Nov 2, 2010
    #7
    The mid-2011 Mini has a Thunderbolt port so a Thunderbolt to Gigabit Ethernet adapter could be an option if you are not using that port for something else.
     
  8. MikeatOSX macrumors regular

    MikeatOSX

    Joined:
    Mar 26, 2007
    Location:
    Austria
    #8
    Which update do you mean?
    Did you ever try a fresh install on an external hard disk for testing?
     
  9. macdragonfl, Aug 18, 2016
    Last edited: Aug 18, 2016

    macdragonfl macrumors 6502

    macdragonfl

    Joined:
    Jan 11, 2006
    Location:
    Ft. Lauderdale,Fl
    #9
    i would do a clean install before i did anything else. The pram battery could also be bad. If clean install does not work, replace pram battery. I did that to a friends iMac that optical drive would not work and half of usb ports were dead. Fixed it all.
     

Share This Page