After Sierra upgrade, Bluetooth: Not Available

Discussion in 'macOS Sierra (10.12)' started by Treadpool, Oct 10, 2016.

Tags:
  1. Treadpool, Oct 10, 2016
    Last edited: Oct 10, 2016

    Treadpool macrumors newbie

    Joined:
    Oct 10, 2016
    Location:
    Boston, MA
    #1
    I did an in-place upgrade of El Capitan to Sierra a week or so ago. Everything seems ok except for Bluetooth. It's completely non-existent.

    I've tried re-installing Sierra, SMC reset, and NVRAM reset. I've tried deleting the bluetooth plist file. When I go to About this Mac and select System Report, the Bluetooth section under "Hardware" says "No information found".

    When I go to Bluetooth in System Preferences -> Network, Bluetooth is off. The option to "Turn Bluetooth On" is greyed out.

    Bluetooth was working fine before the upgrade and now it seems there's no driver or anything installed. Any ideas?
     
  2. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #2
  3. Treadpool thread starter macrumors newbie

    Joined:
    Oct 10, 2016
    Location:
    Boston, MA
    #3
    Thanks - looked for that. All it gives me is the option to "Create Diagnostics Report on the Desktop". I don't see any of the other options in that menu when holding down the keys it says to.
     
  4. senand macrumors newbie

    Joined:
    Jan 24, 2017
    #4
    I have exactly the same problem.
    Funnily, it used to work on Sierra for me, and now an unknown reason it stopped working, with the same symptoms as described.

    Did you fix it in the meantime?
    --- Post Merged, Jan 24, 2017 ---
    For me resetting the NVRAM worked
    https://support.apple.com/en-us/HT204063
     
  5. Treadpool, Jan 25, 2017
    Last edited: Jan 25, 2017

    Treadpool thread starter macrumors newbie

    Joined:
    Oct 10, 2016
    Location:
    Boston, MA
    #5
    Unfortunately, no. I had to buy a Bluetooth USB dongle - seems the upgrade messed up my Bluetooth permanently. Brought it into the store and they agree - offered to replace the comms board for $150. I politely declined. Then again, it's hard to directly associate it (and prove the case) to an OS upgrade even though it worked fine minutes prior in El Capitan. Dead in Sierra.
     
  6. apoklipsys macrumors newbie

    apoklipsys

    Joined:
    Apr 25, 2017
    #6

    Hi Guys, i've done all the recommended steps and nothing.. and changed the comm board, nothing.., a few weeks ago i was working with apple support and they told me to delete the login items on my user account, after that, it worked.., but a month after problem is the same, and no login items.. everything happened after a Sierra update.
     
  7. nobodykeys macrumors newbie

    Joined:
    Aug 18, 2009
    #7
    Hi - which dongle did you get? Most on Amazon don't seem to endorse Mac support.

    Also, was it straightforward to set up? I read on some other forums how it was problematic to get the OS to switch to using the dongle Bluetooth, as opposed to the inbuilt Bluetooth.
     
  8. mariyasomers, Oct 13, 2017
    Last edited: Dec 12, 2017 at 1:13 AM

    mariyasomers macrumors newbie

    mariyasomers

    Joined:
    Oct 11, 2017
    #8
    i troubleshoot this issue on my Macbook pro, following this source, Erase Bluetooth Plist required on serious problem.

    it will auto add once we reboot the system or reconnecting to Bluetooth. Really Helpful: http://bit.ly/2AbP4pU
     
  9. tomkessler macrumors newbie

    Joined:
    Nov 2, 2017
    #9
    I ran into this on a 2017 imac. In addition to pram reset, smc reset, and erasing the Bluetooth.plist files
    I had to boot into safe / fix mode.
     

Share This Page