Airpods not showing on Watch 3

Discussion in 'Apple Watch' started by Scott6666, Sep 24, 2017.

Tags:
  1. Scott6666 macrumors 65816

    Scott6666

    Joined:
    Feb 2, 2008
    #1
    My airpods are not showing on my new Watch 3 even though they are on my phone. Tried a erase and re-pair but still nothing. If I go to Bluetooth it just searches in vain.

    Are your airpods connecting to your Watch 3? Maybe bluetooth is not functioning on my watch.
     
  2. patrickdunn macrumors 6502a

    patrickdunn

    Joined:
    Apr 16, 2009
    Location:
    St. Louis, MO
    #2
    I had the same issue. I had to put them in pairing mode - hold the button on the back until the indicator light blinks white. Then my watch found them and paired. See if that works.
     
  3. Trent0341 macrumors 6502

    Joined:
    Jun 3, 2007
    #3
    Mine connected seamlessly but I would have recommended the same thing Patrick did.
     
  4. Scott6666 thread starter macrumors 65816

    Scott6666

    Joined:
    Feb 2, 2008
    #4
    Worked. Thank you so much! Saved me a genius bar appointment.

    Hope this does not mean my W1 chip is not working (if the watch even has one).
     
  5. Jgibb26 macrumors newbie

    Jgibb26

    Joined:
    Sep 24, 2017
    #5
    One thing I do if they are not connecting is to go to the airplay icon on the pull up menu on the watch face screen and select AirPods I don’t know if that will help anyone or not
     

Share This Page

4 September 24, 2017