Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

jimmy_uk

macrumors 65816
Original poster
Oct 19, 2015
1,378
1,318
UK
So my new AirPod Pros pair and work no problem. They also seem to charge in the case ok. But when I get the onscreen animation upon opening the case I remove an AirPod and put it back the two images of the AirPods dance side to side like it’s glitching and shows a red exclamation. This swaps depending on what AirPod I remove then replace.

There’s no dirt or dust in the case or AirPods. What the hell is happening? Are these defective?

I repaired several times and reset the phone but it keeps happening.

829EE2B7-39B2-4DC5-8B7D-5103EB082236.png
 
  • Like
Reactions: ascender

thedru13

macrumors 6502
Sep 12, 2014
304
102
They might be updating. I had the same issue when they were installing the newest firmware.
 
Comment

Tommy Hewitt

macrumors member
Sep 19, 2013
69
79
Same here, doesn't matter if I use it with iphone or ipad pro. No need to worry, a fw update will fix this I guess.
 
  • Like
Reactions: jimmy_uk
Comment

jimmy_uk

macrumors 65816
Original poster
Oct 19, 2015
1,378
1,318
UK
Phew. Glad I’m not the only one. Sometimes the on screen animation doesn’t come up at all so I was hoping it’s a software glitch. Clearly there’s an issue if the earphone animation is dancing left and right, right? ???

Regarding software do they update themselves?
[automerge]1572477216[/automerge]
I’m on that but have the issue.
 
Last edited:
  • Like
Reactions: moyjoy
Comment

HalfPintOfInnes

macrumors member
Sep 11, 2016
56
60
Scotland, United Kingdom
Came here to see if anyone else was having the same issue, thought I was putting them in the case wrong, but nope, both securely in, and the right one seems to be flashing up with the red exclamation point anytime I open the case. Not exactly reassuring for a product I've owned for less than 6 hours. Hoping it's software and not a hardware issue.
 
Comment

jimmy_uk

macrumors 65816
Original poster
Oct 19, 2015
1,378
1,318
UK
Came here to see if anyone else was having the same issue, thought I was putting them in the case wrong, but nope, both securely in, and the right one seems to be flashing up with the red exclamation point anytime I open the case. Not exactly reassuring for a product I've owned for less than 6 hours. Hoping it's software and not a hardware issue.
It has me looking at these in a different light because these seem fragile and the charging area on the AirPods are very small as are the pins in case. Any dirt, grit or micro scratches are gonna kill these I’m sure. In contrast my Sony WF-1000XM3 are built like a tank. I just hope Apple haven’t over engineered these on a quest to make them super user friendly and simple. Or do I mean under engineered?
 
Last edited:
Comment

HalfPintOfInnes

macrumors member
Sep 11, 2016
56
60
Scotland, United Kingdom
It has me looking at these in a different light because these seem fragile and the charging area on the AirPods are very small as are the pins in case. Any dirt, grit or micro scratches are gonna kill these I’m sure. In contrast my Sony WF-1000XM3 are built like a tank.

I'm still trying to get used to the earphone portion facing the inside of the case and not facing outwards like the original AirPods were. But there seems to be a lot of excess space where the stem and the charging pins are, also worried about dirt/debris getting in there
 
  • Like
Reactions: jimmy_uk
Comment

Banglazed

macrumors 68040
Apr 17, 2017
3,592
4,282
Cupertino, CA
A friend experienced this issue even on the AirPods 2. Leave it in the case to charge.

Open the lid and check the status light. It should flash amber. Press and hold the setup button on the back of the case for 5 seconds. The status light should flash white. If it still flashes amber, connect the case to power, close the lid, and wait 10 minutes.

On your iPhone, go to the Home screen. Open the case with your AirPods insideand hold it next to your iPhone. A setup animation appears on your iPhone. Tap Connect.
 
Comment

Apple_Robert

Contributor
Sep 21, 2012
24,486
29,609
In the middle of several books.
Phew. Glad I’m not the only one. Sometimes the on screen animation doesn’t come up at all so I was hoping it’s a software glitch. Clearly there’s an issue if the earphone animation is dancing left and right, right? 💃🕺🏻

Regarding software do they update themselves?
[automerge]1572477216[/automerge]

I’m on that but have the issue.
My pro pods still haven’t updated after an hour in the case next to the phone. It would be nice to be able to manually update the firmware.
 
  • Like
Reactions: jimmy_uk
Comment

jimmy_uk

macrumors 65816
Original poster
Oct 19, 2015
1,378
1,318
UK
A friend experienced this issue even on the AirPods 2. Leave it in the case to charge.

Open the lid and check the status light. It should flash amber. Press and hold the setup button on the back of the case for 5 seconds. The status light should flash white. If it still flashes amber, connect the case to power, close the lid, and wait 10 minutes.

On your iPhone, go to the Home screen. Open the case with your AirPods insideand hold it next to your iPhone. A setup animation appears on your iPhone. Tap Connect.
Light is green not amber?
 
Comment

Shadowbech

macrumors 604
Oct 18, 2011
6,875
2,872
Happens on my AirPods 2 as well, not just the APP. But still plays music. But haven't had this issue with my APP yet. *Knock on Wood
 
Comment

aloper

macrumors 6502
Nov 23, 2015
409
419
Rocklin, CA
Unboxed and connected them to charge...always charge up to 100% before I dive in using them. While charging, opened up the case and got the left one bouncing back and forth from red to green. Let them finish charging and then paired. Haven’t had the issue since after using them for a few hours...Have put them in the case to charge and used again, rinse and repeated a few times and now they both rock solid green...
 
Comment

kmjo30

Cancelled
Nov 14, 2017
20
14
New Orleans, La
Charged to 100% AirPods pro and case. Went to gym around an hour at the gym my right pod went out before my left. Right 46% Left 76%. Left AirPod was playing while in case also. I’ll be keeping an eye out for uneven battery drain. I’m thinking it’s from the battery indicator jumping left to right. We are starting to buy some expensive problems lately.
 
  • Like
Reactions: jimmy_uk
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.