Airport DHCP fails to get address (Mac on Windows Network)

Discussion in 'Mac Accessories' started by markogier, Jun 7, 2006.

  1. markogier macrumors newbie

    Jun 7, 2006
    Please help!
    I am a comitted Mac switcher trying to put my lovely new MacBook onto the office Windows network. I can connect to the office wireless network (WEP key etc) and the little radar Icon in the menu bar lights up. However, I cannot get the MacBook to obtain an IP address via DHCP. I just keep getting the default self assigned address (169.....).

    However, when I connect to the network via a cable using the built in ethernet connector, I get the DHCP address just fine and everything works OK.

    Also, if I assign an IP address manually to the wireless card (checking it is a free address!) it accepts the settings but I cannot network, not even a basic ping of another machine on the local internal network (all our internal machines are using 10.0.0.x addresses and sub net)

    The DHCP server is not in the wirless router but is a Windows server machine.

    This is driving me crazy. I have called Apple care and they just dont want to know because there is a Windows machine in the mix. I expected better from them, particulalrly as I have paid for Applecare!!

    Many thanks
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Open up your Network section of System Preferences and match the settings for the ethernet port to the settings on the Internet pane of AirPort Admin Utility. Is there any discrepancy? :)
  3. markogier thread starter macrumors newbie

    Jun 7, 2006
    Hi there
    Thanks for your interest. I may have confused things a bt here. I do not have an Airport base station just a wireles card in my MacBok (which I assumed is called an Airport). The wireless base staion is a Netgear Wireless router. The Netgear is not providing DHCP, that is being done by a Windows server.

    As I said, I can connect to the Netgear router wirelessly using the WEP key etc, but when I do I do not get passed an IP address from the Windows server.

    However, if I connect to the lan with a cable, it all work s fine and I get an IP address etc.

    Also, I can connect to my DLINK wirless router at home (which is set to give DHCP IP addresses) and it all works perfectly.

    If you are thinking the Netgera could be faulty, I doubt that as my Windows laptop connects fine and gets addresses.

    This is driving me nuts!

  4. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Ah, my bad. Okay, match the AirPort card settings with the ethernet settings. Notice any differences? :)
  5. maxvamp macrumors 6502a


    Sep 26, 2002
    Somewhere out there
    How is your network wired to the NetGear? Is your DHCP server plugged into the LAN ports or the WAN Port?

    I suspect that if your network is plugged into the WAN port, that the Netgear, with DHCP turned off, may be blocking, at some level, communications to the WiFi.

  6. tmtracy macrumors newbie

    Jun 11, 2006
    I had this same problem, but it was because I was entering the wrong key on the wireless network. OS X won't tell you if it's wrong, it will just connect and not do anything. Contact your sys admin and see if the router is seeing your macbook, if it isn't, that's prolly your problem. tripple check with your sysadmin that you have the right key as well.
  7. markogier thread starter macrumors newbie

    Jun 7, 2006
    Thanks for the replies to this. To respond to the suggestsions

    1. I have quadruple checked the WEP key for the wireless router and it is correct. I am connecting to the router. When viewing the list of connected clients from the router admin console my MAC address is listed. But I d not get an IP address.

    2. The wireless router is on the LAN side of the network. It is not actually used to route to the internet, it is just used as a wireless access point. It has a 10.0.0 address the same as all the other devices on our internal LAN. We do have another rouer which is used to connect the LAN to the internet. DHCP is turned off on that device.

    Just to be clear
    1. This works fine if I connect an ethrnet cable to the MacBook
    2. The DHCP over the wireless works fine on my Acer PC laptop running XP and other people using Sony or Dell PC paltops and XP are fine too.
    3. The MacBook connects wirelessly to my (D-Link) router at home perfectly and I get the IP address no problem. (At home I am using 192.168.2.x addressing)

    I guess having the ethernet cable trailing across my desk is not too much to deal with, it is just frustrating that I cant get wireless to work!!

    Pleae keep the ideas coming, and thanks!
  8. jsw Moderator emeritus


    Mar 16, 2004
    Andover, MA
    As mad jew mentioned, please be sure that when you go to System Preferences...->Network and choose Show->Airport in the second drop-down, that, in the TCP/IP tab, you have DCHP selected. In fact, for each of the relevant tabs "TCP/IP","PPPoE", etc., toggle between the Airport and Built-in Ethernet selections in the "Show" drop-down to, as mad jew suggested, make sure they're the same.

    Edit: other suggestion: I'd click on the "Location:" drop-down and choose "New Location..." (after clicking the lock on the bottom left to unlock things), then create a location called "Work" or whatever, then set it up there. That way, you can also create a "Home" or whatever location to change the way things network when your laptop is there (and so on, for other places you want to connect wirelessly). Then you can toggle network selection with the "Location" menu item under the Apple menu (the one on the top left of the screen). I use a manual address at home (with no proxies) and DHCP at work (with proxies), and this shortcut comes in handy daily.
  9. garfield2002 macrumors regular

    Oct 31, 2003
    Are you using the ASCII WEP key or the whole hex number? I had a similar problem with my TiBook and a Linksys router. Even though my computer gave me the option of 128-bit ASCII, the router would not recognize the key, I had to type in the whole 128-bit hex key.
  10. Sesshi macrumors G3


    Jun 3, 2006
    One Nation Under Gordon
    I haven't even ventured doing this on the Mac yet (never had problems with DHCP assignations) so I'm not sure if it's possible, but have you tried setting a valid IP address manually on the wireless network?
  11. sfmacguy macrumors newbie

    Jun 17, 2006
    can log on but no ip address

    is access control happening on the wireless router?
    you might need to add the mac address of the airport card to the router.

  12. rdepom macrumors newbie

    Jun 28, 2006
    Not sure it's a windows problem or a hardware one...

    I think you guys are assuming some kind of hardware problem when I disagree. I've had exactly this issue with my iMac G5 connecting to our Belkin router, only occasionally and usually when signal strength is poor. I've just gt a MacBook and am having massive problems with this on my University wireless network. I am pretty sure that the problem is OS X's DHCP timeout. Basically it requests an IP address and if the server/router is too slow to respond it gives up and assigns itself one. The issue is that it's giving up too fast. Windows DHCP isn't exactly snappy which would explain Mark's problem, and I know damn sure my Uni's servers are sluggish at times (to be fair they're handling hundreds of wireless roaming connections at any one time plus thousands of wired ones). My big problem is, I have no idea how to change this timeout value! It seems to be about 5s and I think it needs at least doubling. The value must be in a config file somewhere but not sure where, and I can't track down a GUI control for it. Ideas anyone?
  13. markogier thread starter macrumors newbie

    Jun 7, 2006
    Hi there all.
    Thanks for the interest in this post. To update, I still cannot get the wireless airport to get a DHCP IP address from the office netgear router. But the DLink wirelss router at home is perfect and the macbook happily gets an IP setup via DHCP.

    I have tried all the suggestions given
    1. Manual address
    2. Copying settings form the (working) cable connection
    3. Setting up a work location (nice feature this, makes moving around a breeze)
    4. I even tried changing the channel number on the router (to 5) as Iread somewhere that interference can cause problems.
    5. Triple checked the WEP key and it i correct (same key in my PC laptop works fine)

    This is driving me nuts!! Any more ideas.

    BTW. V disappointed with Mac support. I have paid £199 for apple care support and just got some indian guy who could hardly speak english telling me that nobody knew anything about MacBooks and even if they did, because I am trying to connect to a Windows network they were not allowed to help. So much for encouragng people to switch!

  14. Eraserhead macrumors G4


    Nov 3, 2005
    Insist on speaking to someone more senior at Apple if you call them, the problem could well be an OS X/Windows incompatibility, you don't normally use a windows server to give out DHCP.

    For the WEP key have you tried getting the Hex version? That might help. (someone else should be able to tell you how to find what this is)

    The other thing you could try is switching the wireless network security to WPA instead of WEP as that is a lot more secure (and trouble free) it should work fine with OS X or XP SP2.
  15. bokdol macrumors 6502a


    Jul 23, 2002
    ok so i am going to try to figure out your settings.

    1. you have cable internet
    2. plugged into a windows server. (which is set to dhcp) out into...
    3. a wireless router.
    4. the wireless is just bridging the dhcp numbers to the wireless?

    now this is what i suggest. change your wireless router settings to give out dhcp numbers. so the wireless becomes another dhcp server. (not just a bridge)

    i have my cable going to a wired router. that give out dhcp. and my wireless is conected to that. and gives out a different range of dhcp numbers for wireless.
  16. stevep macrumors 6502a


    Oct 13, 2004
    Is the Windows server dishing out the ip addresses? Do you need to put in its' address in the proxy server settings, maybe????
    System prefs> Network> Airport> Proxies> then choose Web Proxy HTTP and type in the IP address and port number (eg and 8080).
  17. jtown macrumors 6502

    Jul 3, 2003
    Just saying this because I haven't seen it mentioned by many of the responders. He's not using the router as a router. What he's attempting to do is use the wireless portion of his router like one of these, eleminating the physical wire. The router may simply not be capable of functioning like this. It's a software issue and it may not be designed to provide that function.

    Getting mad at Apple is pointless. The OP is attempting to set up a non-standard network, using a router in a role it wasn't designed to perform. Please stop wasting Apple's time. Not only did they not sell him this setup or promise him that it would work, nobody would sell him a router and guarantee it could be used like this. It's not Apple's fault he's having trouble with this and it's not their responsibility to fix the problem.

    Now, for the issue at hand...

    The easiest solution would be to obtain the right tool for the job. Remove the "router" from the setup. If you're going to use a router like a switch, don't. Just get a switch. They're $10. Get a wireless "gaming" adapter, configure it, plug it into a switch attached to the network. Yes, they're generally used to attach a wired device to a wireless network and this is going the other way around but it really doesn't matter which end of the link it's on.

    If you don't want to buy new equipment (those adapters are kinda spendy for what you get), you'll have to hope your router can be configured to do what you want. Some can, some can't. If your router's wireless side can be set to "client" instead of "AP", give that a shot. That might let it bridge the wired and wireless connections inside the router. BTW, WPA won't work with this kind of setup. You'll be limited to WEP.

    This is, of course, assuming you absolutely must use the windows server as the DHCP server and router.
  18. Moe macrumors regular

    Apr 27, 2003
    Here's your problem (as said above the router turns what you think of as your network (singular) into two networks (plural) and your DHCP client and server are on different networks).
  19. Demoman macrumors regular

    Mar 29, 2005
    Issaquah, WA
    That is exactly what I think too. You need to be connecting using a wireless Access Point, not a Router, connected to your main network. Then you will probably have success. I am running this at work without a hitch.
  20. trainguy77 macrumors 68040

    Nov 13, 2003
    Almost all wireless routers have settings designed to do exactly what he is doing, and it works for the PC. So what I think he should try is enter those manual IP addresses and then try to ping the wireless routers address. This way you having nothing to do with that extra DHCP server. Also make sure the routers IP your pinging is in the same block as your manuel IP. (ie 192.168.1.X) If this ping does to go through then you know your not connected to the wireless part of the network. If that is the case make sure there is no MAC filtering turned on, on the router. If it is add your macs MAC address to the list and things should be good.

    Post a response of what happens with what I mentioned here, and then we can continue troubleshooting. And the router should work just fine. By the way what is the model number of this router?
  21. trainguy77 macrumors 68040

    Nov 13, 2003
    This should not be the problem if the router has been configured correctly from what I can tell with his network NAT, and DHCP has been disabled on the wireless router. Which turns it into a switch. And besides that is beside the point as its all plugged into the LAN ports not the WAN. If it was plugged into the WAN port then it routes traffic and blocks traffic.
  22. markogier thread starter macrumors newbie

    Jun 7, 2006
    Hmmm, seems like I rattled JTown's cage a bit. Sorry about that. But lets just be clear about Apple support.

    1. I crossed over from being a long time Windows user on the basis that Apple claim Mac work fine in a windows network environment and do everything (OK most things) better.

    2. I PAID £199 for Apple Care support. I had to before they would discuss this issue with me. Only then to be told, in badly spoken english, that a) nobody has had any training on the MacBook and b) even if they had they were instructed not to support Mac issues if the machine was used in a Windows environment. This is not really following up on the marketing hype they put out about being better and integrating fine.

    3. There are dozens (even hundreds) of articles on the net on various newsgroups, including Apples own forums, about this EXACT problem. Firstly on the MAcBook Pro and now on the MacBook. So much so that there are published articles describing the wireless networking woes users are having and that they are being given full refunds by Apple. They dont do that lightly.

    So am I fed up with Apple. Yes.

    So please understand my frustration JTown.

    To get back on topic, JTown suggested it was my own fault for trying to use a router etc in the wrong way. I use the term router purely because that is what it says on the box. It is not routing, NAT is turned off, it is not connected to a WAN, it is not serving DHCP, it has a local (10.0.0.x) IP address and is used ONLY as a wireless access point. Trainguy77 descirbes it perfectly in his subsequent post (thanks guy).

    All the evidence points to something inherently wrong with the MacBook firmware/software/hardware (who knows, Apple dont seem to!).

    1. Cable connection works fine (DHCP or manual)
    2. Wireless connects fine (with DHCP) to my router at home set up in exactly the same way (except that one IS routing as it is my broadband connection)
    3. My windows laptop can connect wirelessly without a problem
    4. Entering a manual IP address does not work. I cannot see the network.
    5. All other wireless machines at the office work fine
    6. I do connect to the wireless box as when you look at the connection status on the wireless boxes management page, my MAC address is in the list.

    Just to re-cap my setup

    1. Netgear wirless box, not doing DHCP, not routing, no NAT, MAC address filtering, my MAC address in the list, WEP password (10 digit text), connects OK, does not give IP address.

    2. Windows network with a Windows server dishing out DHCP stuff. Can use it perfectly with cable (drives, printers, databases, proxy server for internet etc, etc.). NOTHING with wireless connection, not even ping, even if I type in a manual IP address (valid, in-range, unused etc.)

    Have tried just about evrything mentioned in the many posts I have read. These include

    1. Change channel number of wireless box
    2. Remove network from mac, remove password from keychain and start again.
    3. Try entering exact same details as cable connection manually.

    I am at a loss now. Any help greatly appreciated.
  23. trainguy77 macrumors 68040

    Nov 13, 2003
    Is there any chance there is any other type of security you don't know of? RADUIS? anything like that? Captive portal?
  24. brbubba macrumors 6502


    May 20, 2006
    Hmmm things that come to mind.

    Are you running the latest firmware form netgear, never hurts.
    Is the netgear in some special rangemax or enhanced network speed mode. This could screw with things as most of those enhanced speed modes are not common protocols.
    I am not too familiar with server 2k3, but I am sure it has a DHCP log, you should be able to view it and see the request from the mac to the server for an address and then you should also be able to see the server offering an IP to the machine. Any kind of errors in that log might give you some clue as to what is happening.
    Also I would think the DHCP server has an option for creating an IP reservation table based on MAC address. Try putting an entry in for your mac, maybe you will get lucky.
    When you enter an IP in manually, including DNS, Gateway etc, what happens? Can you ping other computers on the network, can you ping external IPs? Are you sure you are not running a proxy?
  25. markogier thread starter macrumors newbie

    Jun 7, 2006
    Hi there

    Thanks to Trainguy and brbubba for your input. As far as security goes, the only security setup on the netgear in WEP and MAC address table. I am 1000% certain I have the correct WEP password (10 digit text) and that my MAC address is in the table on the wireless box (I can see it connected from the management console).

    As for the Netgear firmware it has been updated to the latest version. It is not set for any speed/range boosting settings, just straight g standard.

    I have not tried 'reserving' a mac address on the dhcp server, I will try that.

    As for putting in a manual IP etc, I have tried that. It goes in OK but I cannot get on the network, no ping etc.

    Still driving me nuts!!!!

    Thanks for the input

Share This Page