Airport Extreme Base Station Kicked the Bucket

Discussion in 'Mac Basics and Help' started by hexonxonx, Jun 12, 2011.

  1. hexonxonx macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #1
    Woke up this morning to find no internet. Base station is cold and dead after 5.5 years of good service. :( Shall have a good and proper burial for him.

    I'm stuck now using a Linksys WRT54GC wireless router which doesn't play well with my Macs and iPhones. I just can't get it configured properly for Wifi. When it does work, I get very slow speeds, barely 1MBPS. Normally with the base station, I would get 15 which is normal. I do get 15 when connecting with my ethernet cable.

    Anyone have any suggestions on configuring this router properly to a MB and MBP?
     
  2. applefan289 macrumors 68000

    Joined:
    Aug 20, 2010
    Location:
    USA
  3. hexonxonx thread starter macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #3
    At $179, it will be sometime before I can buy another one.
     
  4. kppolich macrumors 6502

    kppolich

    Joined:
    Nov 28, 2010
    Location:
    Iowa
    #4
    new from 138 used from 89

    i picked up a used one -like new for 90 a few months back and it was actually brand new still wrapped in plastic.
     
  5. hexonxonx thread starter macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #5
    I picked up one on Craigslist just now for $50. Guy said it was a year old and looks as good as new. Got it running and put the Linksys back in the closet where it belongs.
     
  6. Peteman100 macrumors 6502

    Joined:
    Apr 28, 2011
    Location:
    Berkeley, CA
    #6
    Damn nice find! I might have to have to look around Craigslist for myself now....
     

Share This Page