AirPort - Self assigned IP address - no internet!

Discussion in 'macOS' started by beautifuldawn, Feb 7, 2008.

  1. beautifuldawn macrumors newbie

    Feb 7, 2008
    (I hope this thread is in the right section!)

    I just bought a white applemac laptop yesterday and it has all been set up - but the internet won't connect. I have a home network which always worked fine with my microsoft laptop and the AirPort is 'on' - but it says I have a 'self assigned IP address and may not be able to connect to the internet.'
    ... well, I can't! So... what do I do?

    I've tried all the 'assist me' guides on it but it just leads me around in circles - ending with 'this connection error cannot be fixed'.

    Please help me as soon as you can!
  2. ScoobyMcDoo macrumors 65816

    Nov 26, 2007
    Austin, TX
    You running Leopard? Tiger? I assume leopard since you just bought it. When you click on the Airport icon in the menu bar does it have an option to "turn airport on"? If so, do it. One you know it's on, there should be a list of broadcasting wireless networks - do you see yours?

    Also tell us how your wireless router is setup and what model it is.
  3. beautifuldawn thread starter macrumors newbie

    Feb 7, 2008
    I think it's Leopard... and my Airport menu icon is 'on' and there is a tick beside my chosen network, but still no internet.

    I have no idea how my router was set up (someone set it up for me!) but it's a D-link DI-624+ (don't know if that's the right thing to write down - I'm just reading from the box). Errr, it also says at the bottom '802.11g/2.4GHz Wireless. G+ . 54Mbps

    Does that help at all?
  4. richard.mac macrumors 603


    Feb 2, 2007
    51.50024, -0.12662
    allow your router to assign you an IP -> make sure "using DHCP" is selected for Airport in the Network preferences.
  5. beautifuldawn thread starter macrumors newbie

    Feb 7, 2008
    How do I allow my router to assign me an IP? & my thing is already set to DHCP, still no internet, heh!
  6. mheidt macrumors member

    Jun 7, 2005
    call "someone".

    Did he setup the Windows client too?

    If he did it right, he might set a password as well which you might not know either.
  7. beautifuldawn thread starter macrumors newbie

    Feb 7, 2008
    You mean the password to my home network? I know it and have already put it in..

    So I should call the person who set up my router? Is there anything else I can do to fix this? I'm not keen on paying someone to come out if all I need to do is tick a box, heh!
  8. richard.mac macrumors 603


    Feb 2, 2007
    51.50024, -0.12662
    the router should do this automatically. my mac connected to my home network as soon as i typed my WEP password in setup assistant. try rebooting the Mac and the router.
  9. mheidt macrumors member

    Jun 7, 2005
    Which version of Leopard do you have?
    If you don't have 10.5.1, you need to hook up via ethernet first to get the latest patch.

    At least my WLAN didn't work before 10.5.1.
  10. beautifuldawn thread starter macrumors newbie

    Feb 7, 2008

    Is that what the 'self assigned IP address' is? Because it says I have that but then underneath it says this may or may not work and... obviously it's not working right now!

    Um... so are there any settings I can change in network preferences that might allow me to access the internet?
  11. beautifuldawn thread starter macrumors newbie

    Feb 7, 2008
    I think I have version 10.5

    Don't I need a cable to connect to ethernet? I don't have one... :(
  12. mheidt macrumors member

    Jun 7, 2005
    you can try and open up your MAC address filter...
    I'm not sure, if this will help. But my first installation couldn't handle WPA security.

    and selfassigned (a 169-number) just means, that it couldn't connect to the router.

    screenshots of your WLAN/IP settings might help...

    But open up your router first (you still have your windows pc?)
    and reboot your mac.

    And I would buy a cable. it's much cheaper than "someone" :)
  13. AlBDamned macrumors 68030


    Mar 14, 2005
    This is a very annoying problem that's just started happening on my leopard machine.

    What you need to do is go into System preferences> Security>firewall then turn it off to "allow all incoming connections".

    Then turn your airport off.

    Then turn it back on again.

    You should now be able to connect to the web.

    Then you need to go back and turn your firewall back on (very important!).

    Hell knows why this happens but it's yet another crap bug in Leopard.... :rolleyes:

    Literally started happening for no apparent reason after three months.
  14. avenuesalan macrumors newbie

    Feb 9, 2008
    This started happening to me after getting a new wireless router. This is a connectivity problem pure and simple. It has to be a problem of compatibility between the new router and Airport. That self-assigned IP number just means that my wireless airport card is losing connectivity to the router and the router cannot assign it an IP address because it cannot see my airport card or maintain a connection long enought to assign it an internal IP address.

    I can fix it by rebooting. Wonderful! But it is intermittent, comes and goes, and I never had this problem with my old clunky Linksys g router. It only started when I purchased a brand new Netgear WNR3500 router.

    And I have a Windows XP computer on the same network with a Netgear g card, that does not have this problem, so it is the Mac/Airport and Netgear router issue.

    I have a Powerbook less than one year old. Still running Tiger and the Apple Wireless network adapter 802.11 a/b/g/n that came with it. Wireless was perfect on the old linksys g router. Things were going so well, I even have not yet installed Leopard even though I purchased the upgrade when it came out.

    Instead, I buy a new router and boom. Troubles. I was laughing at all the people who installed Leopard, but now I fell into the same trap by buying a new router. Don't buy any technology until it is a year old.

    Frustrating. Right now I have a 25 foot ethernet cable plugging into my laptop because I am sick of screwing around with the intermittent loss of wireless connectivity.

    I may reinstall my old Linksys router and see what happens. I may also cut my wireless security back from WPA2 to either WEP or nothing to see if this intermittent loss of connectivity relates to the security mode.

    My MTU is 1500, which is default on the new router. I am not going to mess with that.
  15. AlBDamned macrumors 68030


    Mar 14, 2005
    I think it's a Leopard bug as opposed to a router problem. Ergo, nothing you do to your router will fix it, it's a problem in Leopard that needs to be fixed.
  16. avenuesalan macrumors newbie

    Feb 9, 2008
    Can't Be a Leopard Prob cuz I dont' have Leopard

    As I mentioned in my first post, I am having this problem with Tiger. I have not yet installed the Leopard update that I purchased. And to correct my original post, I have a MacBook Pro, not a Powerbook. Anyway, my problems started after purchasing a brand new Netgear router. I have now reinstalled my old Linksys and so far, no more problems, but I will keep you posted. If the old Linksys router continues to work, then it must be a router issue and not Leopard, because again, I do not have Leopard.
  17. AlBDamned macrumors 68030


    Mar 14, 2005
    Well in your case it might be a different problem, but the OP's first post was about Leopard and there are several threads on the net in various forums about a Leopard specific problem....

    However, I also have this problem with a Netgear router, but I also have it at work with the Airport Extreme, so I'm pretty sure it's an OS X problem and maybe one relating to a recent OS X update that went into recent Tiger and Leopard updates.
  18. hob macrumors 68020


    Oct 4, 2003
    London, UK
    The firewall thing really helped me out here! I don't have OS X firewall running, but I did have Little Snitch and PeerGuardian running. This was stopping me from getting a DHCP address at university - at home I have a static one.

    So you might want to try either:

    a. Checking for programs like Little Snitch and PeerGuardian
    b. set up a static IP address. Best way to do this would be to write down all of your Windows IP address details (IP Address, Subnet Mask, Gateway/Router, and DNS servers) and then transfer the same information into System Preferences->Network->Advanced (and choose set IPv4 Manually). Make sure you +1 onto the end of the the IP address from the other machine. So if your IP address on your Windows laptop is, make your Mac's IP address

    Good luck! PM me if you need any more help :)
  19. avenuesalan macrumors newbie

    Feb 9, 2008
    Router Report

    AIBDamned, what you say makes sense, because even though I have not yet upgraded to Leopard, I have continued to install all the Apple updates they send me, which I am sure include all the Leopard stuff. So let me tell you the results of my re-installing an older router and then ask if you have any recommendations on finding a compatible router.

    As I mentioned in my earliest post, I had an old LinkSys WRT54G router when I bought my new MacBook Pro last year and it has always worked fine on my mixed Windows & Mac home LAN. Then I upgraded to a Netgear WNR3500 which was released only a month ago and have had nothing but problems. So last night I re-installed my old Linksys router and downloaded, uploaded, and transfered files and it was all perfect. I have been monitoring my send errors and recvd errors in Network Utilities and was getting thousands of errors using the new Netgear router, but after I reinstalled the old clunky, slower Linksys G router, I have not had a single new error!! And no intermittent connection loss.

    Of course the old router can only sustain WEP security, not the WPA2 that I was using on the old router, and it is very slow on big local area file transfers. So I would like to find a newer faster router that actually works with Leopard. A small request I would think.

    So now, what do I do? Should I return my new Netgear Router to Best Buy and try to get my $150 back, even though I have lost my receipt? And if so, do you have any recommendation as to what I should buy, because I really do not want to continue using my old Linksys G router. Should I just go to the Apple Store and buy that Airport Extreme Router with the USB port for the printer (none of the Windows routers seem to have a USB port). Will that Apple router work fine with my mixed network of Apple and Windows computers?

    Or should I hang on to my Netgear WNR3500 and try it again in a few months, hoping by then that there are firmware updates or further Leopard patches? It seems so strange that I am punished for buying the latest and greatest technology!

    Also, would you recommend I go ahead and install my Leopard upgrade?
  20. funkybrenner macrumors newbie

    Feb 11, 2008
    my symptoms...

    From all that I've read online, there are dozens of different self-assigned IP problems. I thought I'd share with you what I've learned, at least about my
    "strain" of this problem.

    80% of the time, I have a self-assigned IP on my desktop (iMac G5). This is ever since I upgraded to 10.5.1. Sometimes, normally twice a day, I can restart the computer, and then I'll have internet for two to three hours before it dies again. Upgrading to 10.5.2 unfortunately did nothing to help me.

    What I've learned is that I don't think it has anything to do with routers. At home, I am connected to Verizon FiOS through one of their standard wireless routers. This is where I initially upgraded to 10.5.1 and the problem started. At school, I am connected to Time Warner Cable via my AirPort Extreme (purchased Summer '07, the model before gigabit ethernet). I get the same problem in both places... this leads me to believe it doesn't have anything to do with an Apple router vs. a 3rd party router.

    This may be obvious, but communications on the local network (Back to my Mac for instance) work fine, even when I'm getting the Self-Assigned IP error on my desktop.

    The guys at AppleCare told me to do most of the things I've read suggested online... (trash keychain entries, renew DHCP etc) to little avail. My next option, as far as my case with tech support goes, is an archive/erase and install... which I am avoiding (at first I was waiting for 10.5.2, but now I see it doesn't fix my problem). So I guess that's my only option... unless someone can shed new light on this.

    Hope my input helps!
  21. SJR macrumors newbie


    Nov 29, 2007
    Nottingham, UK
    Well, so much for 10.5.2 fixing this problem.

    Many of us have been waiting to see if Apple have been listening to our complaints and it would appear they haven't!

    I am STILL unable to connect to my Corporate wireless network at work - same problem that has been reported since the bug was introduced in 10.4.10 - MacBook Pro connects to the wireless network, but fails to obtain an IP address from the DHCP server (hence the self-assigned IP address)...

    Come on Apple - GET IT SORTED - let's have 10.5.3 out quickly with a fix for this widely reported bug... :(
  22. sandylp macrumors regular


    Jul 10, 2004
    San Francisco Bay Area

    The guys at AppleCare told me to do most of the things I've read suggested online... (trash keychain entries, renew DHCP etc) to little avail. My next option, as far as my case with tech support goes, is an archive/erase and install... which I am avoiding (at first I was waiting for 10.5.2, but now I see it doesn't fix my problem). So I guess that's my only option... unless someone can shed new light on this.
    I have the same error on one of the ethernet ports on my new MP. (Maybe this is why there's 2.) It says "Ethernet 1 has a self assigned ip address and may not be able to connect." Since I had just received the computer, Apple suggested that I reinstall Leopard, which I did, but it didn't help. Still have the same message on that port. I'll probably never need that port, but I'm just curious as to what could be causing it. :confused:
  23. omegabane macrumors newbie

    Feb 13, 2008
    Experiencing same problem

    I am experiencing this same issue on one of the three wireless networks I connect to.

    My Airport connection was working with no problems on Monday night at work. At one point I had to disconnect from the wireless network to connect to a wireless peripheral (a Panasonic LCD projector). Only five minutes later when I was done with the LCD projector, I connected back to the wireless network and... nothing. I had full signal strength but a self-assigned IP address. I can connect to the exact same network via ethernet. Manual IP configuration does not work.

    I am able to connect without any problem at all at home and at the University Library, but just not at work.

    It seems from this thread that this is a common Leopard problem, although I have found other threads online where people report a similar issue is 10.3.x.

    I'm running 10.5.1 on a MacBook Pro3,1
  24. THX1139 macrumors 68000


    Mar 4, 2006
    Count me in as another one with the same problem. I had a perfect connection to the internet then I decided to move the wireless into my office. All I did was unplug and plug it back into the modem and it stopped working. I can see the AEBS and can log into it, I just can't get internet. My base station is flashing amber instead of glowing green. I tried a hard reset and that didn't work. If I take the ethernet cable and plug it directly into my Mac, I get online. I went to the Apple store and they issued me a replacement (won't be here until next week). It's the THIRD Airport Base station in 7 months! The last one did the same thing... just started flashing amber and stopped connecting to the internet. When I told the guy at Apple what happened, he was mystified and tried to blame my modem or house wiring. He was really blown away that I was on my 3rd AEBS because he said they rarely get any back... and I'm on my 3rd one. I hope this one doesn't die or they will think I'm using it for a hockey puck.
  25. margoesmattress macrumors newbie

    Feb 23, 2008
    Linksys and Mac-self assigned problem solved, finally!!!

    I just completed a post to an old thread "Linksys WRT54G and MACs" I am pasting in here just in case it might be helpful. I do know the frustration!!!!

    I am writing because I just got my wireless connection to the internet re-established..Yeh!!! It had been working for months, then stopped working (I am sure it was a result of trying to get on a closed network at my parents house, not knowing what I was doing....). Anyway, we have a PC laptop and a MacBook(dual platform). Everytime I tried to get on the internet, my computer said that it had a self-assigned IP address... I could connect when using the Windows side of my computer, but not when using the Mac side. I had talked to Apple, and Linksys before today. Each company, after a few feeble attempts, saying that it could not help me because they did not support the other's product. Today, I tried again. First to Apple, they went through a few steps with me(the same ones often sited here..) and it didn't work. Because, I was able to connect to a neighbors open (Linksys router) network, Apple said it was something with my router that was not sending the correct info. Talk to Linksys, I was told. So I called Linksys, this time I had someone that really did help. Simply, I had to put a '$' sign before my network password!!!! This time it worked! Linksys said that Apple should have known that the '$' sign was needed. Out of three tech, not one apple tech even mentioned it. In case you try it and it doesn't work, Apple had suggested that I reconfigure my router as an open network and once it was working, set it up as a closed network. I hope this helps. I was completely frustrated with this problem and found no help from any product websites. Unfortunately, sometimes it takes talking to more than one tech representative to get the right information.

Share This Page