All my cydia sources gone?!

Discussion in 'Jailbreaks and iOS Hacks' started by riceboy927, Dec 31, 2010.

  1. riceboy927 macrumors newbie

    Aug 15, 2010
    So I was downloading something off cydia and it seemed to be working fine, I left my phone alone to get some water and then next thing I know I come back and it seemed to be turned off. I figured it simply had crashed and would boot into safe mode. However when I opened cydia all my sources were gone. ALL OF THEM :(, I googled this but the solutions didn't seem to help, or I did them wrong. Anyone have any idea how to fix this?
  2. Krafty macrumors 601


    Dec 31, 2007
    La La Land
    Attempt to add a source. This has happened to me with biteSMS beta. It prompt me to remove the corrupt .deb file, and the sources revived.
  3. riceboy927 thread starter macrumors newbie

    Aug 15, 2010
    thank you so much!!
  4. ocs1024 macrumors newbie

    Jan 18, 2011
    what source did you add to revive all of them?
  5. bella92108 macrumors 68000

    Mar 1, 2006
    I'm having the same issue, when I launched cydia it shows no sources but I SSH'd and it says theyre all there. But I tried to add a source and it fails to add because of a bitesms repo error even after I removed the bitesms repo via ssh. Any ideas? Cydia just crashes out :-(
  6. TJone macrumors 6502a

    Aug 2, 2010
    It may be some unrelated network issue with Cydia. See if it works tomorrow. Something similar happened to me with all sources and all packages disappeared from Cydia but it fixed itself after a few hours - when I opened Cydia again it worked.
  7. LEXS1411 macrumors 65816


    Sep 22, 2007
    FIX: If your Cydia is "blank" just go to Changes, click Refresh, and then restart Cydia
  8. bella92108, Jan 30, 2011
    Last edited: Jan 31, 2011

    bella92108 macrumors 68000

    Mar 1, 2006
    It's not that simple or people wouldn't ask. When that "refreshes" it doesn't reload anything, because the Sources list is empty... without sources = no list under changes.

    UPDATE: Still not working 4 days later... anyone else have suggestions? When I do a refresh I get errors galore about and the old bitsms repo, but yet it's not listed in repos ... is there a way to just go back to only the default Cydia repos and I can just add my extras again?
  9. primalpolymath macrumors newbie

    Feb 22, 2011
    I had this problem, I dug around and found a cydia.log in var/tmp that read
    "dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem."

    ssh into phone or use mobileterminal, run dpkg --configure -a, reboot, all better.:D
  10. barracudas macrumors newbie

    Jan 24, 2012
    Locate and delete the following two files:

    Remove anything in this folder. Leave the folder, just make sure it is empty:
  11. Rockboy5570 macrumors newbie

    Apr 10, 2013

Share This Page