Animations laggy and choppy

Discussion in 'OS X Yosemite (10.10)' started by baryon, Oct 27, 2014.

  1. baryon macrumors 68040


    Oct 3, 2009
    I'm running on a high end late 2013 Retina MBP with 16 GB RAM and the i7 CPU with discreet graphics.

    Animations such as opening tabs in Safari, switching spaces left/right, activating Mission Control, showing desktop, etc... are all lagging a little bit and being choppy. They were super responsive and smooth in Mavericks.

    I'd honestly take an outdated looking GUI over choppy animations any day. Not a big deal, but it just feel slow and unresponsive, when Apple is all about making things responsive. I'd rather they make the GUI look like Windows 95 but make the animations smooth than make it look modern and unresponsive.

    Anyone else seeing this, and finding it irritating? Apple has always done this (Snow Leopard made animations choppy and so did Lion), it's like they fix it in one release then break it in the next...

    Any way to fix this? I've noticed that animations are butter smooth right after boot, and they suddenly become choppy at some point... tried disabling transparency to no avail. Are there background apps known to cause this? I usually have Skype, Dropbox, Mail, Safari and iTunes open all the time.
  2. n-evo macrumors 65816


    Aug 9, 2013
    It's a perpetual circle with Apple: things that worked in one release are broken in the next, are fixed again and end up being broken once more.

    It's the same with Mail and hiding its main window upon opening at login for me:
    - Mac OS X Panter: Works
    - Mac OS X Tiger - Leopard: Broken
    - Mac OS X Snow Leopard - OS X Mavericks: Works
    - OS X Yosemite: Broken

    Annoying as hell.
  3. kittencounter macrumors member

    Mar 22, 2013
    If you reduce transparency it will be smooth again. For butter smooth performance it's recommend to run in "Best for Retina" scaling. But seriously...who the hell does that :rolleyes:
  4. emporiky macrumors regular

    Mar 27, 2014
    Yes, the lag is there and it's quite annoying :(
  5. pruppert macrumors 6502


    Jan 30, 2008
    Yep, I have noticed the same thing. It seems to help if you disable transparency in system preferences and also reduce the number of desktop spaces to as few as possible. Hopefully Apple can remedy this in a future update.
  6. Abba1 macrumors regular

    Aug 6, 2014
    I have it too, but only in a limited number of (Apple) Apps. I thought something was wrong with my Mac, but obviously it is a Yosemite problem.
  7. smellalot macrumors 6502

    Dec 6, 2011
    I do on my 13" model as there is really no benefit in squeezing more than one window onto the small screen. I suppose most people run it in best for retina mode.
  8. pruppert macrumors 6502


    Jan 30, 2008
    I've noticed significant improvement after a restart.
  9. baryon thread starter macrumors 68040


    Oct 3, 2009
    I've reduced transparency and it didn't change a thing. I also run in Best for Retina, since as a retoucher, it's important that there is no interpolation and lost pixels on the images I work on in Photoshop. 100% needs to be 100%. I'd think most people who do image work on their machine will use that setting, but if you only use your computer for web browsing, you would be fine with any other setting as you won't be counting pixels.

    Yes me too, but the problem seems to return after some time. It looks like some app or operation causes it to start lagging, and then it just stays that way until a restart.
  10. Daysight macrumors regular

    Dec 15, 2011
    Now I've got this problem since upgrading to Yosemite. Seemed to be OK at first I think but now Laggy desktop switching, slow app starts, and the yosemite drop down menus don't stick unless I hold down the mouse button and release it on the menu item I want. Fixes on reboot but reverts in a day. Too bad. My mid-2011 Mac ”just worked" since I got it and through prior OS upgrades. Sigh. Here I go again. Diagnostics time.
  11. Abba1 macrumors regular

    Aug 6, 2014
    Did a clean install and animations no longer choppy.
  12. sickducker macrumors member

    Sep 1, 2014
    Me to, but than it gets choppy again after a day use. I think this is a memory bug.
  13. redheeler macrumors 603


    Oct 17, 2014
    I do that. I hate running in the higher than native HiDPI resolutions because they are scaled down to fit on the display and bring the severe pixel-level quality loss associated with that. I also don't choose the native non-HiDPI resolution because it makes things on the screen too small (although I do occasionally choose that on my rMBP when I really need more space).

Share This Page