Another Mac Pro 4,1 to 5,1 EFI Update Problem

Discussion in 'Mac Pro' started by jmurph21, May 7, 2015.

  1. Earl Urley, Oct 19, 2017
    Last edited: Oct 19, 2017

    Earl Urley macrumors regular

    Joined:
    Nov 10, 2014
    #51
    I recently inherited an 8-core 4,1, slapped in a blank, reformatted hard drive, installed Mountain Lion (10.8.5) from a USB key, and was able to flash it with no problems. Identified as a 5,1 in ML's System Information.

    Just had to make sure I had the EFIUpdate mounted and was connected to the Internet. Also lucked out in that it seems to have an EVGA 680 flashed with an EFI ROM, or it could be one of the rare actual EVGA 680 Mac cards that were sold at retail. Sheesh, two PCI power cords? Didn't think it needed that much juice.

    Right after that, I booted to a High Sierra USB installer. Ran Disk Utility, wiped the drive blank, then ran the HS installer. It told me it would have to do a firmware update (yet again!) so I followed the onscreen instructions, shut it down, held the power button.. watched the DVD drive open, watched the firmware update thermometer.

    A minute or so later, the machine rebooted again and happily installed High Sierra with Supplemental Update. I looked at the log and it didn't do any HFS to APFS, the machine booted from an HFS+ volume as usual, as it should if it's a platter hard drive.

    I thought it was kind of weird that it literally ran the firmware update from a wiped drive, probably the firmware updater is written onto the recovery partition or something?

    HS actually boots fairly quickly on a decent platter hard drive if you have decent RAM (12 GB RAM in triple interlace config, 500 GB WD drive @7200 RPM, 16MB cache)

    Thinking about getting a Lycom DT120 and a Samsung 960 EVO and see if that will boot now..
     
  2. smcimarty macrumors newbie

    Joined:
    Oct 16, 2017
    #52
    First thanks for responding,
    I did the firmware update/upgrade from 4.1 to 5.1. It will boot but will not restart, when ever I try to start or restart the first time it tries it just hangs and the fans are on and the power light flashes. I can then hold the power button to shut down and then after it shuts down I can press the power button and it will start.
    So i'm not locked out it just will not start the first time when trying to start or restart.

    I may also have an issue will video now, the last time I got it to start the video was not working, I'm not that concerned about that as much because I mainly use it as a headless server and use Apple Remote Desktop to control when I need to.

    I hope I explained myself well, I don't do alot on the forums.

    Thanks again for any insite you can give me.
     
  3. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #53
    Still can’t understand what you mean.

    1) you did the firmware update. Is that mean the update was successful? Or you attempted to do it, but fail?

    2) what do you mean will boot but not start? You can hear the “don” sound but computer hang with black screen?

    3) you mentioned power light flashing, how it flash? (It is an error indication light in some specific scenario)

    4) you mean every time you have this “no start” issue, you can always force shutdown, then the computer can boot all the way to desktop?

    5) what is your computer config? (especially important to know which GPU you are using)

    Anyway, your firmware is good, no matter you are still with 4,1 firmware or 5,1.

    It sounds like your PSU (or some other hardware. e.g. GPU) is failing, which cause the “no start” issue.

    AFAIK, when we say “boot”, it usually means the computer can be started up normally. If we want to descript “power up but not working”, use the term “power up” is better than “boot”. Because “boot” basically means “the whole start up process”. It doesn’t quite make sense that “can boot but cannot start”.
     
  4. Squuiid macrumors 65816

    Squuiid

    Joined:
    Oct 31, 2006
    #54
    A 960 EVO won’t work.
    Your options are AHCI drives only, so:
    SM951 AHCI edition
    XP941
    HyperX Predator

    The updated 5,1 firmware only enabled APFS boot, not NVMe unfortunately.
     
  5. smcimarty macrumors newbie

    Joined:
    Oct 16, 2017
    #55
    Thanks you and I do appreciate your patience,

    1). Yes I did the firmware update and it seems to be successful. It now says 5.1 and the boot rom is MP51.007F.B03

    2). I can get it to boot up in 10.12 and everything seems to be working. The issue is when I go to restart (Apple menu - Restart) it will not. That is when I get the flashing power light.

    3). Not sure if there is any specific scenario it just flashes on-off with fans on ( but I do not think they are on hight)
    4). Yes, when I get the flashing power light I can then force shutdown and it will boot to the desktop.

    5). See attached
    Screen Shot 2017-10-20 at 9.44.03 AM.png
    Screen Shot 2017-10-20 at 9.44.20 AM.png
    Screen Shot 2017-10-20 at 9.44.39 AM.png

    I have read that the video card could cause issues but I can't find anything on the card I have so not sure if that could be the issue.

    Thanks again for your help.
     
  6. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #56
    Ok, now is much more clear. It’s nothing to do with the firmware, and you only have one problem, which is you can’t perform a warm restart.

    For every warm restart, it’s basically “shutdown -> POST (the “don” sound) -> boot to desktop again”. Does your computer hang before or after POST?
     
  7. smcimarty macrumors newbie

    Joined:
    Oct 16, 2017
    #57
    Ok, tries the warm restart and it seems that it's the shutdown. It seems to start flashing almost immediately after i click the restart.
     
  8. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #58
    So you have a shutdown hang, which is quite a common bug in MacOS. Good news is most likely your Mac is completely fine. It's just the OS is buggy. By the way, how long you wait for it to "shutdown"?
     
  9. smcimarty macrumors newbie

    Joined:
    Oct 16, 2017
    #59
    I have waited about 5 minutes at times just to see if it would finish.

    So you think it's more of an OS bug, so I should try and reinstall the os?

    Once I got the firmware updated I installed 10.12 on a SSD but I did it from a USB that I have used before on a Mac mini that works fine.

    Would there be a better place to download 10.12 to install? Should start with an older OS and upgrade to 10.12?

    Thx
     
  10. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #60
    You can just boot into recovery partiton to format the hard drive and perform a clean install at there.
     
  11. JedNZ macrumors 6502

    JedNZ

    Joined:
    Dec 6, 2015
    Location:
    Deep South
    #61
    I can wait up to 40 minutes for a restart/shutdown to occur on my cMP (see specs in my sig which includes 960 EVO). I can hear the spinners chugging away, but I leave it to do it's thing. I wouldn't recommend you interrupt this unless someone confirms it's safe to do it.

    As for the 960 EVO, you can use it like I do for data (not boot) - I've got my one paired in a Fusion Drive (FD) with a 2TB spinner and it works well. I haven't updated to HS yet as aren't sure if the 960 EVO will be seen natively with the FD or if I have to create the NMVe kext (like I currently have to do when Sierra is updated).

    On an aside, not sure if HS would try and convert my 960 EVO to the new APFS and thus kill my FD if I upgrade to HS. A few questions looming there for me, and no one can confirm for certain what will happen as I appear to have a fairly unique setup.
     
  12. PowerMac G4 MDD, Oct 21, 2017
    Last edited: Oct 21, 2017

    PowerMac G4 MDD macrumors 68000

    PowerMac G4 MDD

    Joined:
    Jul 13, 2014
    Location:
    At the intersection of Conch and Coral.
    #62

    I would try doing the firmware flash again, even if you've already tried it. Firstly, you NEED a genuine Mac Pro card, be it a GT 120 or whatever. Secondly, you need to disable SIP prior to the flashing process, if you haven't done so already. (And, of course, you need a genuine card to both disable SIP *and* upgrade the firmware.)

    If that doesn't work, do the same procedure again, yet use an entirely different hard drive [with a clean installation of OSX on it]. I have a second 4,1 which would reboot and skip the firmware flashing procedure every time. I tried using a different HDD as my boot drive, and it suddenly worked. I am not sure why it had something to do with the HDD, but I guess it did.
    --- Post Merged, Oct 21, 2017 ---

    HS currently does not work with Fusion drives, nor does APFS work on HDDs. A Mac with an HDD could upgrade to HS, but the file system will not be converted to APFS. As for Fusion drives, I think they'll simply become destroyed by HS, for the time-being.

    All SSDs are automatically converted, and I believe that blades on PCIe adapters should also be converted and installed to just fine. I, however, take the precautionary step of removing all other disks BEFORE I upgrade. I don't want my Windows SSD or backup HDDs to get touched.

    BTW, for any firmware update (such as the one included for 5,1 or 4,1-->5,1 conversions), you have to use a genuine Mac card - be it the stock card or some sort of Mac-Edition card. I keep my Mac Pro's stock GT 120 off to the side, in case I need to do something like this.
     
  13. devon807 macrumors 6502

    devon807

    Joined:
    Dec 31, 2014
    Location:
    Virginia
    #63
    Best bet right now would probably be a HyperX Predator. SM951's are overpriced right now for some reason.
     
  14. Angelus macrumors 6502

    Joined:
    Apr 19, 2002
    Location:
    New Zealand
    #64

    Hi there,

    I've been away from the forum for a while whilst studying for exams. I downloaded the High Sierra updater and was planning to run it next week but now you've got me rethinking that plan. Of note I do have a native GPU to apply the firmware update for High Sierra.

    I've got a 4.1 2009 Mac Pro flashed to 5.1. Currently has Sierra with a DIY Fusion drive (Evo 840 256Gb and 3TB HDD). So are you saying that the High Sierra update will break my DIY Fusion drive?
     
  15. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #65
    Or a properly flashed card like the one's sold by MVC. I updated the firmware, twice, on my cMP 5,1 with an MVC flashed Gigabyte G1 Gaming GTX 1080.

    Lou
     
  16. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #66
    Some extra info

    1) if he run the firmware updater AGAIN, he will downgrade the firmware back to 4,1, but NOT re-do the 5,1 firmware installation. If he want to install a solid 5,1 firmware again. He better run the High Sierra installer, which will install the most up to date 5,1 firmware for him.

    2) Genuine Mac card is not required. All he need is just a Mac EFI GPU, self flashed or direct from Apple doesn’t really matter.
     
  17. DPUser macrumors 6502a

    Joined:
    Jan 17, 2012
    #67
    I have had situations where USB connections caused lengthy boot times and failure to boot. Tested by removing USB devices, then booting. Rectified with a new powered USB hub.
     
  18. PowerMac G4 MDD macrumors 68000

    PowerMac G4 MDD

    Joined:
    Jul 13, 2014
    Location:
    At the intersection of Conch and Coral.
    #68

    Yeah, that's true; a flashed one will work. He either needs a flashed one or genuine one - nothing else.
    --- Post Merged, Oct 22, 2017 ---
    Make sure you have a quality hub. I had a 10-port Chinese hub which died and apparently took two USB ports with it, on my 1,1 Mac Pro.
    --- Post Merged, Oct 22, 2017 ---

    As far as I know, 'Fusion' drives don't work under High Sierra. Currently, no hard disk can be converted to the new file system; they remain as HFS. That being said, I am unsure as to whether it will break it or simply not give either drive APFS. I'd look up the issue and read further. I personally haven't looked into it much, since I don't run hybrid drives.
     
  19. smcimarty macrumors newbie

    Joined:
    Oct 16, 2017
    #69
    Well I have tried a couple of thing and still no luck.

    First tried to reinstall 10.12 with no luck. Tried it from the recovery image and from a USB neither one would install. I think mostly because it will not do warm restart, again if I use the shutdown command it will Boot just fine.

    So then I switched HD the old drive that had 10.11 and tried to downgrade the firmware with no luck. It creates the RamDisk, I shutdown and restart holding the power button until the tone and nothing still 5.1.

    Anyone have any other ideas?

    Thanks
    --- Post Merged, Oct 23, 2017 ---
    And regardless of what I start from 10.12 SSD 10.12 USB or 10.11 HD it will not do a warm restart.
    --- Post Merged, Oct 23, 2017 ---
    Would a NVIDIA GeForce 7300 GT be a card I could use?
    Will it help at this point since I can not get it to downgrade?
     
  20. Pizzaman69 macrumors newbie

    Pizzaman69

    Joined:
    Jun 12, 2017
    #70
    BE VERY CAUTIOUS WHEN DEALING WITH MACVIDCARDS!
    I bought a GTX980 off him last fall. Died after 2 weeks. After 6 months of trying to get him to help address the issue, I finally took it into a local shop to get tested and they confirmed it was shot. MVC's finally provided me with directions on how to return it for a replacement, which I did. They then confirmed on their end that the card was bad and asked me for my address so they could send the replacement. I gave it to them. After not seeing anything for a month, I contacted him again for a status update. He replied with 'Is this your address?' but the address he had written in the email was not the address I had provided him with. I replied again with my address, including the original message I had sent, and since them I have heard ZERO from him. It's now been 4 months and he has ignored every email I have sent over that time. I have tried replying to his messages and sending new messages through his contact for, but absolutely nothing back. So at this point it looks like he sold me a bad card, cost me further money to return the old one and kept my original USD600. BE VERY CAUTIOUS WHEN DEALING WITH MACVIDCARDS!
     

Share This Page