App Store crash on PURCHASE after jailbreak?? (RESOLVED)

Discussion in 'Jailbreaks and iOS Hacks' started by GunBlazerX, Aug 3, 2010.

  1. GunBlazerX macrumors member

    Joined:
    Aug 3, 2010
    #1
    I have searched far and wide and I cannot understand why it seems this is only happening to me.

    Long story short, after multiple attempts of the following:

    1.Freshly restored and synced phone
    2.jailbreakme then phone reboot
    3.sb settings
    4. five icon dock
    5.openssh
    6. bitesms
    7. mywi

    ISSUE: Somewhere between steps 3 and 7 inclusive, app store crashes completely out to springboard when I am in the apple app store app and I try to purchase.

    ie:

    I am at an app with the button [2.99] I tap once, [2.99] ----> [INSTALL] I tap the green shiny install button, theres about a 1 second hang and the app crashes out and nothing installs and no purchase is made.

    Does anyone know what is causing this? This is a serious problem with my phone that I have recreated multiple times. I have ensured that I can purchase apps before jailbreakme and shortly after jailbreakme too.

    Note: Doesn't matter if app is free or priced its always the same crash.
     
  2. Mademan12321 macrumors 6502

    Joined:
    Jun 29, 2009
    #2
    Not sure which one it could be as I have GV, My3g, Rock, and Five dock and none have crashed on me. Make sure that all the apps compatible with IOS 4. My friend had the same issue with an old version of MyWI that cause it to freeze then crash.
     
  3. GunBlazerX thread starter macrumors member

    Joined:
    Aug 3, 2010
    #3
    Please re-read my post as your answer did not even relate to my problem nor did you say anything I didn't already know. :(
     
  4. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #4
    I was going to help until I noticed you mentioned Installous, so I reported this thread instead.

    One more question before the thread gets deleted.....Since you use Installous, why are you buying any applications from the App Store, shouldn't you be stealing them?
     
  5. GunBlazerX thread starter macrumors member

    Joined:
    Aug 3, 2010
    #5
    Ummm because I do buy apps and alot of them? I think you don't realize that there are actually a variety of legitimate uses especially in my case where I can no longer even buy apps from the app store. And believe me, right now I am trying to get my money to the hands of some devs otherwise I wouldn't be asking for help on this issue.

    Another thing is I have lost my ability to purchase apps even before I had installous. So you can just stop talking about it completely.

    Does anyone else have any solution or experiences on this problem I have?
     
  6. chargit macrumors 6502a

    chargit

    Joined:
    Jan 17, 2010
    Location:
    Evansville, In
    #6
    well I have the same issue as you and it started yesterday. I cant even update the apps. I am on a 3gs JB with spirit with 3.1.3 and NO installus. I think it has something to do with the app store.
     
  7. thep33t macrumors regular

    Joined:
    Jun 18, 2009
    #7
    app store crashing, instaluolus?

    That's your issue, sounds like the appsync, or whatever the current version installuolus installs crashes the real app store.

    Try undoing the patch, and it might work...
     
  8. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #8
    My answer may no be of too much use for you, but I think you need to look deeper for a reason, maybe app or something you did that you haven't mentioned, I got all the same app you are running and I got no issues.

    To test it i just went to app store and download brain trainer (#3 on top free apps), i got no issue, it downloaded and run real fast.

    I did exactly this...i got a few extras..
    1.Freshly restored and synced phone
    2.jailbreakme then phone reboot
    3.sb settings
    4. five icon dock
    5.openssh
    6. bitesms
    7. mywi
    8. Extras: GPSphone, backgrounder, iFile, winterboard.

    no issues.
     
  9. iphonedude123 macrumors member

    Joined:
    Aug 2, 2010
    #9
    The thread didn't get deleted.

    Owned.
     
  10. tempusfugit macrumors 65816

    Joined:
    May 21, 2009
    Location:
    Chicago
    #10

    Nice soapbox, how's the weather up there?
     
  11. illutionz macrumors 65816

    Joined:
    Oct 2, 2007
    Location:
    Rhode Island
    #11
    I have similar setup with you and I managed to get this free NAMCO Compilation app... It's downloading now
     
  12. TuneWolf macrumors newbie

    Joined:
    Aug 4, 2010
    #12
    Same issue

    I am having the same exact issue on my iPhone 4 4.0.1. App Store crashes whenever trying to install or purchase, however, updates seem to work oddly. Without this fixed, to me at least, the jailbreak is worthless.:mad:
     
  13. Telecacher macrumors member

    Joined:
    Jun 21, 2010
    #13
    I was having this issue (App Store crashing to springboard after clicking Install to download an app) and resolved it. In my case, I was keeping App Store in the SBSettings dock. Removed it from there, now problem is gone and App Store is downloading again.
     
  14. organsoup macrumors member

    Joined:
    Jul 10, 2009
    #14
    This was my issue as well. Took app store out of the sbsettings dock and no longer have the issue. It worked with 4.0 on my old 3G but not 4.0.1 on my IP4
     
  15. kamce macrumors newbie

    Joined:
    Aug 4, 2010
    #15
    Thanks for the tip on removing the app store from the sbsettings dock. This solved my problem with the app store crash as well.
     
  16. Cbza macrumors newbie

    Joined:
    Aug 4, 2010
    #16
    I can CONFIRM that this works: I had AppStore in a categories grouping (not SBSetting dock), and I had this issue. Was about to uninstall cydia apps one-by-one to diagnose when I found this thread. Registered JUST to respond.
    Worth noting: I've always had appstore in a categories group in the past, first time it's given any trouble. Phew - thought Apple had found a way to lock us out! I happily pay for apps, so that would have hurt. Will now play around a bit to see where I can safely put appstore.
     
  17. Cbza macrumors newbie

    Joined:
    Aug 4, 2010
    #17
    PS: anyone else experiencing the YouTube bug: YouTube app is fine, but YT vids in web pages and RSS readers are blank rather than showing first screen, and cannot be clicked to open in quicktime player. Annoying, but the only JB issue I have at present and I've gone balls-to-the-wall on Cydia apps!

    Update: Same issue!!! Taking YT out of a folder sorts this out.
    Wow, I bet the camera issue (would not open shutter) issue I had on my previous 3GS was a similar problem...
     
  18. shotts56 macrumors 6502

    Joined:
    Sep 23, 2008
    Location:
    Scotland
    #18
    I had a similar issue, but I resolved it by running the "Run diagnostics" option on itunes. I've talked about it on the other similar thread which is running.
     
  19. GunBlazerX thread starter macrumors member

    Joined:
    Aug 3, 2010
    #19

    THANK YOU GUYS for this solution. I appreciate it greatly!! I would've never realized the issue lied within sbsettings.
     
  20. TuneWolf macrumors newbie

    Joined:
    Aug 4, 2010
    #20
    That was my same exact problem. Moved it into one of :apple:'s mini-groups and all is back up and running again.:p
     
  21. jbarresi19 macrumors 6502

    Joined:
    Jul 11, 2010
    #21
    I think that mikepa thinks he owns these boards. Hey mike if u got nothing nice to say why don't you keep ur opinions to urself. U think people will stop using installous cause u don't like it or because their thread gets deleted. Don't get me wrong I don't agree with it but I am not going to act better than anyone else and tell them how to live.
     
  22. Kelerika aprn macrumors newbie

    Joined:
    Aug 15, 2010
    #22
    Thanks...

    Had same issue and did what you suggested...issue resolved! Thanks!
     
  23. murdercitydevil macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #23
    So is there a way to fix the categories bug without reinstalling categories? This just started happening. God I hate when things don't work for NO reason without any provocation.
     
  24. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #24
    Haven't seen one posted. Same issue with the iTunes app--works fine outside a Categories folder, will not work while inside one. I had to reconfigure my setup to make room for those two apps.
     
  25. gillespieza, Dec 13, 2010
    Last edited: Dec 13, 2010

    gillespieza macrumors newbie

    Joined:
    Dec 13, 2010
    #25
    Hiding App Store from the SpringBoard by any method is the culprit

    I had a similar problem. I had reinstalled a few patches and various things to try to get Installous to stop crashing (or rather, to resolve the invalid IPA error I was continually getting), and then App Store would no longer install legitimate apps (free or purchased - yes, I use Installous and still purchase apps. Evaluate first, then buy, thats my MO).

    Anyhoo, after uninstalling Installous, rebooting several times, reinstalling Installous, reinstalling virtually everything I'd installed in Cydia and still having the same problem, I was at my wits' end and was about to rejailbreak (what a pain!), but then I noticed some common themes among the various forum threads.

    I think the key thing here is hiding the App Store icon from the SpringBoard (or default iOS 4 folders), by any method.

    I did not have the App Store in my SBSettings Dock, or toggled in SBSettings, nor was I hiding it using Poof, but I did put it in a custom folder in Categories. Removing it from the custom folder and putting it back on the SpringBoard immediately fixed the AppStore crashing problem. You don't even have to remove it from your custom folders in Categories, actually -- just go into the Hide settings and make sure its not hidden there (they are auto-hidden if you put them in a Category folder).
     

Share This Page